?
Solved

How to configure netflow in Cisco 6513 with SUP 720

Posted on 2007-07-31
6
Medium Priority
?
5,578 Views
Last Modified: 2012-08-13
Hi Experts

We are having two cisco 6513 switches with SUP 720. One with IOS 12.2.17d-SXB11 and other with 12.2(18)SXD7b. I have configured netflow in both the switches. The switch with IOS 12.2.17d-SXB11 is working fine and I am able collect netflow statistics for both in and out where as I am using the same configuration with my other switch with IOS 12.2(18)SXD7b, it can only recive the netflow for in but not for out. So what do you think the problem might be , is the configuration has to be changed ? becoz of other IOS ? please let me know.

Here is config  

SWITCH with IOS 12.2.17d-SXB11 - WORKING for in and out

mpls ldp logging neighbor-changes
mls flow ip interface-full
no mls flow ipv6
mls cef error action freeze
interface Vlan1
no ip address
shutdown
!
interface Vlan50
description NETMANG
ip address 50.0.0.2 255.255.255.0
ip helper-address 10.0.1.100
ip helper-address 10.0.1.101
ip nbar protocol-discovery
ip route-cache flow
standby 52 ip 50.0.0.1
standby 52 timers 5 15
standby 52 preempt
!
interface Vlan100
ip address 10.0.0.54 255.255.248.0
ip directed-broadcast 101
ip nbar protocol-discovery
ip route-cache flow
standby 10 ip 10.0.0.10
standby 10 timers 5 15
standby 10 preempt

ip flow-export source Vlan100
ip flow-export version 5
ip flow-export destination 10.0.0.1 9996
ip flow-export destination 10.0.0.6 9996
ip http server
!
!
logging trap notifications
logging 10.0.0.2
logging 10.0.0.6
logging 10.0.0.5
access-list 101 permit udp host 10.0.0.6 any eq echo
!
snmp-server community xxx RO
snmp-server community xxxr RW
snmp-server ifindex persist

SWITCH with IOS 12.2(18)SXD7b - NOT WORKING (Working only for IN)

mls ip multicast flow-stat-timer 9
mls aging long 128
mls aging normal 32
mls flow ip interface-full
no mls flow ipv6
mls nde sender
mls cef error action freeze

interface Vlan1
no ip address
shutdown
!
interface Vlan50
description NETMANG
ip address 50.0.0.3 255.255.255.0
ip helper-address 10.0.1.100
ip helper-address 10.0.1.101
ip nbar protocol-discovery
ip route-cache flow
standby 52 ip 50.0.0.1
standby 52 timers 5 15
standby 52 priority 50
standby 52 preempt
!
interface Vlan100
ip address 10.0.0.55 255.255.248.0
ip directed-broadcast 101
ip nbar protocol-discovery
ip route-cache flow
standby 10 ip 10.0.0.10
standby 10 timers 5 15
standby 10 priority 50
standby 10 preemp

ip flow-export source Vlan100
ip flow-export version 5
ip flow-export destination 10.0.0.6 9996
ip flow-export destination 10.0.0.1 9996
ip http server

snmp-server community xxx RO
snmp-server community xxx RW
snmp-server ifindex persist

Cheers

0
Comment
Question by:alkhaleej
6 Comments
 
LVL 8

Expert Comment

by:yasirirfan
ID: 19598685
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 19599520
Try adding this on the one that doesn't work under vlan 100
  no ip flow ingress


From Cisco documentation
Cisco IOS Release 12.2(18)SXD or later, the command is automatically remapped to the ip flow-ingress command before it is added to the in the running configuration. Therefore you must use the no ip flow ingress command to disable NetFlow (ingress) accounting on the interface.
0
 
LVL 8

Expert Comment

by:Jim_Coyne
ID: 19600843
add ip flow egress to see all traffic

add ip flow egress and no ip flow ingress to see only in

0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 

Author Comment

by:alkhaleej
ID: 19606429
No use of using no ip flow ingress and the command no ip flow egress is not supported.
0
 
LVL 8

Accepted Solution

by:
yasirirfan earned 2000 total points
ID: 19630091
Hello,
I think that it can be a normal situation, because all traffic goes to the "HSRP selected" GW (in your case sw #1). The sw #2 is receiving only HSRP hello messages from sw #1.

Cheers

Yasir
0
 

Author Comment

by:alkhaleej
ID: 19634029
Hi yasir your are right , since HSRP is working I cannot get the netflow for both in & out in other switch.

Thanks a  lot
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question