Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 668
  • Last Modified:

solaris: howto fix "tftpd daemon.error Protocol not supported"

OS: Solaris
Product: Mostly jumpstart

Just to make sure this is documented as I've seen this error on many forums without a working solution:

tftpd[]: [ID  daemon.error] socket (delay): Protocol not supported

The solution (or workaround) is to:

1) Stop any network client boots.

2) Kill the in.tftpd process on the boot server.

3) Copy /tftpboot to a new dir e.g.:
cp -r /tftpboot /mytftpboot

4) Rename the original /tftpboot e.g.:
mv /tftpboot /tftpboot_orig

5) Update /etc/inetd.conf to  point to the new /mytftpboot dir on the line starting with tftp.

6) Restart inetd <PID>
kill -HUP <PID>

DONE, now you can network boot again.
0
paulqna
Asked:
paulqna
1 Solution
 
NopiusCommented:
paulqna, thank you for info. It's always good to know how to fix new problem.

Also I guess that it is a bug and you should write a message to solaris support.
You can reproduce the problem and you can provide all needed info.
0
 
paulqnaAuthor Commented:
Actually if there are links in that directory I've told to move/rename, these should be adjusted also as the full pathnames will become invalid as the directory they point to does not exist anymore.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now