• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 839
  • Last Modified:

Windows 2003 Small Business remote Web Workplace

My Windows 2003 small business server, web page for remote desktop connections has stopped working. The webpage comes up and allows me to login. The check email piece is working fine. When I click on connect to remote desktops (computers or servers), I click on the computer name and get the remote desktop connection prompt asking me if I want to allow to connect to the computer with the checkbox if I should allow the clipboard to be activated. I click Yes and then I get a slight delay and a vbscript error:
Remote Desktop Disconnected
The client could not connect to the remote computer.  Remote connections might not be enabled or the computer might be too busy to accept new connections.  It is also possible that network problems are preventing your connection.. Please try connecting again later.  If the problem continues to occur, contact your administrator.

I'm logged into the page as the domain administrator account. I put in port 3389 in the router and can connect to the server directly through remote desktop bypassing the webpage.  But using the webpage as administrator I get the same error message no matter what I connect to.  This was working fine when the server was built. We are not sure what caused it to stop working. The last thing that we remember doing was putting on service pack 2 when it showed up in windows updates.  I've also noticed that there is an error in event log for IIS admin helper service is not terminating upon server restart and will not start when I tried to do so manually. I receive an error 1067. Not sure if this is tied to the remote web workplace webpage.  Terminal services is started and running on the server.
0
sraley
Asked:
sraley
  • 4
  • 4
  • 2
  • +2
1 Solution
 
Rob WilliamsCommented:
There are a few issues relating to remote connections after installation of SP2 that you may wish to have a look at:
http://www.lan-2-wan.com/2003-SP2.htm
More specifically possibly this one, though you can still use Remote Desktop:
http://blogs.technet.com/sbs/archive/2007/06/01/unable-to-rdp-rww-into-the-sbs-server-after-applying-sp2.aspx
0
 
sraleyAuthor Commented:
I ran the suggestion netstat -aon | find ":3389"  and received:

TCP 0.0.0.0:3389 0.0.0.0:0 Listening 4416
TCP 192.168.16.2:3389 71.166.139.216:50794 Established 4416

The second line is me connecting directly through RDP to run this command. So we know terminal services is running according to the article.

MS referenced a patch KB936594 so I downloaded and installed it. After installing it indicated I did not have priveledges to reboot the computer through remote desktop.  It appears from the article is that SP2 is causing the issue. Not sure if I should try to remove it and hope that it doesn't cause more damage.
0
 
CircleblueCommented:
gulp.. check your backups first if you are going to remove SP2.  I would stick with trying to resolve the issue rather than uninstall the SP and introduce new ones possibly.  Take a look at the mstsc.exe on the command line with mstsc /?  to see the options.  Maybe that will give you a way to run it on  the command line and bypass the web page.  

Cheers,

Brian
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
Rob WilliamsCommented:
I haven't seen the problem where RWW doesn't work but Remote Desktop does. You have verified the service is running, and also installed the patch. I can only suggest at this point, updating the network adapter's drivers or try the registry changes:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;927695
though I am doubtful either will help.

You are supposed to be able to un-install SP2, and many have reported doing so successfully, but I have to agree with Circleblue, make sure you back up first, it could be risky, especially on SBS.
0
 
DrDave242Commented:
Are you able to establish a direct RDP connection from the server to another machine on your network?
0
 
sraleyAuthor Commented:
Yes I connected from server1 to other servers/desktops via remote desktop.
0
 
DrDave242Commented:
OK, so there's no problem between the server and other machines.  You mentioned that you forwarded port 3389 on your router, and I assume that you've got port 443 forwarded as well, since you can log into the RWW page, but you didn't mention port 4125.  Have you forwarded that one also?
0
 
sraleyAuthor Commented:
4125 was not in the router. I added it and it worked. I'm not sure what happened there. We haven't done anything to the router in a while. Is this a new requirement? Thanks!
0
 
Rob WilliamsCommented:
Do you have UPnP enabled on the router? SBS can configure the router for you automatically, if UPnP is enabled. If that is the case, perhaps SP2 made the change? It is recommended you disable it for security reasons anyway:
http://www.grc.com/unpnp/unpnp.htm
0
 
CircleblueCommented:
SBS and UPnP.. have had no luck with it so far.. using Linksys routers.  
0
 
Rob WilliamsCommented:
Works sometimes, but must say I would hate to depend on it. However, since sraley didn't make any router configuration changes, I thought it might have been due to that. Just looking for a plausible explanation.
0
 
sraleyAuthor Commented:
upnp was enabled so I disabled it.
0
 
wallslxCommented:
I have 4125 forwarded.  I am only having this issue from one of my employee's laptop's and no other station all else are able to pass through RWW.  Her account is able to RWW from a different computer.  She is able to RDP fine.

Any ideas?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now