• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8587
  • Last Modified:

Question about Eclipse/Epic and PadWalker

Hi,

Can someone give me some decent instructions on how to install the PadWalker portion of Epic when using Eclipse?

I have found some examples, but there must be a simple set of steps somewhere that tell how to install/setup PadWalker.

500 points and an "A" grade for the answer...thanks alot!

Andy
0
abrusko
Asked:
abrusko
  • 5
  • 4
1 Solution
 
Adam314Commented:
From the epic page, it looks as though you just need to have padwalker installed, and it will be able to be used by epic.

Do you have it installed?
If not, install using:    perl -MCPAN -e 'install PadWalker'
0
 
abruskoAuthor Commented:
Thank you for the reply...2 questions tho:

Where would the PadWalker files be?  Right now they are all in a folder on my desktop (windows XP).

Also, when I run perl -MCPAN -e 'install PadWalker', I get the following message:

can't find string terminator 'e' anywhere before EOF at -e line 1.
0
 
Adam314Commented:
Are you using ActiveState version of perl?  If so, you'll want to use ppm instead to install the package.
At a prompt:
    ppm install PadWalker

The files will be instealled into one of the lib directories for perl, probably c:\perl\site\lib
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
abruskoAuthor Commented:
Thanks again for the reply.  I'm not sure what version of Perl I'm using...sorry...I'm new to this and trying to get things setup so I can start teaching myself the language.

I ran ppm install PadWalker and got the following results:

C:\Perl>cd bin

C:\Perl\bin>ppm install PadWalker
Downloading ActiveState Package Repository packlist...failed 500 Can't connect t
o ppm4.activestate.com:80 (connect: Unknown error)
Syncing site PPM database with .packlists...done
ppm install failed: Can't find any package that provide PadWalker

C:\Perl\bin>

Any ideas?

Thanks!

0
 
Adam314Commented:
Are you behind a firewall, where you need to use a proxy?
If so:
    You need to set some env vars before running ppm:
    set HTTP_proxy=http://<ProxyServer>:<ProxyPort>
        where ProxyServer is the server name or ip address of your proxy server
        where ProxyPort is the port for your proxy server
    If you need to use a username and password with your proxy server, you also need:
        set HTTP_proxy_user=<UserName>
        set HTTP_proxy_pass=<Password>
    Then try the ppm install PadWalker again.

If not:
    try to ping the server:
        ping ppm4.activestate.com


0
 
abruskoAuthor Commented:
Thanks...Yea...I am behind a firewall.  I have a meeting for the rest of the day, but I will give this a try first thing tomorrow.

Thanks again!
0
 
abruskoAuthor Commented:
Sorry for taking so long to reply...had a meeting all afternoon yesterday.

Ran the set HTTP commands and tried a ping...it worked.  Then I ran the: ppm install PadWalker
Here are the results:

C:\Perl\bin>ping ppm4.activestate.com

Pinging ppm4.activestate.com [209.17.146.133] with 32 bytes of data:

Reply from 209.17.146.133: bytes=32 time=82ms TTL=46
Reply from 209.17.146.133: bytes=32 time=82ms TTL=46
Reply from 209.17.146.133: bytes=32 time=82ms TTL=46
Reply from 209.17.146.133: bytes=32 time=83ms TTL=46

Ping statistics for 209.17.146.133:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 82ms, Maximum = 83ms, Average = 82ms

C:\Perl\bin>ppm install PadWalker
ppm install failed: Can't find any package that provide PadWalker

C:\Perl\bin>

Is PadWalker really necessary...do you think this is this worth pursuing?

Thanks again for your help.
0
 
Adam314Commented:
I've never used it.  But if it helps you, you should install it.

I have these two repositories, and with them, find PadWalker
http://ppm.ActiveState.com/PPM/ppmserver-5.8-windows.plex?urn:/PPM/Server/SQL
http://theoryx5.uwinnipeg.ca/cgi-bin/ppmserver?urn:/PPMServer58

To add repository:
at command prompt:  ppm
at ppm prompt:   rep add AS2 http://ppm.ActiveState.com/PPM/ppmserver-5.8-windows.plex?urn:/PPM/Server/SQL
at ppm prompt:   rep add Uwinn http://theoryx5.uwinnipeg.ca/cgi-bin/ppmserver?urn:/PPMServer58

Then install.

See here for more about ppm:
http://aspn.activestate.com/ASPN/docs/ActivePerl/5.8/faq/ActivePerl-faq2.html
0
 
abruskoAuthor Commented:
OK...I'll poke around and see what I can do.  I might have a few more questions on Eclipse and will probably focus on that for a while.  Thanks again for all the Info.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now