connect to ftp but cannot see any filestructure Mac osx server 10.3.9 FTP

Posted on 2007-07-31
Last Modified: 2013-12-02
I can connect succesfully to my ftp username is authentacating ok, but I cannot see any file structure.

I have succesfully connected from some machines outside of the network thru the web.

I used a PC from outside using the FireFox FTP Client plugin to connect succesfully from the web.  I used the same client and setup internaly to test and it connects but is not able to build any folder structure or see anything on the ftp server.

I am using a Mac OSx server 10.3.9  on a G4 for my ftp server, it is behind my Linksys router and connected through our data T1.  I just switched from one providor to another TDS Metrocom, but this is only an IP change and a DNS change????  Maby not?

Is there any knowen issues here? can anyone please get me back on track?

I am no Expert, so Please experts help.
Question by:marcomnordic
    LVL 6

    Accepted Solution

    Do you have Passive FTP set up in your System Preferences/Network/Configure/Proxies?

    Author Comment

    It seems not.  When I go into the proxies tab, I have nothing checked except at the bottom to use passive ftp mode (PASV).  Is there something specific I need to do here?

    Again to clarify, it is working for most all clients, but in select cases we cannot see the directories in the ftp that shoud show up.

    Author Comment


    do you have any imput on these settings, why it would have been working before I made the ip change and now I would need to make changes to my system?

    for referance, the change was my outside IP, and I made the change to the dns record almost a week ago.


    Author Comment

    Anybody, anybody??? thoughts please,
    LVL 5

    Assisted Solution

    well, if you want you can read what is PORT (active) or PASV (passive) mode and yo will realise why you have to make changes.

    Users connecting from behind the network may use passive and you can try to configure the client which connects from the network to use PORT.

    FireFox FTP Client

    How do I turn off Passive Mode/turn on Active Mode?
    Select a new account or edit an existing one by going to the "Manage Accounts" menu.
    In the Account Manager, select the "Connection" tab.
    Uncheck the "Passive Mode" option.


    Author Comment

    I didnt resolve the issue with either of these, but both were very helpfull to me in QUEST to solve the issue.  

    Thank you experts.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    The error "There was an error performing the update" occurred on a Mac OS X client workstation running  Symantec AntiVirus for Mac ( - the Enterprise product vers…
    Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now