?
Solved

ntbackup fails

Posted on 2007-07-31
7
Medium Priority
?
946 Views
Last Modified: 2012-05-05
I'm having the same problem with ntbackup on a couple of 2003SBS installations. The one I'm focusing on right now is a completely fresh system installed last week, including all patches and SP 2. The tape drive is a Sony AIT 40 GB IDE.

ntbackup is scheduled by AT:
ntbackup backup "@C:\Data\Backup\Daily_Set_Members.bks" /n "Daily-Full" /d "Daily Full Backup" /v:yes /r:no /rs:no /hc:on /m normal /j "Daily Job" /l:f /p "8mm AIT" /um

Each night the backup log shows:
The requested media failed to mount. The operation was aborted.

1. Using Start / Run / ntmsmgr.msc I've checked that under Libraries the Sony AIT 40 GB IDE Drive has no "red x" problem.
2. I've confirmed that the tape in the drive has been freed. It now appears under Media Pools / Free / 8mm AIT. Logical State is Available. Format is Removable Storage Service. Under properties, Enable Media is checked.
3. Under Start / Administrative Tools / Services, the initial setting for the Removable Storage service was "Manual" on the new installation. The error occurred those nights. I changed it to "Automatic" and "Started" and the error still occurred exactly the same way.
4. I attempted to apply KB831664 (although I was a bit dubious about whether it would actually be a solution anyway, I figured it was worth a try.) Installation of sbs2003-kb831664-x86-enu.exe failed with:
Setup cannot continue because one or more pre-requisites required to install KB831664 failed. For more details check the Log File C:\WINDOWS\KB831664.log (Log file is below.)

I've truly reached the end of my rope with ntbackup. I really hate the idea of switching to BackupExec (I really don't want to need an application to be installed as part of a bare-metal restore process, but I realize this is just a matter of taste. My strong preference is to make 2003 SBS work "out of the box" so I'm really looking for a solution to get ntbackup/RSM working properly, not a 3rd party program.) I realize there will probably be a number of people inclined to post that ntbackup is a horrible solution and I ought to just dump it (and at my current level of frustration with it, I can understand why people feel that way) but that's not the direction I'd prefer to go.

The reality is that I know ntbackup CAN work and does (consistently) on other systems I've set it up on in the same fundamental way. There's just something that has gone wrong here in this installation that I'm at a complete loss to find and fix. It's truly bizarre. Absolutely everything I can see here looks to be correct and set up the same way other clients I have were who have gotten consistently good backups with the same general approach.



=======
BELOW IS C:\WINDOWS\KB831664.log
=======


Log file included:
2007/7/31  9:54:50.109
***

Exe = update.exe, Version = 5.4.1.0
***

================== Update.exe started at  7/31/2007 at  9:54:50 ==================
***

Service Pack started with following command line:
***

Return Value From IsSbs2003 = 0

***

IsSbs2003 returned 1
***

Fist Condition in ChkSBS.Section Failed
***

Condition Check for Line 1 of PreRequisite returned FALSE

***

ReadStringFromInf: SetupGetLineText failed: 0xe0000102
***

KB831664 Setup encountered an error:  Setup cannot continue because one or more pre-requisites required to install KB831664 failed. For More details check the Log File C:\WINDOWS\KB831664.log
***

ReadStringFromInf: SetupGetLineText failed: 0xe0000102
***

Setup cannot continue because one or more pre-requisites required to install KB831664 failed. For More details check the Log File C:\WINDOWS\KB831664.log
***

Message displayed to the user: Setup cannot continue because one or more pre-requisites required to install KB831664 failed. For More details check the Log File C:\WINDOWS\KB831664.log
***

User Input: OK
***

Update.exe extended error code = 0xf0f4
***

Update.exe return code was masked to 0x643 for MSI custom action compliance.
0
Comment
Question by:mcj
7 Comments
 
LVL 13

Assisted Solution

by:ocon827679
ocon827679 earned 450 total points
ID: 19602942
Can you run the job manually from ntbackup?  this will tell you if ntbackup is working

Can you run the job based on the command line manually?  this will tell you that your command line is right - if it is then maybe use the task scheduler, rather than AT
0
 
LVL 11

Accepted Solution

by:
Zenith63 earned 600 total points
ID: 19603847
Hopefully somebody can help you, but to be honest I think you're wasting your time.  I spent months trying to get NTBACKUP to work with tape drives but it just isn't reliable.  It will work for a while but will start failing again.  I see you've got the /um switch in there which tends to help a bit...
NTBACKUP works rock solid for file backups, but tape management seems to be sadly lacking.

Symantec do a cheaper "small business edition" of Backup Exec which will work very reliably and is what I ended up replacing NTBACKUP with after the months of trials.  In fact if you shop around when buying tape drives some will come with Backup Exec Quick Start edition which works perfectly for standard file backups.
0
 
LVL 3

Assisted Solution

by:Circleblue
Circleblue earned 450 total points
ID: 19608185
Quick question.. are you using the backup wizard to set the backup?  If not I would recommend you do.  SBS is ruled by the wizards (no, not the LOTR type!)  Have you considered using external drives for your backup medium?  I use an external USB drive and works great.  They are ridiculously cheap now.

Cheers,

Brian
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mcj
ID: 19611434
Before last night's cycle, I tried removing the tape drive from Device Manager and the Removable Storage Service, then scanning for hardware changes and letting the system add it back. (I had seen this as a proposed solution after googling...) It didn't change anything.

At the AT schedlued time, once again I got the same message:
The requested media failed to mount. The operation was aborted.

This was interesting. AT was schduled to call my backup.bat file at the set time and obviously failed. Shortly after, I remoted in and manually double-clicked backup.bat and it ran without any problems at all. The only difference is that when AT runs it, the process is invisible, but when logged on as Administrator, after double-clicking the backup.bat file, the backup utility opens visibly and runs.

For tonight's cycle, I will try calling backup.bat using schtasks instead of AT and see if that makes a difference.
0
 

Author Comment

by:mcj
ID: 19619273
Update. Possibly Solved.

As I mentioned before, Tuesday's cycle failed to run automatically, so I ran it manually. (And that means I simply "double-clicked" the backup.bat file that AT was supposed to run automatically.) The manual run succeeded.

Afterwards, I noticed that the Removable Storage Service now identified the same tape differently. Before it was manually run, the tape format was "Removable Storage Service" but after it was shown as "Backup Utility (NTBACKUP)" instead. This got me thinking.

Some comments I've googled across so far have seemed to indicate that "fresh tapes" and/or "formatted tapes" are handled differently than used ones. That even even when you use the /um switch in your backup script, that "always overwrite whatever tape you find" switch is inconsistently obeyed.

My current suspicion is that /um is obeyed for ANY tape when requested directly by a logged on Administrator, but is only complied with when run by AT for tapes that are already "known." Once the tape has been manually run by the Administrator, the tape becomes "known" and later AT requests to use it WILL be obeyed.

So for the Wednesday cycle, I changed nothing. I left my scripts exactly as originally set up, the only difference was that I used the same tape that was now identified as "Backup Utility (NTBACKUP)" format.

Sure enough, It ran without any errors last night. I'll test this for a few more nights and post comments on the results.
0
 
LVL 11

Expert Comment

by:Zenith63
ID: 19620757
Bare in mind that when you double click your backup.bat you are running the backup as the user 'Administrator', whereas when the AT command runs a scheduled backup it actually runs as the System Account, this is why you are seeing the different results.

This and the unpredicatable use of tapes (first use, unformatted, reused etc.) are just some of the reasons NTBACKUP doesn't work well with tape drives and I had to stop using it.  CircleBlue's suggestion of removable drives is a good one though; NTBACKUP works perfectly when using simple media like this that isn't managed by Windows' Removable Storage.  However you then get into issues like how often to take away drives etc etc.

We've finally got away from all of this rubbish by hosting an offsite backup service.  The software manages everything and it's a great service to sell to customers.  We haven't sold a tape backup system in 12 months and have moved 80% of existing customers off tape to offsite backup...
0
 

Author Comment

by:mcj
ID: 20153125
Thanks to everyone who participated. I split points to each of you.

In the end, the largest part of the solution seems to have been to confirm that any newly loaded tape shows as type = Backup Utility (NTBACKUP) once loaded. Going to manage, RSM, Media and confirming you see that seems to resolve the issue. If it does not show that, then the tape won't run automatically by either AT or Task Scheduler.

To "reset" the tape, I created another batch file that runs on a tiny folder. If a tape shows type=new or whatever, then I run that "backup" batch file and afterwards the tape shows type = Backup Utility (NTBACKUP) and seems to work.

 in Removable Stor
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The problem of the system drive in SBS 2003 getting full continues to be an issue, even though SBS 2008 and SBS 2011 are both in the market place.  There are several solutions to this, including adding additional drive space or using third party uti…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
Look below the covers at a subform control , and the form that is inside it. Explore properties and see how easy it is to aggregate, get statistics, and synchronize results for your data. A Microsoft Access subform is used to show relevant calcul…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question