Posted on 2007-07-31
Last Modified: 2008-01-09
hi experts...
i just set up a new cisco 836 adsl over isdn router.
i picked this router because it comes with an isdn bri st backup interface
however, im having difficulties configuring the isdn part.

im posting my config so you can have a look,
i edited it, removing my attempt to configure the backup interface
the posted config is a working adsl configuration
im kind of in a rush, hence the 500 points...
thanks in advance

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
hostname *******
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$vkr0$XEBX4DuFbmLKkSoRhktVd/
no aaa new-model
resource policy
clock timezone PCTime 2
clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp excluded-address
ip dhcp pool sdm-pool1
   import all
ip tcp synwait-time 10
no ip bootp server
ip domain name
ip name-server
crypto pki trustpoint TP-self-signed-1137065381
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1137065381
 revocation-check none
 rsakeypair TP-self-signed-1137065381
crypto pki certificate chain TP-self-signed-1137065381
 certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31313337 30363533 3831301E 170D3037 30373331 31333533
  32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31333730
  36353338 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100D092 40D19060 F026B906 03B42988 DA17C70F 39DECE76 6CE7E3A5 674C85CD
  CB9CE711 87DC98C6 D2E05631 2D643228 7BEEEDEA 20AF9D07 F8332E87 D9AE1C90
  3A64D902 1F981FDB 8D3E7718 9A254372 21A64077 AAB25A72 31EB4ADB C6B2357B
  C19917ED 3400D53D A10C5C23 C1A39B72 9350F262 F7462011 9F1FC802 389ECECE
  87BD0203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
  551D1104 1A301882 16617A69 6D757468 2E796F75 72646F6D 61696E2E 636F6D30
  1F060355 1D230418 30168014 4F43B3C1 536AEA45 52408358 587374B3 297CB746
  301D0603 551D0E04 1604144F 43B3C153 6AEA4552 40835858 7374B329 7CB74630
  0D06092A 864886F7 0D010104 05000381 8100BC7A 0C9E2117 11EB6E3F AE5B0610
  0A72A0C0 D6BB6413 E6AC6CB4 272D4641 715E7F07 AA3A93FE 4653D895 9FA11E41
  58D93348 18E37EDF 304A8FE6 1E64980C E22D7772 74E5F4AA 77B817B6 2C2B4053
  23813C94 514A66EA EDF09D62 9F72439A 2255C5C5 C5B2CDD1 07B60060 3BA1D67B
  C24B7AD5 1A489081 54C19478 FA3D0367 FAD5
username ****** privilege 15 secret 5 $1$0AvD$Af09ChcMx4NSqVDAho1N71
 interface BRI0
interface ATM0
  no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no atm ilmi-keepalive
 dsl operating-mode auto
interface ATM0.1 point-to-point
 description $ES_WAN$$FW_OUTSIDE$
 no snmp trap link-status
 pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface Vlan1
 ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username *********** password 7 044D0A421B201E
ip route Dialer0
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 25 25 extendable
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit
dialer-list 1 protocol ip permit
no cdp run
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
webvpn context Default_context
 ssl authenticate verify all
 no inservice
Question by:pk24573
    LVL 4

    Accepted Solution

    Try using the following link,

    Let me know if it was of any use to you.

    LVL 1

    Author Comment

    nope, it doesnt help me at all.....

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
    Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
    After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now