• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3959
  • Last Modified:

Microsoft Photo Editor Unknown file format jpg

if i try to open jpeg [.jpg] file by double clicking, MS photo editor opens and gives this error message:
---------------------------
Microsoft Photo Editor
---------------------------
Unknown file format
---------------------------

if i open MS photo editor first and try to open the file i get:
---------------------------
Microsoft Photo Editor
---------------------------
Photo Editor cannot find or open
f:\photos\IMG_0171.JPG
---------------------------

the operating system and office were reinstalled recently.
i also tried doing a repair of MS photo editor using the office cd.
these same files opened fine before. they still open in other programs such as irfanview and exif.
MS photo editor opens .bmp files fine.

OS = XP pro sp2
MS photo editor = ver 3.0.2.3
logged in as admin
0
alk444
Asked:
alk444
  • 4
  • 3
1 Solution
 
war1Commented:
Greetings alk444 !

This normally happens when opening images in .jpg format saved directly from the web. The .jpg format uses more than 1 compression scheme and the MS Photo Editor seems picky what it can accept.

I don't know of a real, "fix" for the problem but a work-around that will enable you to view them with Photo Editor is to open the image in another viewer (for example, Irfanview) and re-save in .jpg format over-writing the original when prompted. Once re-saved the image will open normally in Photo Editor.

http://forum.worldstart.com/archive/index.php/t-6070.html

Best wishes, war1
0
 
alk444Author Commented:
these files are the same ones that worked before. they are on a different drive and were not affected by the system reinstall. they are digital camera files and screen shots etc. and were not downloaded.

i tried your work around, but still get the same error message.
0
 
war1Commented:
Check if the JPEG file is too large. I have found that when a jpeg file is too large, MS Photo will just kind of blow its mind and not do anything. I am not sure what the size cap might be, but I have this trouble with anything above 1mb or so.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
alk444Author Commented:
i have tried files from 127,048 to 4,518,482 Bytes and these are files that used to open fine in MS photo editor.
0
 
war1Commented:
alk444,

Seems like something is wrong with MS Photo.  Make sure other programs are not running. Then reinstall MS Photo.  

If no joy, ohter photo editors are better and more reliable.  Irfanview works well.
0
 
alk444Author Commented:
i did reinstall MS photo, but no help. i have switched to Irfanview, but i miss the ability to have multple photos open in one window for comparison.
0
 
DEBROCKECommented:
I had a similar problem and this worked for me.  For reference, I have WinXP SP2, Office XP.
The problem has to deal with the Microsoft Shared Graphic filters when you do an install or reinstall.
1)  Make sure you have "C:\Program Files\Common Files\Microsoft Shared\Grphflt\JPEGIM32.FLT" on your system.  If you don't, you need to get that from your office cd.  You most likely have it and your registry doesn't know where it is, that was my problem.

2)  Backup your registry

3)  Open up Registry key:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Graphics Filters\Import\JPEG

4)  Odds are the "JPEG" filter doesn't exist.  If it doesn't, this is your problem.  If it does, not sure I can help.

5)  If it doesn't exist, then use the code snippet below and paste it into notepad and rename it as JPEG.REG

6)  Double click on the file and add it into your registry.  Once you do that, it will work if you have the same problem.
Windows Registry Editor Version 5.00
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Graphics Filters\Import\JPEG]
"Extensions"="jpg"
"ExtensionsEx"="jpg jpe jpeg jfif"
"Name"="JPEG File Interchange Format"
"Path"="C:\\PROGRA~1\\COMMON~1\\MICROS~1\\GRPHFLT\\JPEGIM32.FLT"
 
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Graphics Filters\Import\JPEG\Options]
"ShowProgressDialog"="Yes"

Open in new window

0
 
alk444Author Commented:
the file is there and my reg looks same as you suggested. i did not run your code.
i switched the jpg file association back to MS photo editor just to test it and now it's working.
i haven't done anything that should have fixed it, so i don't know what the problem was.
thanks for the suggestion.
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now