[Last Call] Learn how to a build a cloud-first strategyRegister Now


unable to find script library '/aspnet_client/system_web/1_1_4322/WebUIValidation.js

Posted on 2007-07-31
Medium Priority
Last Modified: 2008-01-09
I have seen my problem about a hundred times. I Haven't found a solution that works for me.
I am moving my web site from an old server ms win2k3 no sp's. To a newer better one with win2k3 sp2
The path on the 2 machines is identical except the machine name.
From localhost I get "unable to find script library '/aspnet_client/system_web/1_1_4322/WebUIValidation.js'
From th www I get a logon dialog box everytime I attempt to do anything.
I have run 'aspnet_regiis -c'  no fix
Then I ran 'aspnet_regiis -i reinstalling and svr32 and reregistered the aspnet_isapi.dll  succesful.  
Web site still has the same errors.
I made sure my virtual directory was pointing to wwwroot, even repointed to 1_1_4322 still not working
I restarted IIS and or the machine between each  "fix"
Question by:hlbyrdman
LVL 25

Expert Comment

ID: 19604767
copy aspnet_client folder from c:\inetpub\wwwroot to your web application root directory and see if it works.

LVL 63

Expert Comment

ID: 19604781
Mrs Google does say: http:/Q_21542561.html and http:/Q_20762240.html

Author Comment

ID: 19605193
I copied aspnet_client folder to web application root  no fix.
I had already found Q 21542561 and run regiis -c  no fix
Also I read Q 20762240  I don't understand how it helps

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

LVL 15

Expert Comment

ID: 19607301

Author Comment

ID: 19607549
My users ad data to a sql database. Validation is server side. So "http://msdn2.microsoft.com/en-us/library/yb52a4x0(vs.71).aspx"  doesn't apply.

Accepted Solution

hlbyrdman earned 0 total points
ID: 19607964
While I hate fixing things by reinstalling. Thats what I did. I removed application server from my server roles. Re-applied all ms updates. Reinstalled application server. Re built the virtual directory.  Took about 15 min.  Everything works. Been looking for a fix for two days.
Thanx all
LVL 63

Expert Comment

ID: 19608107
You can ask here for question close: http:/Community_Support/General/newQuestionWizard.jsp

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
In this blog, we’ll look at how improvements to Percona XtraDB Cluster improved IST performance.
The viewer will learn the basics of jQuery, including how to invoke it on a web page. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery.: (CODE)
The viewer will learn the basics of jQuery including how to code hide show and toggles. Reference your jQuery libraries: (CODE) Include your new external js/jQuery file: (CODE) Write your first lines of code to setup your site for jQuery…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question