[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3108
  • Last Modified:

Can I use sendmail instead of qmail (on a Plesk server)?

I use a custom mass-mail program (written in c++ & perl) that uses sendmail. Now I'm moving to a new dedicated server (OS Fedora 4.2 hosted at goddaddy.com) with a Plesk (8.2) control panel that uses qmail as the default mail server.

When testing the mass-mail program on the new server I get error messages (below) indicating a problem using qmail. Apparently the sendmail file on the new server is just a symlink to qmail, and the mass-mail process is trying to use qmail but can't do it successully.

I don't mind using qmail for all of my "normal" email accounts, but to avoid having to recompile the mass-mail program I would like to use sendmail for that program instead of qmail. There is a package (sendmail.sendmail) already installed in the same folder as "sendmail" (/usr/sbin/) that I believe is the actual sendmail apllication.

How would I go about using sendmail for the mass-mailer, or is it even possible to run sendmail for a specific application on a Plesk server?

Thanks,

zzthomaszz

ssl error log:
[Mon Jul 30 14:02:53 2007] [error] [client 121.247.152.144] qmail-inject: fatal: qq waitpid surprise (#4.3.0), referer: https://68.178.200.19/cgi-bin/admin/admin.cgi?command=choose_sendfile_files 

Mail log:
Jul 30 14:02:53 srv1 qmail-queue-handlers[29571]: starter: wait for submitter[29574] failed - No child processes
Jul 30 14:02:53 srv1 qmail-queue-handlers[29571]: mailsend: wait for submitter failed
Jul 30 14:02:53 srv1 qmail-queue-handlers[29571]: cannot reinject message to mail system
Jul 30 14:02:53 srv1 qmail-queue[29570]: starter: wait for submitter[29571] failed - No child processes
Jul 30 14:02:53 srv1 qmail-queue[29570]: mailsend: wait for submitter failed
Jul 30 14:02:53 srv1 qmail-queue[29570]: cannot reinject message to mail system
Jul 30 14:02:53 srv1 qmail: 1185822173.730467 new msg 21530383
-----
New Server uses:
apache 2.59
Perl 5.8.6
C++ 4.02
0
zzthomaszz
Asked:
zzthomaszz
1 Solution
 
xcomiiiCommented:
I had a similar situation, and I called Plesk about it. They told me that Plesk does not support other then qmail in the Pleask app.
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now