?
Solved

Windows 2003 Terminal Services sound problem

Posted on 2007-08-01
5
Medium Priority
?
1,563 Views
Last Modified: 2009-11-24
I have a Win 2003 server and I am using it just for Terminal services. My problem is that I cant seem to make the sound work in a remote session. If I am at the console, it works fine. I have it setup already in the client. If I just try to play any sound it gives me a device error. This seems to happen on more than just this server. I have a couple of them with sound cards, and I get the same thing. Any help would be great. Thanks
0
Comment
Question by:kjamez
3 Comments
 
LVL 4

Expert Comment

by:aces4all
ID: 19610609
1.  Check device manager on your terminal servers to make sure sound cards and their drivers have been properly installed and are to up to date.
2.  Make sure the Windows Audio service is started on the teminal servers.
0
 

Author Comment

by:kjamez
ID: 19611181
Thanks for the post. The sound works fine if you at the server and not in a remote session. Yes, the Audio service is started and working.
0
 
LVL 4

Accepted Solution

by:
kdubendorf earned 2000 total points
ID: 21017566
Sounds on Windows 2003 Terminal Servers are diabled by default.  Check the following link:

http://support.microsoft.com/kb/307071


The important except is as follows:

To turn on the use of sound on the Terminal Server computer, follow these steps:
1. To start the Terminal Services Configuration snap-in, click Start, point to Run, type tscc.msc, and then press ENTER.
2. Double-click RDP-TCP Connection.
3. In the RDP-TCP Connection Properties dialog box, on the Client Settings tab, click to select the Audio Mapping check box.
4. Click OK to close the RDP-TCP Connection Properties dialog box.
5. Quit the Terminal Services Configuration snap-in.
Note: my experience is that this is normally turned on.
To configure the settings for remote computer sound on the RDC client, follow these steps: 1. Click Start, point to All Programs, point to Accessories, point to Communications, and then click Remote Desktop Connection.
2. In the Remote Desktop Connection dialog box, click Options.
3. Click the Local Resources tab.
4. In the Remote Computer Sound section, click Bring to this computer in the drop-down list.
5. Click Connect to use the new settings.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This Micro Tutorial will teach you how to add a cinematic look to any film or video out there. There are very few simple steps that you will follow to do so. This will be demonstrated using Adobe Premiere Pro CS6.
this video summaries big data hadoop online training demo (http://onlineitguru.com/big-data-hadoop-online-training-placement.html) , and covers basics in big data hadoop .
Suggested Courses

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question