• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 942
  • Last Modified:

SSL certificate installation

I'm installing an updated SSL certificate from Go Daddy. I successfully installed the intermediate certificate but when I try to install the final certifacte I'm getting all the way through the certificate install wizard but it ends with an, "Failed to install certificate, Access is Denied".
Any ideas on how to resolve this problem?
0
Henry_Wagner
Asked:
Henry_Wagner
  • 5
  • 4
1 Solution
 
northcideCommented:
make sure you use the certificates snap-in and make sure it uses the "Computer Account".

awesome ssl tool for windows - http://www.microsoft.com/downloads/details.aspx?familyid=cabea1d0-5a10-41bc-83d4-06c814265282&displaylang=en

0
 
Henry_WagnerAuthor Commented:
Welll, I have downloaded and run the diagnostics. It comes back with an error reading the metabase, "cannot read metabase". The suggestion is then to download and install the IIS 6 resource kit. I have downloaded, installed and run the Metabase Explorer. When running this application it comes back with an error, "Failed to connect to the local metabase", "Failed to open metabase key, Reason, access is denied". I'm stuck here. Any ideas?
0
 
northcideCommented:
oooh very nice.  you're logged in as admin right?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Henry_WagnerAuthor Commented:
Yes, I'm logged in as admin
0
 
northcideCommented:
in metabase explorer - does it open at all?  do you see the root node?  if so right click on it and check the permissions.  make sure administrator is listed.  if not go to the owner take ownership as admin
0
 
Henry_WagnerAuthor Commented:
it opens to a blank grid and the only choices I have are to "connect" or "import key".
0
 
northcideCommented:
ok thats pretty nasty.  i'd guess that your metabase is corrupt.  im no expert when it comes to the metabase - but that stuff definitely should not be happening.

you might want to try restoring a backup of your metabase.  luckily iis6 creates a revision backup each time its edited.  This article outlines some things you might want to try.

Might be a good idea to do this after hours in case something gets truly messed up.  also have a credit card available in case you need to call MS for support :)
http://www.windowsitpro.com/Articles/ArticleID/22281/22281.html?Ad=1

0
 
Henry_WagnerAuthor Commented:
Alright, i coughed up the $200+ and had Jaskirat of MS show me the errors of my ways. The problem was that someone prior to me had changed the Dcom properties and by going into Adminsitrative Tools --> Component Services and under Computers selecting the properties of my computer I was navigated to the default properties. Those properties had been set to anonymous under the impersonation level. Once the settings of the Default Authentication Level was set back to "Connect" and the Default Impersonation level was set back "Iddentify (the MS defaults), the certificate installed fine. I appreciate everyone's help on this but it took a level 2 engineer with remote control of my system to figure this one out.
Henry
0
 
northcideCommented:
aha, very interesting.  i'm going to add this one to my KB.  I was starting to feel dumb for a moment but i was convinced it was a very obscure strange problem.

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now