• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 355
  • Last Modified:

Problems detecting drives Dimension 4500 XP home

I am working on a Dell Dimension 4500 running XP home.  There are two problems that I think may be linked.

1. The autoplay feature does not work on either of the CD/DVD drives.  I have run Kelly's
autoplay fix on them and it comes up with no problems, but autoplay still doesn't work.
2. The second problem is with the hard drives.  I've just cloned the original C drive and made
the larger clone the master and the old drive the slave.  I've set the jumpers for master/slave
and put the master at the end of the connector and the slave below it.  Still when I boot with
both of them up the old drive comes up as C and the new one as F.  I've gone into the bios
also hit alt-F to redetect the drives but it still comes up this way. I've also tried it with all drives
set to cable select.
The customer is coming over in a few hours so swift help is appreciated.
Thanks,
Al
0
alanlsilverman
Asked:
alanlsilverman
3 Solutions
 
Da1KingCommented:
On some OEM systems it doesn't matter what you have the jumper settings set to.  Try to set both drives to cable select and then place the master at the end of the IDE cable and the slave in the middle and try again.  This should make them detect in the proper order.

With the autoplay make sure that the CD/DVD that you are using has some kind of autoplay on it.  Try using an audio cd or heck a blank CD should cause some kind of autoplay to come up.  Some data CD's don't have the autoplay info and won't bring anything up.
0
 
techcontractingCommented:
Disconnect the old drive temporarily to see if it will boot with the new one only.  If all is ok, put the old drive on the 2ndary cable with the CD ROM (drive- master, cdrom- slave).  Then in the BIOS, you want the boot drive to be Hard Disk 0 as the 1st boot device, (hard disk 1 is the 2nd drive)

For AutoRun feature, see this:  (you may have to edit the registry setttings)

http://www.moonvalley.com/products/rwavdc/enable.htm

0
 
and235100Commented:
To fix the autoplay issues - try http://www.microsoft.com/downloads/details.aspx?familyid=C680A7B6-E8FA-45C4-A171-1B389CFACDAD&displaylang=en

As to your second issue - if want to dual boot from both drives you are not going to be able to change the drive letter. The problem being - you created a clone - and hence, the mbr picks up the old drive as the primary windows disk - and the jumper settings do not matter at all - it is all about the mbr.

You may find, booting with the new hard disk alone, running fixmbr and fixboot from Recovery Console may change the drive letter to C:, then add in your other hard disk, and change the boot.ini on the first hard drive so that you can select the old drive to boot from.

Fixing the mbr may not help, in any case - you really need to not use the older hard disk in conjunction with the newer one - why do you need to do this anyway?

0
 
and235100Commented:
I hoped that helped.

Thank you.
0
 
alanlsilvermanAuthor Commented:
It did, with both issues.  The customer is gone and I can finally get some rest.  It's been hectic the last few days.
Thanks so much,
Al
0

Featured Post

Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now