USB hard Drive not showing up in Hardware Browser

Posted on 2007-08-01
Last Modified: 2013-12-16
I plug in my new USB hard drive to my Linux Enterprise 4 server and it's not recognized? It does not show up in  the Hardware Browser.
Question by:alantone
    LVL 2

    Expert Comment

    Check to see if it's being detected at all when you plug it in.  After you plug it in, at a terminal type:

    dmesg | tail -n 20

    You should see something to the effect of it detecting a device like "sda" or "sdb" and then it should show you the valid partitions on the usb device.  Something like "sda1 sda2" or "sdb1".  If you see something like this, you have a problem with DBUS/HAL.  You can still mount the drive manually though.  We'll say that it detected a usb drive that has one partition on it, sdb1.  To mount that you would type, as root at a terminal:

    mkdir -p /mnt/thumbdrive
    mount /dev/sdb1 /mnt/thumbdrive

    This should then show up in your file browser.

    Author Comment

    I run the dmesg command and I get nothing about  it detecting any device, no "sda, sdb, sda1" etc. at all.
    LVL 2

    Expert Comment

    Do you have another USB device you can plug in there?  I would verify that the USB port itself is working.  When you plug any USB device into that machine, *something* should be appended to dmesg.  You should see something new show up at that end of it, whether it fails to load the appropriate driver for the device or everything works perfectly.  If you are not getting anything new in dmesg after plugging something in to the USB port, you may want to reboot, go into the BIOS and make sure that all of your USB ports are enabled there.
    LVL 12

    Expert Comment


    Author Comment

    OK, I got into the BIOS and enabled USB. Now when I do a dmesg | tail -n 20 I see that the computer is seeing the drives. I have 2 that I need atached. One drive sdd with partition sdd1 returns the following error when I enter

    # mkdir -p /mnt/thumbdrive
    # mount /dev/sdd1 /mnt/thumbdrive

    I get
    # mount: you must specify the filesystem type  
    LVL 2

    Accepted Solution

    Ok, try:

    mount -t vfat /dev/sdd1 /mnt/thumbdrive

    This assumes that it is formatted fat32.  For a list of filesystem types that you can use for specification, do:

    man mount

    Scroll down until you see a line like this:

           -t vfstype

    Read that section and it will tell you different filesystem types you can mount (as long as you have kernel support for them!).

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
    If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
    Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now