[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 226
  • Last Modified:

Shared printer install fails.

I am setting up a new w2k r2 server and trying to install shared printers.  The printers are setup using ip ports.  The first printer setup fine, but when I tried to setup the second printer I recieved this message.
Either the printer name was typed incorrectly or the specified printer has lost its connection to the server.
The printers page showed the printer with a ,0 after the printer name.  Some times there are multiplule copies of the printer with the name followed by ,1 and the next instance ,2 and so on.  The properties pages do not work.  I have to stop and start the print spooler service to be able to delete the printer.  I have restarted the server after deleting the printer.  When I try to setup another printer I get the same error.
I even tried setting it up to a local lpt1 port and I cannot get the printers to install now.
I have setup lots of printers using ip ports but have never had this problem.
0
n8498x
Asked:
n8498x
1 Solution
 
kbratton1Commented:
First, make sure that all your printers have valid (and different) ip addresses and are plugged into the network.  Now go to the printer server and make sure you can ping the printers.  Next, make a port for the first printer and name it with a unique name that identifies the printer that will attach to that port.  Finally, install the new printer driver for the new printer, then install the new printer and give it a unique name that identifies that printer and attach it to the port you set up earlier.  Repeat as needed...
0
 
Alan Huseyin KayahanCommented:
      Hi n8498x
              Please have a look at following http://support.microsoft.com/kb/883789
             *Also Start>run>regedit, then locate
            HKEY_LOCAL_MACHINE>System>CurrentControlSet>Control>Print>Printers . Remove the incorrect/no more available printer entries from here. Do the same in Currentcontrolset001 and 002

Regards
0
 
n8498xAuthor Commented:
I have installed lots of printer over the years.  I have never had the printer installiation process crash.  The coment from MrHusy has some clues as to what is going on.  After the printer creation process crashes the only thing that works is to delete all printers and start over.  
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now