[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 578
  • Last Modified:

USB Mass storage device recognized by Device Manager, but is not assigned a drive letter

I have a 500 GB external Iomega hard drive (USB/Firewire) and am running Windows XP Professional.  Today when I went to restore my backup from this drive, the USB connection was recognized by the device manager, but was not assigned a drive.  The USB drive recognized mass storage unit attached, but the Computer Management section of XP only sees my C drive.  All of my drivers are up to date and I have tried reinstalling them as well.  Tech support at Iomega thinks I need "data recovery".  Can anyone suggest an alternative?  The drive seems to be working (no crashes or unusual noises).
0
Shys
Asked:
Shys
3 Solutions
 
and235100Commented:
First of all - try another usb slot - does the hdd require external power - if so - plug it in.

If not, then make sure that if using a usb hub - then plug the external power source in.

If you boot with a cd from here (http://www.nu2.nu/pebuilder/) and plug your drive in prior to boot - can it be seen in the A43 file management utility?
0
 
natcomCommented:
the quickest way to find the source of the problem is by  trying the hard drive on a different computer. if this same problem on a different computer it is more likely that the partition is damage.

And you definitely going to need recovery software.
I would recommend the following free software http://www.pcinspector.de/file_recovery/uk/download.htm

if you able to see the drive on a different computer.
It is more likely that all you need to do is  reset the bios on your machine.
0
 
KCTSCommented:
Right click My Computer, Select manage, go to Disk Management, Right click on the device, Select "Change Drive Letters and Paths" and assign it a letter outside the range used by other devices and mapped drives etc.
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
jng1Commented:
Hopefully it's not a bad HD in the external unit.

Another thing to try:
Turn your computer off, then unplug the USB cable and power to the drive.
Restart your computer, plug the power into the hard drive, wait 10 seconds and then plug the USB into the computer
0
 
ShysAuthor Commented:
I am totally new at this forum, so I apologize ahead of time if I am not following protocol.  I don't know how to respond to individual suggestions, and besides, my mainframe just "crashed" so I now have lost everything and no ability to reformat or anything.  I had reinstalled XP and was slowly rebuilding my system when I had tried to restore and contacted this forum.  Now I don't have a computer to restore to.  The computer management area on my computer (which is now "gone") did not recognize any drives, so I can't rename it, I had tried booting every way I could think of and as I mentioned tried the drive on another computer as well.  All the same result.  Well, I have bigger problems now, so I had better decide what I am going to do.  Thanks for your help truly.
0
 
CircleblueCommented:
Shys...  troubleshooting triage for you..  number one get your system running smoothly.  No problems popping up.  then focus on the usb drive..  If the data is intact then it will be there.  However,  while making your "primary" system come back to life, plug the drive into another system to see what it does as natcom suggested.  You will find out if it is readable or not quickly.  If not, then suspect there is a  problem with the USB drive.

Cheers,

Brian
0
 
gb-sdcCommented:
One way to test a drive (and one that I used a few times) is to boot a copy of Knoppix (bootable Linux ISO which doesn't touch the hard drive) on the PC.

Once Knoppix boots, plug in the drive and it should show up on the desktop as an icon.

ftp://ftp.uni-kl.de/pub/linux/knoppix/KNOPPIX_V5.1.1CD-2007-01-04-EN.iso (700MB ISO)

It's a big download, but might be worth a try if you can't find any other way.


Hope this helps.
0
 
thstephCommented:
I suggest the solution offered " KCTS:Right click My Computer, Select manage, go to Disk Management, Right click on the device, Select "Change Drive Letters and Paths" and assign it a letter outside the range used by other devices and mapped drives etc."     ...     but

instead of changing the USB's drive letter try changing your ROMs drive letter for 2 reasons:
a. Most likely you won't find you USB mass storage device there to change the drive letter cause it's trying to use your ROM's drive letter and
b. The second (3rd, 4th ... etc) time that you are going to connect your HSMSD on your USB is again going to try and get the drive letter of your ROM's. So if you have one HDD and 2 ROMS (C:, D: and E:)
try changing D: and E: to E: and F:

Regards
0
 
thstephCommented:
PS. Do you have a removable HDD in your MSD??? If so check if you have your jumper on slave drive!!!!!!
It has to be on primary!!!!!
0
 
ShysAuthor Commented:
I took the drive to a "shop".  They said the external hard drive was "gone" as was my best backup for my recent computer crash.   Given the fact that my regular hard drive has died, as I mentioned earlier, I bought a new hard drive and am slowly rebuilding my computer (without some valuable backup information).  I did try several of the suggestions prior to all of this crashing, including the rebooting and using the device manager to try and find the drive.  If the drive had been "good" those suggestions would have worked.  So in light of this, those of your who predicted my hard drive was gone are the winners.  Thanks,  I will be closing this question as soon as I review the policy.  Thank you everyone.
0
 
ShysAuthor Commented:
I thought I had closed the question appropriately.  I apologize.  Shys
0
 
rindiCommented:
You should still close it.

Thanks,
rindi,
EE Cleanup Volunteer
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now