Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1728
  • Last Modified:

Port 80 not listening on Server 2003 IIS web service

Server 2003 running IIS.  Have an ASP.net web application running from that machine.  Cannot browse to it on port 80 (locally).  have checked port 80 and it is not listening.  I have also checked the registry and confirmed the port is set to 80.  I have also confirmed that the service is running and did stop and start it just for good measure.  This application was working at one time and was recently reported to have simply 'stopped working'.  Any ideas?
0
shimfizzal
Asked:
shimfizzal
  • 4
  • 3
  • 2
  • +3
1 Solution
 
Ted BouskillSenior Software DeveloperCommented:
Have you looked at the properties for the website in IIS?
0
 
Farhan KaziSystems EngineerCommented:
Make sure Windows (or any other) Firewall is not blocking port 80. What if you change port from 80 to something else like 8889? Are able to open page like http:\\ServerIP:8889?
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

If you still not able to run site with the site 80 port then there is problem with the socket pooling so please  disable socket pooling through the following . I think there is also some another service is running with port 80 that's why you are getting problem so do the following and restart computer.


 Bind IIS Sites to an IP
******************

1- Open IIS and select the web site you want to bind. Right click and select [Properties].

2- Click the drop down in the 'Web Site' tab and select the IP you want to bind the web site to.

3- Click OK and stop/restart the web site.


******************
Disable Socket Pooling
******************
(IIS 5.0, 4.0, Windows 2000 and earlier)
1- Open a command prompt and make sure you are in the X:\Inetpub\Adminscripts folder (where X is the IIS installation drive). To do this, type the following lines at the command prompt:
X:
CD\Inetpub\Adminscripts

2- After you open the Adminscripts folder, type the following line at the command prompt:
cscript adsutil.vbs set w3svc/disablesocketpooling true

3- The command replies as follows:
disablesocketpooling : (BOOLEAN) True

4- Stop and start the IIS Admin service.

5- Restart the WWW service.

(IIS 6.0, Windows 2003)

1 Click Start, and then click Run.
2 Type cmd, and then click OK to open a command prompt.
3 Type the following, where xxx.xxx.x.x is the IP address you want to add:
httpcfg set iplisten -i xxx.xxx.x.x

NOTE: add all IP of the server. otherwise IIS not start

When this succeeds, Httpcfg returns the following:

HttpSetServiceConfiguration completed with 0

To view additional status codes, see the Httpcfg help.
After the IP address is added, use the following command to list it:
httpcfg query iplisten

Httpcfg returns the following:

IP :xxx.xxx.x.x
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 
deepaknetCommented:
Any diagnostic messages in EventLog?
0
 
shimfizzalAuthor Commented:
I have changed the Port to 8081 (something that wasn't listening prior to) and restarted the IIS service.  It did not work.  In fact, it does not bring up that port.  This is the same behavior as with port 80.  I have done a port scan on the machine and port 80 is not open at all nor is it being used by another service.  Also, while I don't think it would matter, the firewall IS off.  

I'm pretty sure the problem lies with the fact that IIS will not bring up a port to listen on, I just don't know WHY. :)
0
 
kumar_jacCommented:
Hi,
         If the skype messanger is running quit that . Some other service may using the same port so stop the suspected service and set 80 to IIS and start.
0
 
shimfizzalAuthor Commented:
No messenger clients are running.  Again, though, let me say that port 80 is not listening at all.  Nothing is connected to it becuase it is not open for connections period.  I've check netstat as well as a port scanner and port monitor to look at all process/ports.  It's as if port 80 has been administratively turned off somehow.

Also, again, I've checked and rechecked that the port value for IIS in the registry is 80 and I did restart the service after checking.
0
 
Farhan KaziSystems EngineerCommented:
Did you try creating new website? If yes and that didn't work then take backup of your website(s) and then uninstall IIS and reinstall IIS.
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi shimfizzal:,

have you try with the solution which I have given.
0
 
shimfizzalAuthor Commented:
yes, no affect.  IIS is still not opening up port 80 for connections.  

And there are no other processes using port 80.  Port 80 is not just 'unavailable' it is not open at all.
0
 
Ted BouskillSenior Software DeveloperCommented:
Have you tried to connect to port 80 using telnet?
0
 
shimfizzalAuthor Commented:
I have tried telnet, yes.  I have also used a little app I wrote that uses winsock to connect to whatever port you specify and reports the status of the connection attempt.  I've also used netstat, portscanners, port monitors, etc.;  the whole nine yards.  I'm absolutely sure about the fact that port 80 won't come up and listen when the service is started.
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

Can you give me the result of this command.

httpcfg query iplisten

0

Featured Post

NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now