Only IE can connect to internet, internet works well only in safe mode

I am running Windows Vista Home Premium and recently I have been having a weird problem with the internet.

No windows programs except for Internet Explorer can connect to the internet. IE works fine, but every other program says "not connected" or "no connection found'. However, I have an IP address and windows thinks I am connected and I can access the internet. No firefox, no antivirus updates, etc. However, when I run windows in safe mode everythign works fine.

At first, I thought it was a firewall problem. But I have thoroughly checked and disabled windows firewall and I am not running any other firewalls (double checked by enumprocessess). Even after this the problem remains.

Then I thought maybe I have spyware/viruses. So I started windows in safe mode, in which the internet connection worked fine. I run several different antivirus and spyware utilities and found nothing.

I cannot figure out what is goign on. I thought it might be a winsock thing but then why does IE work fine? I thought maybed a DNS thing but all the websites I go to in IE seem to work.

Why does it work in safe mode but not in regular mode? Why does it work in IE only in regular mode?

PLEASE HELP!!!
dillangerAsked:
Who is Participating?
 
thstephConnect With a Mentor Commented:
So ... you have 2 AV programs right? That could cause many problems! I recommend removing one of them (Symantec) if not both and installing a better one like Sophos or NOD32 (ESET) which are both lighter, faster and more reliable.  Most likely this is the reason for not connecting to the internet. Even if you close them down as you said, I think that symantec leaves an instance open. You would need to remove it completely in order to see if that is your problem.
2nd. Running on "automatically detect internet..." doesn't mean that your ISP doesn't use proxy servers. It might work both with proxies and without proxies. Try surfing onto your ISP's wp and checking the Internet connection settings. They might offer some alternatives.

Regards.

PS. If no 2 is the case you would need to set up your applications accordingly in order to work with proxies
0
 
wct296Commented:
First question - do you have a proxy server set in they network setup of IE... ?

If your gateway is not set or not allowing traffic, but your IE has a proxy server which is set to allow traffic out, then IE will work and nothing else will..

thanks
Cam
0
 
x_calibreCommented:
your antivirus may also have an internet protection module, which is currently only allowing access to IE
check the internet options in your 'antivirus' or security program
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
wct296Commented:
Or an 3rd party firewall of some sort.. Say Mcafee Firewall or similar... Try disabling it for a short period and seeing if the access comes back (if you have a 3rd party firewall)
0
 
cyberpranavCommented:
How are you connected to the internet?

::Pranav::
0
 
tztrhCommented:
have you tried to change security settings in "Internet options"?
0
 
itnowptyltdCommented:
the fact that you get full function in safe mode would eliminate Internet explorer settings as these are not changed by the safe mode startup. which means we are left with firewall or 3rd party application. You said you have tried disabling the windows firewall. using the gui or the service? i would suggest you try the services ( START> RUN > services.msc) find windows firewall and stop the service and try the Internet. I have also seen issued similar to this with new computers that come the anti virus packages from factory that the end user uninstalled. does this apply to you ?
0
 
dillangerAuthor Commented:
There is no proxy server connection to the internet. I have broadband that I connect through wireless. I looked in the IE settings and all that is checked is "automatically detect internet..."

I am running no other 3rd party firewalls. My antivirus apps are AVG and symantec antivirus neither of which have a firewall. Even if I close them the internet still does not work.

I tried disabling the firewall through the services.msc but that did not work either.

THe only thing I can think of is that I installed network magic recently, but when the problem happened I uninstalled it and it did not fix the problem.
0
 
ClawfootSupplyCommented:
Do you have multiple connections?  I'm not as familiar with Vista, but I have seen systems with multiple wireless connections under "my network connections" in XP and 2000 have problems where most programs are trying to access the wrong connection.  Usually that's fixed by removing all connections you are not using.  Unfortunately, I can't tell you how to do that in Vista.
0
 
itnowptyltdCommented:
When you connected to your wireless what location type did you tell vista to use?
to check this open the Network and Sharing center. it will tell you the wireless network name and then in brackets the location type ie smithhome  ( private network ). The options for it are work, private, public
0
 
dillangerAuthor Commented:
tztrh:
I have tried to change the security options but that did not work.

itnowptyltd:
My wireless internet connection is listed as a public network in windows vista.

ClawfootSupply:
I only have one connection to the interent listed.

thsteph:
I have closed all AV programs. I stopped all related services including windows firewall, defender, AVG, and symantec. No change. I am not sure about the whole proxy issue but I am not sure why internet explorer would work if I have not set up any proxy information for it, assuming I did have one.
0
 
cyberpranavCommented:
Seems lke some service or process in normal mode is causing problem...

::Pranav::
0
 
mark_seymourCommented:
I fully agree with thsteph, I think you need to follow his request a little closer.

You need to remove one of the AV programs not simply disable it. You should only run one AV program on your computer. Try totally uninstalling both AV programs and trying your internet, then if it works only resintall one of them not both.
0
 
ChiefITCommented:
Go to the command prompt and type >>IPconfig /all<<. If you see something that says something like "Terrado tunnel" , you are using IP version six on your computer. IPversion 6 is not compatible with IP version 4 routers. But, version 6 routers can run 4 computers.

If you are using IP version 6, call your internet service provider and ask them what version your router supports.
0
All Courses

From novice to tech pro — start learning today.