[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 272
  • Last Modified:

Outlook Mobile Access - Server runtime errors

I now have a user who wants to use OMA on his mobile device.
We use Blackberry units already and SSL on OWA

When the user tries to log onto the site, it asks for his username and password, then it reports a browser error.

When I try the website from my laptop, I get a server runtime error
Server Error in '/OMA' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

0
andrefortier7
Asked:
andrefortier7
  • 7
  • 5
1 Solution
 
SembeeCommented:
You should have something logged on the Exchange server at the same time as the user tries to use OMA. What does that say?

Simon.
0
 
andrefortier7Author Commented:
The mailbox server [zelosottmail.zelos.inside] has its [exchange] virtual directory set to require SSL.  Exchange ActiveSync cannot access the server if SSL is set to be required.  For information about how to correctly configure Exchange virtual directory settings, see Microsoft Knowledge Base article 817379, "Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=817379).
0
 
andrefortier7Author Commented:
I do not have a Front End / Back End solution.

OWA is hosted on the same machine as Exchange is running (only 12 users).

Is there a way I can keep OWA running with SSL and still have OMA working?

If memory serves me correctly, it won't work.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
SembeeCommented:
You can have forms based authentication and SSL enabled with EAS.
The KB article linked to explains how to do it, but I find it has some flaws.
This article on my web site explains how to reconfigure OWA to work: http://www.amset.info/exchange/mobile-85010014.asp

Simon.
0
 
andrefortier7Author Commented:
Sorry for taking so long to get back to you.

Your article will be perfect.

Can I still get help from you if I get stuck??
0
 
SembeeCommented:
Either post back in this question or post a new question.

Simon.
0
 
andrefortier7Author Commented:
Hi Sembee,

I looked at the Microsoft KB article 817379 and 818486.
When I followed KB 818486 I now get a new error message.

I forgot to mention that I have 2 active NIC cards in the server.  One is used on the intranet and the other is hooked up to  a separate VLAN for remote backups.

Also, with only 15 users, OMA, OWA, SSL run from the Exchange Server.

Below is my new error message:
Source: MSExchange OMA
Category: 1000
EventID: 1503

An unknown error occurred while processing the current request:
Message: The remote server returned an error: (403) Forbidden.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


For more information, see Help and Support Ce
0
 
andrefortier7Author Commented:
If I follow your guide, will this resolve my problem?

If so, I will do this overnight
0
 
SembeeCommented:
You are getting forbidden. That is an authentication error. My guide should resolve the problem, that is what I do all the time and it fixes the problem.

Simon.
0
 
andrefortier7Author Commented:
The reason I ask is your article mentions doing a split DNS type scenario.  This I am not familiar on.
0
 
SembeeCommented:
The split DNS allows you to test and use the feature inside the network instead of having to rely on an external connection. It isn't mandatory to do that, but something I recommend when an SSL certificate is used. It means your users can get used to https://host.domain.com working both inside and outside. Makes training easier.

Simon.
0
 
andrefortier7Author Commented:
Cool.

thanks Simon.  Your article worked great.

Took me 5 minutes to do the whole transfer

Thanks!!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now