• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1152
  • Last Modified:

Citrix Presentation Server 4.5 - .Net application in AIE will only run with Admin rights -" .Net Framework Initialization Error"

Apologies in advance because I'm a self confessed citrix newbie....

I'm currently running a POC using the virtual machine from Citrix of Presentation Server 4.5.

I have one application (it's an in-house .Net app) that won't work straight up, as it writes to the filesystem and registry as part of it operation (and confuses any additionl clients) ... so I'm trying to use the AIE to get it up and running.

I have used both methods (assigning an already installed version to an IE and installing into the IE) and in both cases, the app will not work unless I log in with admin rights.  if I log in a s anything else, I get a .Net framework error:

---------------------------------------------------------------------------------------------
XXXXXXX.exe - .NET Framework Initialization Error
---------------------------------------------------------------------------------------------
To run this application, you first must install one of the following versions of the ,NET Framework:
v2.0.50727
Contact your application publisher for instructions about obtaining the appropriate version of the .NET Framework.
<OK>
---------------------------------------------------------------------------------------------


The server has the framework installed - and the app will run if not within the isolation environment - it will also run as admin.  I tried changing the NT perms on the AIE tree... HELP!!!!!


One other issue I'm having is trying to assign a set client name to my clients (so they don't end up with WI_xxxxxxxx_. I can do this if I download the ICA and set the client name on here ... can I do this anywhere centrally.
0
TelnetServices
Asked:
TelnetServices
  • 4
  • 3
1 Solution
 
thegordoCommented:
Hi there

Couple of things to try:

Have you tried installing it as normal using Process Monitor from SysInternals (www.microsoft.com/Technet/SysInternals). Then compare that output to the output during the installation into the AIE.
You can look for "Access Denied" entries in the output and you can address security/ACL issues that way.

Might be a silly question but when you installed the application, did you install it on a install session (change user /install)? All programs should be installed in "global" mode by running the change user /install command, or by using the Add/Remove Programs tool in Control Panel. This ensures that programs will work correctly for all users.


Good Luck!
0
 
chrisnewman01Commented:
Another thing to add to thegordo's response -- when you initially installed the app, did you use AIESETUP or did you install it through add/remove programs?
0
 
TelnetServicesAuthor Commented:
Hi all...

Not sure how to run in "change user /install" - though I have read that before (I did say apologies for being a citrix noob....).  I did run using AIESETUP and I did select to install for "all users" in the MSI dialog box....

Thanks all...
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
thegordoCommented:
To install an app to all users settings:

Logon as Admin to the Citrix Server
open cmd line - type "change user /install" and return
Install your application from CD or network drive via its setup.exe or msi
When install completed -
open cmd line - type "change user /execute" and return
Then test the app

This process will ensure that the application (if compatible with Citrix) settings will be written to all appropriate areas (ie registry) for all users...

Let me know how you get on....
0
 
TelnetServicesAuthor Commented:
Just to let you know... I haven't forgotten you.... just not had the opportunity to test yet..!
0
 
thegordoCommented:
No worries - let me know how you get on!
0
 
thegordoCommented:
I would be happy to share the points if that is an option...

Thanks,

JG
0
 
TelnetServicesAuthor Commented:
We finally solved our issue in a round-about way (by doing stuff differently!)

However - the change user /install advice saved the day here too... so points to thegordo - thanks JG!!!!

Steve
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now