Filter SMTP queue based on sender.

Our Exchange SMTP queue is being swamped by postmaster@ replies going to fake mailboxes reporting that the whatever spam was sent on their behalf did not reach the randomly generated names that do not exist on our server. Is there some way to make the "mailbox not found" replies to try once or twice and then go away? I found the settings for general SMTP sending timeouts and retries, but I want legitimate email to be queued up for 2 days as usual and the postmaster@ replies to timeout after one or two tries. Is there a way to do that? Maybe to filter it based on sender?

The server is 2003 SBS.
Tyson0317Asked:
Who is Participating?
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Even better than that?  Don't send NDR's at all for non-existant mailboxes.  Just enable the  "Filter recipients who are not in the Directory"  option and you will not have any further problems with those.

See:  http://www.msexchange.org/tutorials/Sender-Recipient-Filtering.html

Jeff
TechSoEasy
0
 
Tyson0317Author Commented:
Yea, the thing is, I want legitimate email that had been typo-ed to get an NDR (or at least try twice to send the NDR). So although this is a workaround, I would like to know how to actually specify that NDRs time out and go away after 2-3 tries and other email remain in the queue for 48 hours like normal.
0
 
tigermattCommented:
Without third party software I don't think there's any way for you to achieve that. Personally, I would also enable the setting as Jeff said. The sending mail server should reply with an NDR when message delivery fails, probably after it tries to do it 2 or 3 times.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
All email that doesn't have a proper user's address will get bounced when you enable that setting.  So, your server isn't sending out an NDR, but the sender is being notified that the message didn't go through.  That covers your typo concern.

Jeff
TechSoEasy
0
 
Tyson0317Author Commented:
Jeff, I did some reading on this and yes, your soltion tackles my problem from another angle but gets the job done nicely. I just turned this on and it seems to be working! Let's see what happens with my queue over the next few days, but this is encouraging!
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I had no doubt that it was the right thing to do.  Since I've made this configuration change on over 100 SBS's I know it works... also, you may have noted that in the article I linked, it states that it "is the single most overlooked important setting. It allows you to fight dictionary and other SPAM attacks"

Jeff
TechSoEasy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.