• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 624
  • Last Modified:

Public Folder Emails Routing

Hi,

I have a public folder which I have assigned an email address to and "Mail Enabled" it - it is to catch all emails via a form on our website, plus payment notifications from PayPal.
 
It is setup so that any email that drops in, is copied to a users mail box - strange this is that, the public folder does not get the email, but the users mailbox does!
 
It used to work perfectly but it stopped only since I have renamed a number of public folders - its like its confused - but how can I solve this?
 
This is where the setting is made:
 
"Sales" Public Folder Properties --> "Exchange General" tab --> "Delivery Option" --> "Forwarding Address" --> SBS Users Account selected here --> "Delivery message to both address and folder" is ticked.

Any help is greatly appreciated.
 
Jack
0
JackHodson
Asked:
JackHodson
  • 11
  • 10
1 Solution
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Rather than setting a forwarding address, you should instead create a DISTRIBUTION group.  Then, have the distribution group deliver the messages to whoever you want them to go to and enable the option to also ARCHIVE all messages to a Public Folder.  This is the preferable way to configure something like this.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Jeff, many thanks,

I jsut tried to do this, the progress box says "Creating Distribution Group" and the progress bar is at the end - but the "Close" button is blanked out. What should I do? Reboot? Its been like this for over 5 mins now.

Thanks
Jack
0
 
JackHodsonIT ManagerAuthor Commented:
It finally timed out - said it could not create the public folder, I will try again.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
It sounds as though you may not have a properly updated server.  Can you please post the results of running SYSTEMINFO at a command prompt?

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Still no luck creating the distrubution groups, I have tried different names, and email alias's - I thought it might be clashing as on the first attemp I used the same email address as was previously used for the public folders (now mail disabled)

Here is the SYSTEMINFO:

Microsoft Windows [Version 5.2.3790]
(C) Copyright 1985-2003 Microsoft Corp.

C:\Documents and Settings\Administrator>SYSTEMINFO

Host Name:                 QUAY
OS Name:                   Microsoft(R) Windows(R) Server 2003 for Small Busines
s Server
OS Version:                5.2.3790 Service Pack 2 Build 3790
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Primary Domain Controller
OS Build Type:             Multiprocessor Free
Registered Owner:          Jack Hodson
Registered Organization:   Infomed Research & Training Limited
Product ID:                74995-OEM-4212982-21754
Original Install Date:     26/05/2005, 14:53:58
System Up Time:            1 Days, 1 Hours, 42 Minutes, 13 Seconds
System Manufacturer:       HP
System Model:              ProLiant ML150 G2
System Type:               X86-based PC
Processor(s):              2 Processor(s) Installed.
                           [01]: x86 Family 15 Model 4 Stepping 1 GenuineIntel ~
2793 Mhz
                           [02]: x86 Family 15 Model 4 Stepping 1 GenuineIntel ~
2793 Mhz
BIOS Version:              PTLTD  - 6040000
Windows Directory:         C:\WINDOWS
System Directory:          C:\WINDOWS\system32
Boot Device:               \Device\HarddiskVolume1
System Locale:             en-gb;English (United Kingdom)
Input Locale:              en-gb;English (United Kingdom)
Time Zone:                 (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon
, London
Total Physical Memory:     2,047 MB
Available Physical Memory: 131 MB
Page File: Max Size:       2,666 MB
Page File: Available:      897 MB
Page File: In Use:         1,769 MB
Page File Location(s):     C:\pagefile.sys
Domain:                    INFOMEDOM.local
Logon Server:              \\QUAY
Hotfix(s):                 63 Hotfix(s) Installed.
                           [01]: File 1
                           [02]: File 1
                           [03]: File 1
                           [04]: File 1
                           [05]: File 1
                           [06]: File 1
                           [07]: File 1
                           [08]: File 1
                           [09]: File 1
                           [10]: File 1
                           [11]: File 1
                           [12]: File 1
                           [13]: File 1
                           [14]: File 1
                           [15]: File 1
                           [16]: File 1
                           [17]: File 1
                           [18]: File 1
                           [19]: File 1
                           [20]: Q147222
                           [21]: KB867460 - QFE
                           [22]: KB886903 - QFE
                           [23]: KB933854 - QFE
                           [24]: SP1 - SP
                           [25]: KB870669
                           [26]: Q832483
                           [27]: KB912442 - Update
                           [28]: KB916803 - Update
                           [29]: KB924334 - Update
                           [30]: KB926666 - Update
                           [31]: KB931832 - Update
                           [32]: KB917283 - Update
                           [33]: KB922770 - Update
                           [34]: KB928365 - Update
                           [35]: Q827429
                           [36]: Q927978
                           [37]: IDNMitigationAPIs - Update
                           [38]: NLSDownlevelMapping - Update
                           [39]: Q828026
                           [40]: Q828026 - Update
                           [41]: KB925398_WMP64
                           [42]: KB885492 - Update
                           [43]: KB931768-IE7 - Update
                           [44]: KB933566-IE7 - Update
                           [45]: KB889101 - Service Pack
                           [46]: KB914961 - Service Pack
                           [47]: KB925876 - Update
                           [48]: KB925902 - Update
                           [49]: KB926122 - Update
                           [50]: KB927891 - Update
                           [51]: KB929123 - Update
                           [52]: KB930178 - Update
                           [53]: KB931784 - Update
                           [54]: KB931836 - Update
                           [55]: KB932168 - Update
                           [56]: KB933854 - Update
                           [57]: KB935839 - Update
                           [58]: KB935840 - Update
                           [59]: KB935966 - Update
                           [60]: KB936357 - Update
                           [61]: KB936594 - Update
                           [62]: KB843539 - Update
                           [63]: KB872769 - Update
Network Card(s):           1 NIC(s) Installed.
                           [01]: Embedded Broadcom NetXtreme 5721 PCI-E Gigabit
NIC
                                 Connection Name: Server Local Area Connection
                                 DHCP Enabled:    No
                                 IP address(es)
                                 [01]: 10.42.51.1

C:\Documents and Settings\Administrator>
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Keeping trying won't help... you need to fix the problem.  Please follow the steps outlined in this Blog Post to do that:  http://blogs.technet.com/petergal/archive/2006/05/12/428152.aspx

Also, please be sure that you've installed all the appropriate POST-SP2 patches that are needed on an SBS.  The list of SP2 on SBS issues is here:  http://sbsurl.com/sp2

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Ok, major problems are being uncovered here.

I followed the guide, and then I noticed that a number of NDR were being sent in to our mailbox.

I looked at the queue and its become huge, 100s of emails there trying to send, I think, or they are just failing imediately - cant work it out.

We have done a lot of eshots to customers recently (about 5000 last month) and it looks like they have been stored up - although I wouldnt know this as I check the queue everyday and it looks normal and empty except for the deafult entires.

If you see this thread - there was the same problem yesterday:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q__22739658.html

I also posted my question on smallbizserver.net:
http://www.smallbizserver.net/Default.aspx?tabid=53&forumid=5&postid=71004&view=topic

This is not good and very worrying as it seems the server has been stacking up emails over the last month!

Jack

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Yeah, I saw that post as well.

I don't think that the server has been stacking things up... I think there is a potential that its resending messages that were already sent.  Are you using 3rd party software to send out your bulk email?  Or is it sent via Outlook?

Also, sorry about having your seemingly simple queston turn into so much... but it's times like these that we catch misconfigurations --- when the expectation is that things should just work.  Hopefully though we'll straighten it out so that things just work from here on out.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Jeff,
The server has settled down now, and I have an empty queue, although, now I know this means a lot less than it did before.

We send bulk email using either Word 2007 email merge tool, or we use "Mail Merge Toolkit" from MAPILAB if we want to send attachments. Both appear to link with Outlook and send the emails through there.

I had a similar problem a few months back after sending a big eshot - basically the DSN Messages for submission became very high, I forget what I did now, but NDRs came flooding back - at least at that time I could see the error in the queue.

The only unusual setting I have is under the Default SMTP Virtual Server properties:
Delay Notification: 30 mins
Expiration Timeout: 3 Hours

I set these once so that I knew of failures sooner rather than later, but I beleive the defualt is 12hours for Delay notes and 2 days for Exp Timeouts.

Thanks
Jack
0
 
JackHodsonIT ManagerAuthor Commented:
By the way, I called a few people and asked if they had got the emails, they said no - but then I was relying on thier memorys from over 2 weeks ago

Jack
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I would strongly suggest that you don't send out bulk email from your Exchange Server.  There are a number of reasons to handle this differently, some of the negative ones you've now experienced.  But there are some positive reasons to not send bulk email out yourselves... primarily TRACKING.  You wouldn't have had to call a few people to see if they got the email, you could have a full report of who received it, who opened it, what links they clicked to find out more information about, etc.  

The extra cost for using a third party is well worth it... just consider how much time you've spent cleaning up after this last one!  Plus the marketing reports that you get back are worth tons more than what you would pay to send the messages.  Because then you'll know what the true interest is in your message and what to focus on for the next one.

I've used a couple of companies for this... each has different attributes and weaknesses... but most all allow you to send your first message for free so you can try them out.  

Check out www.constantcontact.com and  www.feedblitz.com as two possible solutions.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Just some info:
I ran the MS Exhange analysis, coulple of results suprised me:

Non-default         SMTP 'msExchSmtpMaxOutboundMsgPerDomain' value changed        Server: QUAY
      The value for configuration setting 'msExchSmtpMaxOutboundMsgPerDomain' for SMTP instance 'Default SMTP Virtual Server' on server QUAY has changed. Default value: 20. Current value: 0.
      arrow Tell me more about this setting.


Non-default         SMTP 'msExchSmtpMaxRecipients' value changed        Server: QUAY
      The value for configuration setting 'msExchSmtpMaxRecipients' for SMTP instance 'Default SMTP Virtual Server' on server QUAY has changed. Default value: 64000. Current value: 0.
      arrow Tell me more about this setting.



And I certainly did not change those!

Also, Sembee mentions Greylisting, seems I could have this problem:
http://www.experts-exchange.com/Software/Internet_Email/Q_22736181.html

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
So, back to your initial question though... See if you can now create a distribution list.  If not, please follow http://blogs.technet.com/petergal/archive/2006/05/12/428152.aspx one more time.

Be sure that you are logged in with the built-in administrator account when doing this.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
I did follow that guide, and tried to make a new Distribution group, but I got the same error message about not being able to make a public folder - strange thing is, the new public folder does appear in the list!

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Oh... are you trying to name the distributon group the same as a public folder that already exists?  That's won't work.  You need to use a different name or delete the existing  PF.

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Jeff

Right, I rechecked the procedure, and either it reset to 443, or I didnt do it properly the first time. But I have now hanged it to double checked it.

Still no joy what ever I put as the name - none of them match a public folder name or an existing email address.

Jack
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Y'know... I had thought this issue seemed familiar and couldn't put my finger on the cause or solution when you first asked, but have now come across it and believe that this may be what's going on:

I believe that you've changed your Exchange server to run in Native Mode (no pre-Exchange 2000 Servers in the domain).  When you do this, the Add-Distribution-List wizard will fail at the create public folder step.  This behavior is expected and the option is a workaround (as I'll detail below).

To verify this, you will find the following at the very end of C:\Program Files\Microsoft Windows Small Business Server\Support\add_distribution_group_wizard.log :

SendHTTPRequest returned [0x80072efd].
pfDLFolder.GetProp returned 0x80072efd, count = 1, string is:
pfDLFolder.GetProp failed, string is empty
            Failed to create public folder with error [0x80004005].
            DoOfflineABTask() - Returned [0]

You can also check the mode of your Exchange server from Exchange System Manager, right-click the domain (Exchange) and click Properties.  Under Operation mode: it will probably state:  "Native Mode (no pre-Exchange 2000 servers)"

If this is the case, do not create a public folder during Add Distribution Group Wizard (i.e., do not check "Create a public folder to archive e-mail messages sent to this group"). When the wizard finishes you must manually create
a public folder in Exchange and then mail enable the folder. Then, open the folder properties and click the Member Of tab, click Add to add the distribution group you just created.

Sorry for the confusion... but hope that fixes things for you.

Jeff
TechSoEasy

0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
FYI, I had answered a similar issue here:  http:Q_22625083.html

Jeff
TechSoEasy
0
 
JackHodsonIT ManagerAuthor Commented:
Hi Jeff,

Spot on, yes it is set in Native Mode.

I followed your instructions, and strangely the email still did not drop in to the public folder. But after I scrapped this folder and made a new one they are working. Only thing I can think of is that the mail settings on the old public folder were corrupt or they do not like name with "." in them - it was previously named "z.Online Sales" - Now its just "Online Sales" - I only had a "z." to keep it at the bottom of the list.

Many thanks for your help.

I am going to start a new thread about the Exchange server now, I am still a bit concerned.

Jack
0
 
JackHodsonIT ManagerAuthor Commented:
btw, should I reverse this procedure or leave it as it is?
http://blogs.technet.com/petergal/archive/2006/05/12/428152.aspx 
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Glad you got it going.

Actually you shouldn't have modified anything per that blog article unless your settings were showing as it described.  If they were, then you can leave it.  If you changed things without really checking, then yes, reverse it.

Jeff
TechSoEasy
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

  • 11
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now