Comcast Cable Connection Won't Load Entire Page: DNS Problem?

Comcast is taking forever to download entire pages on an otherwise very fast connection (20Mbs).  While the site is obtained, for example Yahoo, the complete page for the location within Yahoo, e.g. Groups, takes a very long time to download.  By clicking stop, or stop and reload I can force the page to post quicker, sometimes.  It is very frustrating.
caryafAsked:
Who is Participating?
 
caryafAuthor Commented:
I seemed to have solved the problem via trial and error.

For what it's worth, Apple's Tech Support was NO HELP.  They refused to bump me up to people who knew networks, having me fool around with things that were of no consequence.  Did I real need to defrag a 500GB drive that only had been in use three weeks and had practically nothing on it?

I installed Firefox, then made the cache larger (to 100MB, from 50MB).  I MADE SURE Safara wasn't running at the same time!  This seems to have solved the problem.

Can I give myself points (LOL)
0
 
IanThCommented:
what version of firefox

have you tried reinstalling firefox
0
 
MshineCommented:
I would think if it were a DNS problem, you would not even be able to locate the
website at all.

Question 1. When was the last time you power cycled the Comcast Modem?
Q2. Have you tried clearing your cookies and temporary internet files?
Q3. What version of IE are you using, at least IE6 correct?
Q4. You may want to give Comcast a call. I did receintly, and the tech ended up
changing some cables and filters because mine were outdated and affecting my
connection speeds. (this is highly unlikely to be your problem, but possible)
Q5. Does this happen with ALL websites you go to, or just Yahoo Groups?

It's a start.. let's see what we can do!
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
caryafAuthor Commented:
The problem is with both Firefox (the newest version) and Safari.

I recycled the Comcast modem yesterday, made no difference.  Ditto cookies and cache.

What's strange is I did downloading tests on DSLReports which reported phenomenal downloading speeds, i.e 20Mbs.
0
 
MshineCommented:
Have you tried Internet Explorer??

As rediculous as it sounds, there are still many popular sites that only support
IE.
0
 
caryafAuthor Commented:
The problem is the site is identified, and it loads some elements, but can't load the entire website.  I doubt Yahoo only works on IE, but in any event I have a Mac and IE isn't an option!  My problem is with both Saftari and Firefox.
0
 
IanThCommented:
try doing a refresh

Command+Shift+R

it could be a cached page error and this should fix that
0
 
caryafAuthor Commented:
Nope.  Doesn't work.
0
 
iCoreKCCommented:
If you are using Firefox, update to the newest version.  IE, make sure all your patches are up to date.

I see the exact same issue happening for some of our users and have corrected it with a patch, upgrade, or Malware scan and dis-infection.  

It is almost lie the website doesn't load completely and fills up some cache.  Try having you users delete all files from theri Firefox or IE.  IOW all cache files.

0
 
-Mystique-Commented:
you also may want to clean out your old prefetch data.

2 Good freeware programs I've found for cleaning out old files and freeing up memory and space include:

Crap Cleaner
http://www.ccleaner.com/

Instant Memory Cleaner
http://www.vasileios.gr/freesoft/inst_mem_clean.htm
0
 
Jeff BrownGlobal Helpdesk SupervisorCommented:
NOTE  he is on a mac  mystique  those will not work for him.
0
 
serialbandCommented:
It may be ridiculous, but there is IE for the MAC.

As for your solution, increasing the cache size suggests that the "solution" didn't completely resolve the problem.  If that was the solution, then you are likely getting items out of cache, therefore speeding things up by loading cached items.  You may still be having issues with loading the page directly, but since you're loading from cache, you wont' notice.
0
 
dragonjimCommented:
agree with serialband here -- I think you may have just masked the problem...

To discount DNS... (and I am NOT familiar with MAC)... go to the equivalent of "command prompt"

PING www.yahoo.com
PING {the IP address above resolves to}

If you can PING by name and number, you're DNS is ok.

sounds like cache is the problem.
0
 
ryan_conlogueCommented:
"To discount DNS... (and I am NOT familiar with MAC)... go to the equivalent of "command prompt""

Terminal by going: HDD --> Applications --> Utilities --> Terminal

Commands are the same as a windows machine (ping)
Terminal wont stop after 4 tries so you will need to do Apple + C to bring back the prompt
0
 
edster9999Commented:
I use an add-on for firefox called YSlow  I think you also need FireBug to go with this.
It shows you which part of the page is slow and why.
I use it on a pc so you may have to check if it works on macs.

Hope this helps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.