Configuration of PIX506e firewall for MS Exchange

Posted on 2007-08-03
Last Modified: 2013-11-05
I have a Cisco Pix 506E firewall with the configuration below, however the Exchange server cannot receive mail while behind the firewall.

The Exchange server has two NIC cards Local ( and Wide ( . The wide NIC is a public IP address.
 If I connect the Wide interface on the Exchange server directly to my router and the Local interface to my network, Exchange works fine. If I put the Exchange Server behind the firewall no such luck.

Here is the config of the firewall with IP addresses masked .

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxxxxxxxxx
passwd xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
hostname pixfirewall
domain-name xxx-xxx.NET
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
name LAN_Inside
access-list outbound permit tcp LAN_Inside any eq www
access-list outbound permit tcp LAN_Inside any eq ftp-data
access-list outbound permit tcp LAN_Inside any eq ftp
access-list outbound permit udp LAN_Inside any eq domain
access-list outbound permit tcp LAN_Inside any eq https
access-list outbound permit ip any any
access-list outbound permit tcp LAN_Inside any eq smtp
access-list outbound permit tcp host any eq smtp
access-list outbound deny tcp any any eq smtp log
access-list outbound permit icmp any any
access-list inside_outbound_nat0_acl permit ip any
access-list outside_cryptomap_dyn_20 permit ip any
access-list ExchPer permit tcp any host eq www
access-list ExchPer permit tcp any host eq smtp
access-list inside permit icmp any any
access-list inside permit tcp any host eq smtp
access-list inside permit tcp any host eq www
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside
ip address inside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_1
pdm location inside
pdm location inside
pdm location outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 LAN_Inside 0 0
static (inside,outside) tcp smtp smtp netmask 0 0
static (inside,outside) tcp www www netmask 0 0
static (inside,outside) netmask 0 0
access-group outbound in interface inside
route outside 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server source inside
ntp server source outside prefer
http server enable
http LAN_Inside inside
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup kevin address-pool VPN_1
vpngroup kevin dns-server
vpngroup kevin default-domain xxx-xxx.NET
vpngroup kevin idle-time 1800
vpngroup kevin password ********
telnet inside
telnet timeout 5
ssh outside
ssh timeout 5
management-access inside
console timeout 0
dhcpd address inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80

Question by:KWhiteNYC
    LVL 25

    Expert Comment

    run this

    no fixup protocol smtp 25

    that makes it so the pix won't do mailguard which messes up communications with esmtp MTAs like Exchange
    LVL 79

    Accepted Solution

    Cyclops is right about the fixup, but....
    You don't have an inbound acl to allow email coming in

    access-list inbound permit tcp any xx.xx.xx.107 eq smtp
    access-list inbound permit tcp any  xx.xx.xx.107eq www
    access-group inbound in interface outside

    >static (inside,outside) tcp smtp smtp netmask 0 0
    >static (inside,outside) tcp www www netmask 0 0
    >static (inside,outside) netmask 0 0
    The last static overrides the first two.
      no static (inside,outside) netmask 0 0
     clear xlate
    Now the static matches the acl....

    LVL 1

    Author Comment

    Seems to be working with those changes

    Featured Post

    Courses: Start Training Online With Pros, Today

    Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

    Join & Write a Comment

    How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
    I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now