How To Send ATA Commands To HDD to Unlock Seagate Drive Please.  (Or Any Other Method)

Posted on 2007-08-03
Last Modified: 2008-01-09
I got a 10gig Seagate drive second hand and it turns out to be password protected. I get a message on boot that it is 'drivelocked' and needs a 'drivelock password'.

  Seagate doesn't seem to offer a way around this and I've found nothing else that will, either.

 But i did find in the manual for the drive (an ST310014A) that I managed to download from Seagate's site, that the ATA command for unlocking a drive is F2 Hex.

 Now I need a way to send an ATA command to a hard drive. Just that command is enough. I hope.  I figure systems programmers, Assembler or C maybe, would find this easy to do and I'm appealing for a routine that will do it.

 How a drive manages to keep a password without a battery has me beat, unless it is hard coded in - and then I can't see how you can lock/unlock the thing. But it certainly seems to be true. I can't find an answer on the web but I find enough references to the feature.

I suppose everyone understands that fdisk and such don't work - the drive is locked, it is not accessible. Seagate's own tools, which I downloaded, can't work with it.


ab  :)
Question by:abrogard
    LVL 32

    Expert Comment

    Is this a laptop drive? My suggestion would be just get another larger better drive. It is doubtful you'll be able to break that drivelock protection without professional help costing many times what that drive is worth.

    You may find these useful:
    LVL 91

    Accepted Solution


    Author Comment

    It is not a laptop drive.  It was an Xbox drive. After reading all the links kindly suppplied (except the ftp.compaq one, it wouldn't work) I'm of the opinion that's where the damage was done.

    Thanks for the rockbox thing. It seems to  be about the only glimmer of hope. I'll give it a try.

    Yes, the drive isn't worth much, I can throw it away, but we'd like to know, wouldn't we? And be able to fix it?

    I'll get back to you if I can fix it.  I've contacted the guy I bought it from and he seems unaware - thinks it can be partitioned with partition magic - well I haven't tried that but I rather think it can't be partitioned with anything at all if fdisk can't do it, etc....   So I think he doesn't know what's going on... I forward the links and enlighten him...

    LVL 91

    Expert Comment

    keep us posted . .

    Author Comment


    Well the rockbox thing ( didn't do it.  It reported that the commands were not accepted by the drive.

     Looks like it's not as simple as finding the right interrupt and banging out F2Hex. I'm sure the atapwd thing would have done that.

     It's all too difficult.  I still haven't got a clear understanding of how they manage to do it - in hardware terms - but it looks like they keep the password in the hard drive electronics and it stays there even without a battery.  And then after a certain number of failed attempts it writes something else and that's the end of it, no further chance of unlocking that drive.

    To such an extent, wrote one writer, that in IBM I think it was, where he worked, they'd just automatically junk drives that got locked, with no attempt to rescue them at all.

    This drive of mine asks for a password and won't move on without supplying something, upon which it asks again on a new line. I guess each time that happens it counts as one 'failed attempt' and maybe atapwd won't work now because the drive has gone into that 'ultimate lock' state.

    I contacted the vendor. He's going to send me another drive.

    He says you need the original Xbox machine to fix this.

    SO.... I guess the poster who suggested takes the cake. I'm guessing that's what I asked for: something to write F2 hex to the hard drive.

    I don't think there's any better software out there.

    Possibly there's a fix something like 'Get an Xbox and blah, blah....' but, according to the vendor, not really.. you need the original, he thinks.

    This is very interesting. I'd like to know just how the electronics writes this thing and keeps it.

     I shall go back and accept nobus' post as a solution.


    ab  :)

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
    In this article we will discuss all things related to StageFright bug, the most vulnerable bug of android devices.
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now