• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1002
  • Last Modified:

Hiding security tab from domain clients?

Hello and good day!  

I have a 2003 domain server.  How can I hide the security tab on folders from domain clients?

Thanks
0
Victor_Torres
Asked:
Victor_Torres
1 Solution
 
weellioCommented:


1. Log on to the computer running Windows NT Server or Workstation as a local user who has Administrator rights.  
2. Open Windows NT Explorer and go to Winnt\System32.  
3. Search for the Rshx32.dll file.  
4. Go to the Properties of this file.  
5. Click the Security tab and then click Permission.  
6. Remove the Read permission of everyone and then add the appropriate rights to the appropriate users or user groups.  
7. Restart the computer.  
Now, only the users who have been assigned the rights can see the Security tab.
0
 
oBdACommented:
weelio,
that article is about Windows 2000.

It's gotten easier in an AD domain with XP clients. Simply set the policy "Remove Security Tab" in User Configuration\Administrative Templates\Windows Components\Windows Explorer to "Enabled" in a GPO applied to the user accounts in question.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
Victor_TorresAuthor Commented:
Hello oBda;
       I tried your solution but for some reason I can't get it to work.  It seem that I'm missing a step.  Would you happen to have the step by step to this solution?

Thanks
0
 
weellioCommented:
from memory (hopefully i'm not too far off)
setting up the gpo

open dsa.msc (active directory users and computers)
go to the OU that you want the policy to be applied to
right-click on the OU - choose properties
click on the group policy tab
click add
type the name
click edit
goto here (haven't verified it's there, buthe said it was)
User Configuration\  
 Administrative Templates\
  Windows Components\
   Windows Explorer\
    "Remove Security Tab" set to "Enabled"

close, then go to the workstation with a user that is logged on in the OU

start - run - gpupdate /force
yes to logoff or reboot, depending on what it asks

log on and it should be set
0
 
Victor_TorresAuthor Commented:
Thanks for the help weellio I really appeciate it .  I was able to removed the security tab by following your procedure with one more additional step.  I had to click on division > right click the right pane > new > Organizational Unit > creat new name > right click the new name > properties > Group policy click add > all >choose removed security policy > exit out > then drag the user name to that Division.  
      Is the additional step necessary or I'm just missing something from your procedure?  
 I also tried to undo the changes but I can't get the security tab to show up again...



 
0
 
weellioCommented:
did you ever get your security tab back?
0
 
b0jenglesCommented:
Also another way of disabling the security tab from any user or groups is to deny file access to the following files:
Windows XP X64: "%SystemRoot%\Syswow64\rshx32.dll"
Windows XP x32: "%SystemRoot%\system32\rshx32.dll"

It will just not show up when looking at folder properties. Simple but it works.
Hope that helps someone.
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now