• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1429
  • Last Modified:

remove printers using IPrint policy

Hi,

We deploy printers using  workstation Iprint policies. Teachers can also manually install printers using the web interface \servername\ipp. However, we need to seriously think about this option as too many departments are complaining that people are hooking up to their printers without asking.

I need to remove any printer that is not in a policy for a particular department. I thought this would be a simply procedure...

I check the box that reads, "remove any installed Iprint printer that is not included in the list"  and would expect to see all manually added iprint printers which are not in the policy removed. This does not work. All printers remain.

 Is this a bug or is my thinking wrong?

Thanks in advance

Neil


0
neoice
Asked:
neoice
3 Solutions
 
alextoftCommented:
What you're doing should, in theory, work.

If you could tell us which versions of Netware and Zen you're using, any support packs applied, and what version of the iPrint client you have on your workstations, that would be very useful.

0
 
BudDurlandCommented:
Isn't access to iPrinters controlled by eDirectory?
0
 
ShineOnCommented:
Are you using ZEN iPrint printers policies or is this strictly via the iPrint auto-install/auto-remove feature?

The version of the iPrint client is very important - there were some versions that had problems with uninstall/reinstall functionality.

Does the printer removal policy work if the printer that should be removed was added via a printer install policy - or does it fail to remove any printers, regardless?

Are any of the printers installed via add/remove printers rather than via iPrint?  That's yet another issue.
0
Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

 
neoiceAuthor Commented:
Hi,

Sorry for the delay I have been away for a short break.

We are running Netware 6.5 SP6 and applied recent IPrint patches. Iprint version 4.26 and a mixture of zen 4 and 7 agents. Zen 7 server.
Currently I am trying to bring consistency to the college as we have different versions of 32 NW clients, Iprint and ZEN agents.

We have managed to automatically roll out the Iprint clients and now working on ZEN and NW client 32.

we do not use Imanager to deploy printers, just to create and manage printers. We use workstation polices to roll out printers. For example, we would have an ict support workstation policy where we would configure the iprint option to deploy printers. we have a workstation policy for each department so have several. These policies are then associated with a department container.

This works fine accept if a teacher installs a printer using \\server\ipp it does not get removed if we check the box in the policy.

If we remove the printer from the policy it is then unistalled.

cheers



0
 
ShineOnCommented:
Interesting.

The policy package doesn't roll out printers, just preps iPrint to accept them, or does it roll out the printers?

The problem is the uninstall policy as opposed to simply removing the printer from the policy altogether - removing the printer from the policy will uninstall the printer that was previously manually installed via the \\server\ipp method but otherwise the printer stays despite the uninstall option set.

Is there any difference between ZFD4 and ZDM7 iPrint printer management?  If you're using ConsoleOne for managing your ZEN objects, are the snapins in place for supporting the current ZDM7 or are they ZFD4 snapins?  
0
 
ShineOnCommented:
What was the solution?
0
 
neoiceAuthor Commented:
Hi,

We have yet to find a solution. I thought it was unfair leaving the question open as people have commented. I have set up a VMware development environment to try and find a solution. If I succeed I will let you know.





0
 
neoiceAuthor Commented:
Just an update to say I have resolved the issue.

log into Imanager>Iprint Client management

I had found that there was a tick in the 'allow only specified printers to reside on workstations' - this was not present in my development network. I removed the tick and hey presto! everything is working as I would expect.

Cheers,

Neil


0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now