Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4150
  • Last Modified:

Ethernet and Wireless stopped working

We have a comcast modem, and a dlink wireless router at home. It has been working for 9 months  no problem. Last week one day we lost the wireless access. The ethernet reported a network plug was disabled, but still could access the ethernet. I looked at the status of the LAN iom Windows - the default gateway had changed from 192.168.1.0, to 68.x.x.x - a comcast IP.

I replaced the router with a linksys wrt4g, hoping it was related to Dlink, but no such luck. We can reset the cable modem, then the router, and get wireless and wired working for about 12-15 hours straight, then we lose both. The default gateway in the status is again changed from 192.168.1.1 (Linksys) to 71.225.32.1 - I believe that is also comcast.

I have looked here and on other message boards and have tried a few things - disabling the VPN, changing the wireless channel to 11 for example. But I cannot get the network to stay up, and environmentally  nothing changed when this happened. I thought perhaps comcast might have done something but if I bypass the router and plug into the cable modem directly I can get to the internet no problem without resetting.  

I could use some help here, as I really am at my wits end. There are 2 windows machines and one mac connected wirelessly, one windows desktop running XP home media.

Thank you.
0
jfmclaughl
Asked:
jfmclaughl
  • 8
  • 7
  • 5
2 Solutions
 
captainCommented:
Hi jfmclaughl

sounds like you have a DHCP issue here, are you sure that you have only one DHCP in the chain and that the modem does not serve requests.

Way to test is to either disable DHCP in the router or simply set fixed IPs for your PC/MACs

hth
0
 
Fred MarshallPrincipalCommented:
It would be good to be clear about which computers are connected wireless and which are wired because you mention both.

It seems strange that you'd be getting a public IP address on the LAN side of the router.  More strange that this would happen with two different routers!

This suggests a couple of things to look into:

Is there any software installed on any of the computers that came from the ISP for internet access?  I can't imagine how this could affect the router but .. who knows.  You shouldn't need to install or run any ISP software on any of the computers.  

Some routers can be set up as a "gateway" in which case Network Address Translation (NAT) is turned off.  However, most home routers run in "gateway" mode *and* continue to provide NAT - which is what you have as these things start up and work.

If the modem has a USB connection, it should *not* be connected to anything - assuming you're using Ethernet.

The system should look like this:

[Modem]
<>Ethernet cable
<>WAN or Internet port on Router]------[LAN port on Router / Wireless]
<>Ethernet cables or Wireless
<> All the computers.

More often than not these days the Modem will provide NAT and you won't see a public IP address anywhere on your network / cables ... only on the Modem status interface.  Then, the Modem will have a private IP address on the LAN side .. just like the router.

It is easiest to keep the router operating in its "normal" mode, providing address translation.
If the Modem doesn't provide address translation, but rather a public IP address as yours seems to to, then the WAN side of the Router will be assigned a public IP address of the sort you've reported ... just set it to get an IP address automatically on the WAN / internet side.

The LAN side of the router should have a private IP address like 192.168.1.1 (most usual and applies to Linksys).  With DHCP turned on (the usual default), your computers should be able to get addresses automatically in the range 192.168.1.xxx.

If the Modem *does* provide address translation, it's a good idea to have the router WAN side and LAN side on different subnets or address ranges.

It's still a good for the Router to "automatically" get its IP address from the modem to simplify name service (DNS) and, thus, typical internet access.
Then, if the modem LAN address is 192.168.1.1, you will want the router LAN address to be in a different range like 192.168.0.1 or 192168.2.1.  That would be done manually through the router control interface.  

I rather expect there's an extra cable involved if you're getting public IP addresses on any of the computers.  A USB cable perhaps?


0
 
jfmclaughlAuthor Commented:
I did look at the tcp properties on the desktop (ethernet connection) and it is set to get an IP automatically. The router is set to do the DHCP, I don't know about the cable modem. Any way to check that? Or do I need to ask Comcast? Would they (can they) change something like that remotely without notice?

I will call them tomorrow and also do what you suggest. It's either/ or - disable DHCP or set fixed IPs, right?

Thank you.

j
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
captainCommented:
Hi

first work through fmarshall's post to make sure your connection is as he suggests.

the modem will have an IP address that you router uses as a gateway to the Internet. if  you use this is a bowser then you should get an interface. This would allow you to set/check DHCP.

If you disable DHCP in your router, you  can also check what is happening by going to one of your Windows machines and go to Start|Run and type cmd. at the prompt type IPCONFIG /release * and then IPCONFIG /renew. If you have another DHCP in the frame then you will have a new IP assigned.

But as said work through fmarshall's post first, it is virtually your setup guide.

best wishes
0
 
captainCommented:
btw " you use this is a bowser" =you use this in a browser...

me an my thick fingers
0
 
captainCommented:
Hi j

if you do a iPCONFIG /all at the same prompt you can see which IP is currently serving the DHCP requests, something like:
C:\>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : yourpc
        Primary Dns Suffix  . . . . . . .
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . :



Ethernet adapter Nic:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : adapter type
        Physical Address. . . . . . . . . : 00-00-00-00-00-00
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.0.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.1
        DHCP Server . . . . . . . . . . . : 192.168.0.1
        DNS Servers . . . . . . . . . . . : 192.168.0.1
        Lease Obtained. . . . . . . . . . : 05 August 2007 21:46:33
        Lease Expires . . . . . . . . . . : 08 August 2007 21:46:33

hth
0
 
jfmclaughlAuthor Commented:
Hi fmarshall,

here is what I can tell you as far as your questions.

<It would be good to be clear about which computers are connected wireless and which are wired <because you mention both.>
The Desktop is wired and is a windows xp media sp2, one wireless is a sony vaio, one wireless is an apple ibook, and the last wireless is a dell. I am not sure what the vaio is running, have to check that, and the dell is xp professional.

<It seems strange that you'd be getting a public IP address on the LAN side of the router.  More strange that this would happen with two different routers!>
Yes, and all out of the blue everything was working great,  then yikes!

This suggests a couple of things to look into:

<Is there any software installed on any of the computers that came from the ISP for internet access?  I can't imagine how this could affect the router but .. who knows.  You shouldn't need to install or run any ISP software on any of the computers.  >

I'll check. Nothing was installed before. I'm not home right now, but when I get there tomrrow evening, I'll check.

<Some routers can be set up as a "gateway" in which case Network Address Translation (NAT) is turned off.  However, most home routers run in "gateway" mode *and* continue to provide NAT - which is what you have as these things start up and work.>

This router is configured as "gateway" (the linksys). I'll look and see if I can see NAT on or off and post.

<If the modem has a USB connection, it should *not* be connected to anything - assuming you're using Ethernet.>

There is no USB on the modem.

<The system should look like this:

[Modem]
<>Ethernet cable
<>WAN or Internet port on Router]------[LAN port on Router / Wireless]
<>Ethernet cables or Wireless
<> All the computers.>

<More often than not these days the Modem will provide NAT and you won't see a public IP address anywhere on your network / cables ... only on the Modem status interface.  Then, the Modem will have a private IP address on the LAN side .. just like the router.>

I do have an ethernet cable to wan port on the router, and an ethernet for the desktop  to the router  (port 2).

<It is easiest to keep the router operating in its "normal" mode, providing address translation.
If the Modem doesn't provide address translation, but rather a public IP address as yours seems to to, then the WAN side of the Router will be assigned a public IP address of the sort you've reported ... just set it to get an IP address automatically on the WAN / internet side.>

Set the router to get automatically, is that what you mean? The desktop is set to that. And the router picks up whatever the modem sends it, including the DNS addresses.

<The LAN side of the router should have a private IP address like 192.168.1.1 (most usual and applies to Linksys).  With DHCP turned on (the usual default), your computers should be able to get addresses automatically in the range 192.168.1.xxx.>

Yes - the linksys is configured to 192.168.1.1.

<It's still a good for the Router to "automatically" get its IP address from the modem to simplify name service (DNS) and, thus, typical internet access.
Then, if the modem LAN address is 192.168.1.1, you will want the router LAN address to be in a different range like 192.168.0.1 or 192168.2.1.  That would be done manually through the router control interface.  >

Ok, I can try that.

< I  rather expect there's an extra cable involved if you're getting public IP addresses on any of the computers.  A USB cable perhaps?>

There is no additional cable, but I'll double check that.

Thanks,

j
0
 
Fred MarshallPrincipalCommented:
I might have also added:

Assuming that the cable modem does its normal job then you do *not* want to enter any login information into the router - but rather have it "get an IP address automatically" or "dynamic IP address" on the WAN.  The router acts as the "only" computer connnected to the modem.  Presumably the modem does the work of making the connection and the router just needs to get an address when it's connected.

That seems the typical arrangment these days....

0
 
jfmclaughlAuthor Commented:
Hi Captainreiss,

I'll ipconfig and post back that, too. Thank you.

j
0
 
Fred MarshallPrincipalCommented:
Oh ... thanks for the detailed answer!

When you say that the wired computer is on Port 2 and the modem is on the WAN port, consider this:

If you wire the modem to one of the LAN ports on the router, then the router will act as a simple switch and NOT as a router with NAT.  (Actually this is a handy way to avoid double NAT, if the modem is also a router, and to keep all the computers able to talk to one another on the same subnet.)

But, for your purposes, you want to assure that the Ethernet cable from the modem is actually plugged into the WAN or Internet port or the router and *NOT* into a LAN port on the router for some reason or accident....  
Somehow it feels like this has what's happened.  That would account for a computer getting a private address at times (from the router DHCP service) and a public address at times (from the modem).

You want the modem isolated from the LAN with NAT - either provided inside the modem (it appears not to be the case here) or with the router.
0
 
jfmclaughlAuthor Commented:
fmarshall,

positively, the modem ethernet cable is plugged into the wan, not a port. No worries there.

Thx,

j
0
 
Fred MarshallPrincipalCommented:
Hmmmm ... well, there has to be some mechanism for the wired computer to be getting a public address.
Just to be sure, the addresses you gave are the actual addresses, right?
The addresses couldn't be in the APIPA range:
169.254.0.0 to 169.254.255.255 could they?
That means there's no other source and the computer generates it itself.

Otherwise, with no cables in the wrong places it pretty much has to be coming through the router - and that seems rather highly unlikely having tried two different routers.

Let's get down to specifics regarding the Linksys router.  Model and settings.....

What does the Status page say?

Sometimes to troubleshoot things like this it helps to set a static IP address on a wired computer.
For the Linksys you would start with something like this:
In the Ethernet interface Properties:
Set the IP address to:
192.168.1.2
255.255.255.0

and enter DNS servers for Comcast:
68.87.66.172
68.87.96.3
(maybe you don't need the DNS addresses but it could be handy if you have to look something up on the web as you work through this....)

Then, with your browser, log in to the Linsys by entering for the URL / Address:
192.168.1.1
This will take you to the Linksys control panel.
The default login is
 user: admin
and
password: [blank]

If at first it doesn't work, try try again..... Sometimes browsers and this interface are finicky and the only solution I know is to just keep trying.  You might delete all the temporary internet files to help it on its way if it becomes too frustrating.

Then go to the status page and you should see the WAN/internet IP address and the LAN IP address - which will need to be 192.168.1.1 for this to work......

Once you can get to the router control panel then you should be able to carry on a conversation here about what's going on.



0
 
Fred MarshallPrincipalCommented:
I just re-read your original post.
If, on the wired computer, the Ethernet connection is gone and, yet, there is still internet access then there is MAGIC going on.
Or, I'm going to have to push a bit harder on the cable configuration and ask about a wireless interface on that "wired" desktop!

Either there is another cable, Ethernet or USB or there is a wireless connection.  Something has to support an internet interface when the "Ethernet cable is disconnected".  And, something like that might explain how you're getting a public address as the gateway on the computer's intervace.
It's important to note *which* interface has that gateway.
Ethernet?
Wireless?
etc.

Now, an intermittent Ethernet cable could cause the "disconnected" message now and then while still giving the impression that you have a more or less good internet connection.  So, that's worth a look but is a bit of an aside in this addressing question.  I would be suprised if it seems to work very well though.

Anyway,  I'd suggest that you confirm once more that the Ethernet cable between the modem and the router is plugged into the "Internet" port on the WRT54G - which on the WRT54G is set apart from the other ports at the left end of the rear panel.  And, I'd suggest that you plug the wired computer Ethernet cable into Port #1 and confirm that ports #2 through #4 are empty.

Sorry to be so pendantic but this seems central to the matter.
0
 
jfmclaughlAuthor Commented:
Sure, I have no problem with your ideas - I'd do the same thing if I were you. I'll double check the cable, move the wired to 1, post the ipconfig /all, and configure the desktop to a static number 192.168.1.2.

You won't hear from me until  9:30 tuesday am, Eastern time. That's when I have a window to post the results. So don't think I've abandoned the question, just unable to pursue it until then. OK?

What vexes me the most is that this was working fine and then kaput. Does this happen with Comcast? I had Verizon DSL and this never happened.

Thanks for all your ideas.

j
0
 
Fred MarshallPrincipalCommented:
I don't know.  I did see some messages regarding Comcast and DNS complaints but I didn't pay too much attention to them and didn't note the dates.  If somehow the DNS servers get messed up then it could appear that you don't have internet connectivity - when you really do ... to a point.

But, getting a public address on a LAN computer through a router ... that's a puzzle unless the router is bypassed with a cable or is being used as merely a switch (based on how the ports are connected / not connected).
0
 
jfmclaughlAuthor Commented:
I have looked at the system now, and it appears to be working ok. The router says it has been up for a couple days (I have been away this weekend). I did the following -

I checked these things without rebooting anything, unplugging anything to keep the environment as I found it:
*** There is no USB cable from the cable modem.
*** The ethernet cable from the cable modem is plugged into the Internet port of the WRT54g
*** I brought up all 3 wireless (and added another from work) and they are fine.
*** I went through add/remove programs and there is no cable software installed on the desktop. There is NetZero and Earthlink installers there, I assume for dialup and placed by dell on the machine.
*** I did an ipconfig /all from the wired desktop and got these results:
Windows IP Configuration
        Host Name . . . . . . . . . . . . : Wired_Desktop
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : hsd1.pa.comcast.net.
Ethernet adapter Local Area Connection:
        Connection-specific DNS Suffix  . : hsd1.pa.comcast.net.
        Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller
        Physical Address. . . . . . . . . : 00-13-72-32-53-43
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.100
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 68.87.64.146
                                            68.87.75.194
        Lease Obtained. . . . . . . . . . : Tuesday, August 07, 2007 9:03:11 AM
        Lease Expires . . . . . . . . . . : Wednesday, August 08, 2007 9:03:11 AM

*** This looked right - the linksys is the DHCP.
*** I wrote down what was on the Router's status Page:
mac address = 00:1A:70:F6:0F:44
IP ADDR = 71.225.120.183
Subnet Mask = 255.255.255.0
Default Gateway = 71.225.120.1
DNS1 = 68.87.64.146
DNS2 = 68.87.75.194

*** The default gateway in the above status is like what was showing up on the desktop as the deault gateway when I first posted (different address, but this comcast address instead of 192.168.0.1). But things look ok now. The cable modem type is SB4100.

*** Then I did the following:
*** I moved the wired desktop LAN cable from port 2 to 1, and verified, that it is on (1) and 2-4 are not lit.
*** Tried to recreate a normal traffic day with outlook, IE etc doing stuff, started the Remote Desktop from a couple remote machines using gotomypc, downloaded a couple updates for the ibook. Everything is fine.

I am really confused now. This is how I thought it should be, and how it was for nine months with the dlink, except for last week. I hate to disturb sleeping dogs, so I will do the other items here if the network goes down. I'd like to leave this open a few days, and make sure it isn't going to go down. Would there be any objections to that? If the network hangs together this week, I'll close the question and award all the points. I hate things that fix themselves - they always come back to bite you.
0
 
captainCommented:
Hi j

This is how we thought ought to be, everything looks fine and you confirmed what we were thinking. The fact that it works now suggests that there has been something else going on.

Was there a possibility (little brother sister cleaner friend) unplugging something and not putting it back right? As fmarshall said you do not get external IP on the LAN side unless you confuse the router about which side these ports are on.

How does the Router get its IP, is this manually set on first config or does the modem provide this. If you browse http://71.225.120.1 do you get a control panel or login?

All the best
Tom
0
 
jfmclaughlAuthor Commented:
Tom,

That is certainly possible the first time the problem occurred, but I personaly went out and got the linksys and hooked it up myself. It worked for a while then I went through all the motions again, including calling Comcast (which we just reset stuff, it worked for a while, died 12 hours later).

I've got the clock running - so I'll post back at the end of the week. Thank you to everyone, I hope I didn't waste your time. If it's any consolation, I learned some things.

j
0
 
Fred MarshallPrincipalCommented:
In the end, or is it really at the beginning .... ?  

The first thing to always do is to reboot the router and modem.
I've seen very strange things out of a router before it was reboot and suspecting that to be the cause was hard to get around to believing.

So, it's a matter of rote: reboot the boxes with a power off / power on cycle before doing too much other troubleshooting.  I have to do that here every few months.

So, just in case you didn't do that at the time of the initial problem ......
0
 
jfmclaughlAuthor Commented:
No, I rebooted my brains out. Cable and router. Stay tuned, I'll let you know at the ed of the week the scoop.

Thanks a bunch.

j
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

  • 8
  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now