[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1957
  • Last Modified:

Secure Channel Required

When we set up OWA initially on our Exchange 2003 server, we created OWA as a separate site in IIS with a SSL cert so we can access the site externally.  Now we'd like to move that site back under the default web site so we can implement RPC over HTTPS.  We have everything pretty much working except when we want to configure SSL under the default web site for OWA.  We're using a redirect page to redirect an unsecured site to https.  So when I access the site using http://email.domain.com and it tries to redirect I get "Secure Channel Required
This Virtual Directory requires a browser that supports the configured
encryption options"
from the web browser (using IE 7).  But if I access the site https://email.domain.com I have no problems.  Any suggestions?
0
resourcepc
Asked:
resourcepc
  • 2
1 Solution
 
shverCommented:
Have you tried disabling the SSL requirement for the redirect page?
0
 
resourcepcAuthor Commented:
Thanks.  I have that part working, now the only problem I have is if I enter the external FQDN that I assiged OWA I am prompted with the pop-up window.  But if I enter https://email.domain.com/ExchWeb/bin/auth/owalogon.asp I am presented with the FBA logon page.
0
 
resourcepcAuthor Commented:
I figured that out.  Under the default web site, I had to redirect to https://email.domain.com/exchange instead of just https://email.domain.com like I did under a different site in IIS.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now