Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 708
  • Last Modified:

Unable to configure network connection properties.

A recent install/uninstall of the Cisco VPN client seems to have removed my ability to configure the Local Area Connection properties on my Win2003 X64 server.  TCP/IP is functioning correctly, but I am no longer able to access its properties in the connection properties dialog box/General tab.  In the 'This connection uses the following items' box, only 'Client for Microsoft Networks' is listed.  If I click the Install button, I see the Client/Service/Protocol list, but clicking the Add button (with any of the three selected) only produces an error message 'Could not add the requested component. The error is: The system cannot find the file specified'.  Like I say, TCP/IP is actually working, but I would like to fix this before it becomes a problem.
0
LeeDerbyshire
Asked:
LeeDerbyshire
  • 2
2 Solutions
 
chuckyhCommented:
might want to run a sfc /scannow  or reinstall tcp/ip
http://support.microsoft.com/kb/325356
0
 
Farhan KaziSystems EngineerCommented:
Verify following:

Start, Run, RegEdit

Goto following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
Scroll past the folders to show this value: DevicePath

The value should be %SystemRoot%\Inf and of type REG_EXPAND_SZ."
If not then modify as above, after a reboot, everything should work perfectly.
0
 
LeeDerbyshireAuthor Commented:
farhankazi - The registry value is as you describe.

chuckyh - I'll have a look at that article.  Might take a while!
0
 
LeeDerbyshireAuthor Commented:
I ended up doing a system restore from a recent backup, which fixed the problem, but thanks for the suggestions.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now