[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4771
  • Last Modified:

Mas90 report with FRX Problem

Hi, We run MAS90 and I have  a user that is trying to use FRX to get financial reports. I know next to nothing about databases. So I got my odbc driver all set up and it passes connection test with the credentials I give it. When I go to FRX 6.7 Report Designer and add all my company DB information (Which I am about 90% sure is all correct.) I get to the point where it asks me for my login information. The setup I attempted before wouldn't even prompt me fr login so I have to assume that I am hitting the DB now. I enter the same credentials that I set up in ODBC driver and I get the error:

The login failed for the (Company code) company. Make sure the login ID and password are correct and verify the settings on the System Specific Information page in Company Information:

FRx32.OFSIMain.CheckOFSIConnection
8900: A DirectLink error has occurred  during the ConnectToFinSysEntity procedure

Now I dont pretend to know much about setting this up but it doesnt really seem THAT complicated, it looks for certain file that we have only in certain places on our DB server, but who know I could be completely wrong....Any help would be sooooooo appreciated. Thanks
0
JReacher
Asked:
JReacher
1 Solution
 
ewlodarczykCommented:
Since you are using FRx version 6.7, I'm assuming that MAS90 version is greater than 4.10. First, make sure that you have selected the Allow External Access check box in Company Maintenance/Preferences in MAS90.

FRx 6.7 does not play nice with the default SOTAMAS90 DSN, and Sage recommends creating a user DSN for use with FRx. Follow these directions to set up a DSN for use in FRx:

1. In FRx, select  Company / Information / System Specific Information and click 'Define'.
2. Select 'Add' on the 'User DSN' tab.
3. Select 'Sage MAS 90 32-Bit ODBC Driver' (MAS 90 4.0 ODBC Driver if using 4.10) and click 'Finish'.
4. On the 'Basic' tab, enter a Data source name and Description.
5. Enter the path to the \MAS90\ directory.
6. Select the 'Options' tab.
7. Enter the path to \MAS90\SOA\ directory in the 'Prefix' field.
8. Enter the path to \MAS90\Home directory in the 'Views DLL' field.
9. Select 'Dirty Read' and 'Burst mode'.
10. Select 'Apply'.
11. Select 'OK'

Leave the Logon information blank. When you configure the company in FRx, enter the MAS90 logon information when prompted for Logon and Password.

If you continue to receive the error, look into the following:
> The user may not have access to the MAS90 data files. All FRx and MAS90 users should have 'Full Control' permissions to the MAS90 parent folder.
> Try deleting and recreating the company in FRx.
> Try rerunning MAS90 workstation setup to upgrade the MAS90 ODBC driver

If all else fails, run the PVXCOM utility on each workstation using FRx:
1. In WIndows Explorer, go to ..\Mas90\Home\
2. Double-click Pvxcom.exe

Good luck.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now