• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 853
  • Last Modified:

Enterprise manager backup setings

Running 10g on Windows 2003
IN EM i go to  preferences->preferred credentials->host->normal user name/normal password and get credentials success.
Then i go to backup settings, enter the directory g:\machime_backups.
When i go to test i get message :
open2: IO::Pipe: Can't spawn-NOWAIT: No such file or directory at - line 602

I know the directory exists;
What is the problem here?
0
xoxomos
Asked:
xoxomos
  • 5
  • 3
1 Solution
 
joebednarzCommented:
EM is looking for a "DIRECTORY_OBJECT"... it is a database object, called by some name, that specifies a physical directory.

Actually a fairly nice construct because you create the object, e.g., CREATE DIRECTORY xyz AS 'C:\my_directory';

From there, you can specify privileges to users in your database by using simple GRANT/REVOKE syntax.  So you can have, GRANT read, write ON xyz TO joe_user;
0
 
xoxomosAuthor Commented:
You mean like
create directory abc as c:\backup_directory
grant read, write on directory abc to joe;
?
0
 
joebednarzCommented:
Didn't read your post closely enough...

First, you might want to check to see what user the Oracle process is running under, then, check to see if that user has privileges to write in that directory.

Also, if G: is not a local drive, you might be in for some trouble... in the past (on Linux) I've seen Oracle complain about writing to a drive that is not local... just a thought.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
xoxomosAuthor Commented:
I was trying to specify directory as 'G:\dir1\dir2\%format.
I think it has to be 'G:/dir1/dir2\%format
0
 
joebednarzCommented:
Is "%format" part of your directory name or are you trying to get EM to fill in the variable and create a directory name based on that?
0
 
xoxomosAuthor Commented:
Right now it appears to be a permissions problem where all the rights from g:\  should be inherited by g:\backup but for some reason are not.  Now i am just creating the backup in g:\ and manually moving to g:\backup.
0
 
xoxomosAuthor Commented:
Thank you.
0
 
xoxomosAuthor Commented:
Please close.  Problem was i had an extra blank  space in directory name which windows allows.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now