Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 417
  • Last Modified:

Emails are very slow to be sent outsode the organization, Error in queue 421 4.4.2 Connection dropped

I have an Exchange 2007 server (mailbox) and another one (client access and hub transport), the problem is that it taked too much time to send emails outside the org, for example to yahoo or hotmail. The leased line is 1mbps. in the queue I just see some as active all the time (just 3MB emails) and other are showing  retry 421 4.4.2 Connection dropped. for instance i sent an email (3MB) to gmail and it took 7 hours to receive! any idea??
0
mdbanat
Asked:
mdbanat
  • 7
  • 3
  • 2
  • +1
1 Solution
 
midustouchCommented:
Where's the queue located? On your hub server?
0
 
mdbanatAuthor Commented:
midustouch:yes, the queue is on the hub servers.
 zuhairGmaty:I will check the links and get back to you
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Zuhir ElgmatiApplications and Systems AdministratorCommented:
wish you good luck
0
 
mdbanatAuthor Commented:
by the way I don't have any edge server, what I know it can be optional, is that a problem if I don't have edge subscription in the hub transport server?
0
 
Zuhir ElgmatiApplications and Systems AdministratorCommented:
i don't know actually, but in fact i find this discussion concern your issue i send it to you expected it may help you ,
0
 
mdbanatAuthor Commented:
I tired some of the ideas mentioned there but without help. I changed port in the switch, I removed antivirus and checked with ISP. The problem is that it some queues are appearing active, but not sending, it takes so much time and sometimes I receive message that it is delayed
0
 
midustouchCommented:
Have you taken a look at the SMTP logs on your IIS server, that might turn up something.
0
 
mdbanatAuthor Commented:
How? what I know is that in Exchange 2007, we should not install SMTP in IIS, Should I?
0
 
mdbanatAuthor Commented:
OK, SMTP does not work with Exchange 2007 as I checked. I noticed something, all the delay is when we send to hotmail email only, others are fine. Do you have any idea or explanation for that?
0
 
bluwolf57Commented:
I too have ran into the same issues. I have found no solution to this problem and was hoping an expert might be able to solve this one. I have tried everything that I could find as a solution to my problem on this site but nothing works. Please help!
0
 
mdbanatAuthor Commented:
Thanks All
I contacted a consultant and he solved the problem
Thanks again
0
 
mdbanatAuthor Commented:
As per what I understood from him that I should turn off TCP/IP offload engine key on the motherboard of the server. I went to server manual and removed this key. Everything became fine.

Thanks all
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 7
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now