Exchange 2007 - Mail connectors ignoring config?

We upgraded to Exchange 2007 not so long ago, and I have just noticed some problems with the mail connectors.

When sending an attachment over 10mb, I receive this error;

#550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##
Original message headers:
Received: from MSTORE.******************.local ([***.***.***.***]) by
 CAS.**********.local ([***.***.***.(((]) with mapi; Tue, 7 Aug 2007 08:53:52
 +0100

Now, I have already changed the connectors on the client access server as such;

get-receiveconnector in the shell tells me this;
Identity                                MaxMessageSize
--------                                --------------
CAS\Default CAS                         32MB
CAS\Client CAS                          32MB

And get-transportconfig |fl max* give me this;

MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 32MB
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : 32MB

Transport config is;

ClearCategories                : True
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 32MB
MaxRecipientEnvelopeLimit      : unlimited
MaxSendSize                    : 32MB
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
Xexch50Enabled                 : True

Setup is one Mailstore server, one client Access server, and one Edge server.  Edge server connects to two SMTP servers.

Seems incoming mails are being blocked with no notification, but outgoing emails are the most immediate problem. (CEO likes to send many PDF attachments) A test email sent from my Gmail account with a 11mb attachment generates this error;

Final-Recipient: rfc822;adam.peters@*************.com
Action: failed
Status: 5.2.3
Diagnostic-Code: smtp;450 5.2.3 Msg Size greater than allowed by Remote Host


Any ideas? I rebooted all the servers last night, but still no joy. The configs above are run from CAS. I've tried to follow all the technet articles, but Exchange 2007 seems to have changed the setup from 2003 into something monstrous! I've not got a problem using CLI, but when I can't see where the mailflow error is occuring, its very fustrating.
AdamJPetersAsked:
Who is Participating?
 
consultkhanCommented:
HI,
The maximum allowed message size in Exchange 2007 is managed by the various SMTP receive connectors that are installed in your Exchange organization. Exchange 2007 includes two default SMTP receive connectors--the Client SMTP Receive Connector and the Default SMTP Receive Connector.
in your case it appears that you need to chagne the settings for the Default Receive Connector  to 32 MB.
IN case it shows 32MB and you cant send more than 10 MB.
OPEN adisedit.msc and verify the connetor`s MaxMessageSize
THANKS.
0
 
ATIGCommented:
What about on the Send connector?

I see you recieve is set to 32
Transport config is ok

Do a get-sendconnector | fl maxmessagesize
0
 
AdamJPetersAuthor Commented:
Just checked on the Edge server, and your right!

Adjusted the incoming connector fine, but it won't let me edit the outgoing as the connectors are subscribed. I shall do some reading to clarify this, and do the work this evening.

Talk about long winded!

Thanks guys!
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ATIGCommented:
you need to break the subscription, make changes then resubscribe

That is one thing I dont like about edge, almost anything you do require the subscribtion to be removed
0
 
levyngCommented:
I am having the same problem. I have tried everything above with no luck. What do you mean break the subscription?
0
 
Links_TechnologyCommented:
FOR SENDING:
In Exchange Management Council (EMC):
Organization Configuration > Hub Transport > Send Connectors Tab, Go to the properties of that send connector. In the General Tab will see a box with a check mark: Maximum Message Size (KB) [update to desired size]

Organization Configuration > Hub Transport > Global Settings Tab, Go to the properties of the Transport Settings. In the General Tab will see a box with a check mark: Maximum Send Size (KB) [update to desired size]

FOR RECEIVING:
In Exchange Management Council (EMC):
Organization Configuration > Hub Transport > Global Settings Tab, Go to the properties of the Transport Settings. In the General Tab will see a box with a check mark: Maximum Receive Size (KB) [update to desired size]

Server Configuration > Hub Transport > Receive Connectors (Lower box). Update all of your receive connectors: Properties, General Tab: Maximum Receive Size (KB) [update to desired size]
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.