• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 412
  • Last Modified:

server 2003 sp2 loses/forgets tcp/ip settings.

I am setting up a MS server 2003 SP2 standard edition for terminal services. A different machine is the DC. The problem is this.
The TCP/IP settings were not being saved. I could type them in and access the machine (ping, rdp) but if I went back into the TCP/IP profile, everything was blank again. Problems arose at reboot. I manually removed tcp/ip from the registry, uninstalled the network cards, rebooted, server 2003. It correctly found the cards and reinstalled network services. TCP/IP is listed under the cards properties, checked off, blank settings. I fill in the settings, the system asks me to reboot, after reboot the settings are blank. This includes address, mask, gateway, dns, wins, every setting.
I thought this may be a registry permissions problem but am at a loss as to where to check and what permissions are needed. I considered a misconfigured group policy that disallows tcp/ip changes, but can't find references to such.
Anyone have ideas?
0
ljaszcza
Asked:
ljaszcza
  • 2
  • 2
1 Solution
 
SysExpertCommented:
1) Are you setting these settings as Static, or DHCP  ( server should be static ).

2) Is there more than one NIC or teaming ?  You may need the special drivers.

WHat computer model is this ?


What I like to do on any network problem....Is to reset it ALL....

netsh int ip reset reset.log
netsh firewall reset
netsh winsock reset

Then remove ALL NIC's from the device manager..
In the Device Manager, select View>Show Hidden Devices

(If the Show Hidden devices is not presetn, do the following command from a command prompt..)

start>run>cmd
set devmgr_show_nonpresent_devices=1

More information on that command here....
Device Manager does not display devices that are not connected to the Windows XP-based computer
http://support.microsoft.com/kb/315539

Go back to Network Adapters, and make sure your adapters are all gone, including any older ones. (there will be several ' miniport' devices that are not able to be uninstalled....)
Once they are all gone, reboot and let Windows reinstall them...

Thats a total rebuild of your network connections, to hopefully correct any problems with Basic connectivity.

I hope this helps !
0
 
ljaszczaAuthor Commented:
Model is Dell poweredge 2900. Static settings. Two NICs are present, I am only using one and am not using any special teaming or other features. Only one of the NICs has a cable going to it, the other is disabled. I tried switching NICs but the problem persists for either NIC.
I tried netsh in ip reset. The log is unremarkable to me, no errors.
I have not tried netsh firewall/winsock resets yet.
I did remove all NICs but did not try the "hidden devices", when the rebuild completed, the problem was back...
I will try looking for hidden devices, see whether that helps.
Thanks
0
 
ljaszczaAuthor Commented:
Ok, no luck.
Uninstalled all network protocols, clients, etc. Looked for hidden NICs (none present). Removed registry settings per MS "how to reinstall TCP/IP" bulletin. Rebooted, let computer detect and reinstall network.
Same problem. It will not allow tcp ip settings. You type in your fixed address, gateway, etc. and they are not there after you hit ok.
Almost time to reinstall...
0
 
SysExpertCommented:
Yeah, I have to agree that it is time to reinstall.

I would do a system state backup and save it, since you may be able to compare stuff later if you really want to hunt for the cause.

The onlu other workaround is to use a batch file with the network settings in it, but that in general is not a good idea for a server.

0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now