• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1379
  • Last Modified:

Unable to migrate computers with ADMT account... (user rights problem)

I am using ADMT V3.0 to migrate a single NT4 domain (DomainS) to a single AD forest/domain (DomainT).
The migration of users, groups, and local profiles is working very well.

I have a problem with the computer migration (clients are running Win XP SP2).

- The ADMT is installed on a Windows Server 2003 SP2 (member server on DomainT)
- I am using the following account: "DomainS\admt"
- "DomainS\admt" is a memeber of
   * "DomainS\Domain Admins" global group,
   * "DomainT\administrators" local domain group  
   * local administartor on the server running ADMT
  - I also set Full permission to the DomainS\admt" account on the target OU in DomainT.
The Admt application is running under  "DomainS\admt" account.

When I try to migrate an XP  workstation, I get the following error messages:
ERR2:7816 Impossible to determine if the source object '.... /MyPC$, user'match with an object in the target forest or domain
ERR2:7301 The migration of the source object '.... /MyPC$, user' has failed. The target objet was no created. hr=0x80070006
(translated from french)

It sounds like the DomainS\admt" account has not enough rights on the target domain. But I don't know how to proceed.  If I launch the ADMT application with the the DomainT\Administrator, then I don't have the Administrator rights on the users workstations.

Thanks in advance,

  • 3
  • 2
1 Solution
Ron MalmsteadInformation Services ManagerCommented:
Verify your trust relationship.
DomainS\admt should be a member of administrators in DomainT...and it should have permissions to the OU in which your importing to.
Logon to the server which holds the trust and has admt3.0 installed.  Then try to run the migration on machine accounts again.
Also...Turn off the firewall on client machines first.
Ron MalmsteadInformation Services ManagerCommented:
...oh wait nevermind...didn't see the part where you said it was a member of both admins groups in both domains...

Also....you shouldn't be logging on as a local admin.  You should logon with the DomainS\Admt account...preferably on the machine that holds the trust...(trusting DC).  As a local admin you don't have rights to veiw AD in a seperate process outside of ADMT.  I assume your using the RunAs feature....
don't use runas...logon with the account on DomainS, that is admin in DomainT.....then run admt normally.
Qais74Author Commented:
Just to clarify the situation:
- ServerS is the PDC of the Source domain (NT4 SP6a)
- ServerT, is the first DC of the destination domain (W2K3 SP2)
- ServerA, is a member server, on which ADMT is installed. It is memeber of the target domain.

To migrate, I logon as the the DomainT\administrator and I launch admt using the runas with DomainS\admt account.

So, you suggest to logon with  DomainS\admt account on my memeber server and launch admt ?

Qais74Author Commented:
Thanks. I installed ADMT on the DC and now it works.
Ron MalmsteadInformation Services ManagerCommented:
glad to help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now