• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1889
  • Last Modified:

Vista connects to wireless, but won't connect to the internet

I have been trying to get a clients new Sony VAIO laptop connected to the internet via a wireless connection.  I have been able to establish the wireless connection, but it will not connect to the internet.  In the process of troubleshooting, I discovered a workaround, but it doesn't make sense to me WHY it works!  Hopefully, it will make sense to someone who can recommend/suggest a permanent fix.

Here are the specific components: a Sony VAIO laptop (new this year-model VGNFE890) with Vista Home Premium and built in wireless capability, a Qwest DSL wireless modem (Actiontec 2701GH-D) and a Gateway desktop PC running Windows XP. The DSL is working just fine on the desktop, which is connected via ethernet cable to the modem/router. When we set up the wireless connection on the laptop, it connects to the modem, but will not connect to the internet. Clicking on the Repair doesnt workit just says it cant fix the problem.

 In the process of trying to troubleshoot (after being on the phone to Qwest tech support for an hour), I decided to use the ethernet port on the laptop just to see if I could access the internet that wayit worked fine. So, just for fun, I tried unplugging the ethernet cable and refreshing the web pageit was still connected. So I tried browsing to multiple pagesit still worked (via the wireless connection). I then rebooted, tried the wireless connectionit didnt workwent through the process of plugging in the ethernet cable, going to a web page, unplugging the cable and once again the wireless connection began working. So, bottom line, this is an easy, quick workaround, but there HAS to be an explanation for it. Any ideas???
0
pdkimpton
Asked:
pdkimpton
  • 2
1 Solution
 
joinaunionCommented:
Right click connection that uses cable choose disable then try wireless connection again.
0
 
maninblac1Commented:
Try disabling IPv6 on the wireless connection and QoS, your router may be rejecting the IPv6 packets.  Vista should then "attempt" to use IPv4, but who knows if that really works like it's supposed to.  Also look for updated wireless drivers.
0
 
pdkimptonAuthor Commented:
Thank you, joinaunion.  It worked to disable the wired connection--what a simple solution.  Hopefully Vista won't decide to flake out, but for now I have a very happy client!

maninblac1--thanks for your input.  I had already tried the options you gave per advice from Sony (except for disabling QoS), but it didn't work--I'm not sure if also disabling QoS would have done it, but since joinaunion's  suggestion worked, I didn't want to push my luck!
0
 
joinaunionCommented:
:0)
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now