• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1708
  • Last Modified:

fopen ("file", "wb") still writes cf-lf text files in VS2005

Using Visual Studio 2005 in pure C (no C++) I have problems with writing a binary file using fopen() and fputc(). Here is my little test program:

int main (int argc, char* argv[])
{
      FILE *fp;
      fp = fopen ("crlf.tmp", "wb");
      fwrite ("abc\n", 1, 4, fp);
      fputc ('x', fp);
      fputc ('y', fp);
      fputc ('z', fp);
      fputc ('\n', fp);
      fclose (fp);
      return 0;
}

When you look at the resulting file in a hex editor, in both cases the linefeeds are translated into a CR-LF pair. Which would be OK if the file was opened as default or as a text-file but not when it is opened in binary mode.

This has for me been an ongoing problem. Last time I circumvented it by replacing my C-style file I/O with MS specific calls like CreateFile() and  ReadFile(). But this time I prefer to solve the problem "once and for all". :) Also I need this code to be platform independent and this problem doesn't occur on my Unix systems.


0
wschaik
Asked:
wschaik
  • 4
  • 3
  • 2
  • +3
1 Solution
 
avizitCommented:
This is prolly because newline in win machines are translated as CR-LF pair.

on unix machines you can usually convert the file to use only \n using the dos2unix command if available

dos2unix filename  
0
 
wschaikAuthor Commented:
But if you read the MSDN page on fopen() that's exactly what the "wb" parameter should prevent, but it still doesn't do what it's supposed to do. The resulting file is identical if you open with "w", "wt" or "wb".
0
 
josgoodCommented:
I tried your program with VS205 in a C++ project and a C project.  In both cases, the '\n' appears as 0x0a in the hex file.  I cut-and-pasted your code.  I don't get why I'm getting different results.

Could this be a setting in VS2005?
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
wschaikAuthor Commented:
Hi josgood, that's what I was wondering as well. However, to test this I created a 100% fresh project (Win32 console application). I did define _CRT_SECURE_NO_DEPRECATE in my project properties to get rid of compiler warnings, but I can't see how that makes a difference.
0
 
josgoodCommented:
I had no compiler warnings.  This is curiouser and curiouser.

I checked f_mode on my machine.  Setting it to _O_TEXT,  _O_BINARY and _O_WTEXT made no difference.
0
 
josgoodCommented:
I'm running Visual Studio Pro
Version 8.0.50727.762 (SP.050727-7600)

Probably not relevant, but you think of service packs.
0
 
avizitCommented:
what compiler warnings you are getting ? your code looks pretty straight forward  and should compile cleanly
0
 
wschaikAuthor Commented:
Well, the warnings depend on the type of project. If I created an empty project, and pasted in my code, I got no warnings at all Did this test after my origianl post.

At first, I created a Win32 console app with a sample application. Which generates one of those stdafx projects. It's never been clear to me what that stuff is doing, but anyway, in that case it complains about a lot more security related stuff which you can solve with this pre-compiler marcro.

But I only mentioned this to be complete. I don't think it's related. I just started from scratch with a "create empty project", built the app, no warnings whatsoever, and still each linefeed gets translated into a "cr-lf". Go figure ..... :-)

0
 
Anthony2000Commented:
I ran the same code in a cpp win32 console project, no compile errors and it generated a the file without any CR only the LF character.

What hex tool did you use to see if there are any CR's  in the file? The resulting filesize is 8 bytes. What do you see as the filesize? (6 bytes for the printable ascii and two newlines).

0
 
wschaikAuthor Commented:
Anthony, seems you nailed it.

To view the Hex code, I opened the file in UltraEdit and then switched to HEX mode. Seems that UE is first converting the LF's into CR-LF's (I presume that's configurable :-) while reading in the file.

I ftp-ed the file to a Unix box (in binary mode) and used 'od -x' to verify. Indeed no CRs that way.

Thanks,
Willem
0
 
Infinity08Commented:
>> Seems that UE is first converting the LF's into CR-LF's

That's indeed what UE does (you should get a pop-up asking whether you want to convert the file to DOS format - if you click OK, it will do this replacement).

There are several hex editors for Windows that don't have this "problem", as long as you pick one that is advertised as a hex editor. UltraEdit is a text editor that just happens to have a hex functionality, but it is first and foremost a test editor.
0
 
Anthony2000Commented:
In Windows, I have been using frhed. http://www.codeproject.com/tools/frhed.asp
0
 
PaulCaswellCommented:
Hi Willem,

In UltraEdit, go to 'Advanced' -> 'Configuration...'. On the 'General' tab find 'Load/Save/Conversions' and adjust the 'Unix/Mac file detection/conversion' setting.

That applies to version 10 but this mechanism has always been present.

Paul
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 4
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now