Problem sending email - Using the 'forward mail through this connector to the following smart hosts'

Hi.
Our ISP in the UK has requested that we our clients send email (All our clinets us an SBS2003 exchange) through a specific SMTP configuration - this is in an attempt to stop spam from being sent. They have not changed the port number but email is no longer sent via DNS its sent via the 'forward all mail through this connector to the following smart hosts'
i..e. We have added a new SMTP connector to the exchange rouging group.

We have done this - having followed an MS KB article however my question is this:

How do you get exchange to use this SMTP connector. As far as I can tell exchange is still using the default 'Small Bsuiness SMTP connector'.

I say this because if you check out the exchange queue when an email is sent, email seems to be going via the Small Business SMTP Connector.

Am I missing something here? - could anyone please throw some light on this.

Thank you and Regards
Andy.
LVL 1
AndyKeenAsked:
Who is Participating?
 
tigermattCommented:
If you have a Small Business Server then you should be using the Small Business SMTP Connector to send the mail. The best way to set this up is to rerun the Configure Email and Internet Connection Wizard (CEICW) in Server Management. You are given the option there to specify whether you want to send mail via DNS or smart host. That option can be seen in this screenshot: http://www.sbs-rocks.com/sbs2k3/images/use%20dns-15.jpg and is actually marked as "Forward all e-mail to e-mail server at your ISP" but it's the same as a smart host.

If your ISP needs authentication to use their smart host then you can set that in the Small Business SMTP connector. Open the properties for the connector, Advanced tab, click on Outgoing security and select Basic Authentication. I believe there's a modify button you click and then enter username/password.

Hope this helps
0
 
Michael PfisterCommented:
Just modify the mall Bsuiness SMTP connector to forward mail to the smart host and remove your new connector.
0
 
AndyKeenAuthor Commented:
hi MPFISTER - I did try that but internal email did not seem to be routed correctly - would that be correct??? - would that be because i did not use the 'configure email and internet wizard'

Hi Tigermatt - thanks for the info - looks good - I will try it out shortly.

Regards
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
tigermattCommented:
Using any of the SBS wizards is a much easier way to make changes like this on an SBS. They are pre-programmed to change settings across many different programs, so much easier than you doing it all manually. Running the CEICW to set this up will simply reconfigure the SMTP connectors and set up your smart host to the address you specify in the wizard. It's just a much quicker and easier way of doing things, but may perhaps just make one change to an incorrect setting which will get everything running again.

If this were a normal Exchange environment then you could create a new connector as you mentioned and configure it accordingly, but sadly SBS doesn't work like that. It's all wizards, wizards, wizards with SBS!
0
 
AndyKeenAuthor Commented:
Thamks Tigrmatt....
0
 
tigermattCommented:
Cheers :-)
0
 
tigermattCommented:
<offtopic>
Wow! Just a quick note to say "Well done" to Venabili, if you're still subscribed! That's loads of cleanup recommendations you've just posted in "abandoned" questions which I happen to have commented in, so Thanks for your work!

tigermatt
</offtopic>
0
 
VenabiliCommented:
:) Someone had to.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.