• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 443
  • Last Modified:

Folder Redirectio

Hallo, we are tring to change folder redirection from setting \\server\users\%username%\documents to %homeshare%%homepath%documents. The current configuration (with %username%) works fine but after changing it to new configuration we are not able to success. We recieve error:

Failed to perform redirection of folder My Documents. The fully expanded paths for the folder could not be determined. The following error occurred:
The specified path is invalid.

Checkbox "Grand user exclusive rights" is  unchceked
If we check in command line variable %homeshare% it refers to correct path
Any suggestions?
0
glavinfocz
Asked:
glavinfocz
  • 5
  • 4
  • 2
1 Solution
 
and235100Commented:
Are the permissions on the folder and its parent you are try to redirect to suitable?
0
 
glavinfoczAuthor Commented:
Yes they are. It normally works with setting \\server\users\%username%
0
 
and235100Commented:
When you put:
\\server\%homeshare%\%homepath%\documents
into the address bar in Explorer - do you get a proper folder displayed? (when logged on as one of the users)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
matrixnzCommented:
Try %homeshare%%homepath%\documents

Cheers
0
 
glavinfoczAuthor Commented:
variables are following:
%homeshare% ......... \\server\users\username
%homepath% ......... \

so it should be %homeshare%%homepath%documents if I put this path into the explorer I got corrrect path and I see all my documents.
0
 
and235100Commented:
Okay - check "Grant user exclusive rights to My Documents"

Then try again - does it work?

Then uncheck the box - and try again - does it work now?
0
 
glavinfoczAuthor Commented:
It doesnt help
0
 
and235100Commented:
It turns out that you cannot use %homepath%

Folder Redirection is only able to process two environment variables: %username% and %userprofile%. Other environment variables such as %logonserver%, %homedrive% and %homepath% will not work with folder redirection.


from http://www.microsoft.com/technet/community/en-us/management/manage_faq.mspx
(look at Can I use environment variables with Folder Redirection?)
0
 
glavinfoczAuthor Commented:
OK thanks for replay. it is shame that only these two variables can be used.
0
 
and235100Commented:
Sorry that I couldn't have been of more help.
0
 
matrixnzCommented:
Hi all

This actually only applies to Windows 2000 not Windows XP.   Here's how I do it, in Windows 2003 Group Policy Management Console, I select our Users GPO

Under User Configuration\Windows Settings\Folder Redirection
Right Click My Documents
Select Properties
Select Advanced - Specify location for various user groups
Click Add...
Security Group Membership Type: Domain\Domain Users
Target Folder Location Select Redirect to the user's home directory
Click OK
NOTE: Under Security Group Membership
Group=Domain\Domain Users
Path=\\%HOMESHARE%%HOMEPATH%\My Documents

Select Settings Tab
Uncheck Grant the user exclusive rights to My Documents
Check Move the contents of My Documents to the new location
Policy Removal Select: Leave the folder in the new location when policy is removed.
Click OK

Cheers
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 5
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now