• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 706
  • Last Modified:

Connect a MacBook via cable to an ADLS router

I have ADSL and a router with 4 ports.  My computer is a PC.  My daughter has a Macbook with an ethernet port.  When I plug a cable from my modem into her computer, the Macbook doesn't recognize it.  Is there a setting I need to adjust so that it will recognize the modem and go online?

Thanks very much.

Walter
0
wjaros
Asked:
wjaros
  • 2
  • 2
4 Solutions
 
strungCommented:
Pull down the Apple Menu to Preferences and go to the Network Preference. Make sure the network preference for TCP/IP under Ethernet is set to DHCP.
0
 
strungCommented:
P.S. You are connecting the Mac to the Router and not directly to the ADSL modem, I assume? And it is a Router, not a switch or hub?
0
 
ascintoCommented:
When you open up System Preference, and click on Network, go to Show:Network Port Configurations. You'll see a list of the network interfaces. Make sure that Built-In Ethernet is checked, and it's at the top of the list.

If Ethernet is un-Checked, that interface is turned off and that could of course stop the Macintosh from recognizing that cable you plugged in.

The Macintosh uses something called Multi-Link / Multi Homing, which basically allows you to have multiple network connections at the same time. For example, you may have airport connected, and have ethernet plugged in. The Macintosh will use the list in Network Port Configurations to determine which connection it uses first. So you want Ethernet at the top of the list.

Once you do this, change Show: to Built-in Ethernet, and check that Configure IPv4 is set to DHCP ( which I assume is how your router works: you plug a machine in and it just starts browsing the web ). In addition, you could try putting a name in DHCP Client ID, like "MacBook" or something.

Another thing to try is adding a good public DNS server in the DNS Servers field: 208.67.222.222.

And finally, you can click on the Ethernet tab to manually try setting the speed of the ethernet connection, in you situation you can try 100BT Full, and if that doesn't work try 100BT half. Good luck!
0
 
ascintoCommented:
Oh yeah, I just re-read that and noticed you said your plugging the modem into the computer. That won't work, at least not right away. You really should be plugging the Macintosh into one of the four LAN ports on the router, and the modem should stay plugged into the WAN single port on the router.

If, for some strange reason, you need to plug the Macintosh directly into the modem, unplugging the router, you need to power off the modem for as long as 5 minutes to make it forget the MAC address of the router. Don't worry about it, just unplug the power from the modem, wait five minutes, and plug the power back in. Wait for all the lights to go back on, maybe 1 minutes, and then plug the Macintosh back in and see if it works.

But seriously, you want to plug the Macintosh into the router, not the cable modem.
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now