• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2575
  • Last Modified:

D-Link, Router, DI-624

Hi
I want to connect to the server in my office from my PC at home.  I can do it successfully by first connecting to my office's network through VPN and then connect to the server using XP remote desktop.
The problem occurred after I change the Linksys router to a faster D-Link router (DI-624).  The VPN can be connected successfully.  However when I launch Remote Desktop, the yellow header appears as usual (sometimes with a black screen) but then the login screen never come.  After a while, I will get a dialog saying "Network problem".
If I changed back to the Linksys router, I can connect to the office server again and so I believe it is related to the D-Link router.
I've read http://support.dlink.com/faq/view.asp?prod_id=1324&question=remote+desktop and followed it to open port 3389 in the router but it cannot help.  I found many articles on Remote Desktop + router problem but all of them are related to accessing a PC behind the router but my case is go through the router to access a PC in VPN.

What should I do with my router in this case?

Please help
Edwin
0
Edwin_C
Asked:
Edwin_C
  • 2
  • 2
1 Solution
 
chuckyhCommented:
How is the VPN setup on this network? are you running a VPN server on a windows server?
0
 
Edwin_CAuthor Commented:
No.  It is built-in in the firewall.
0
 
Rob WilliamsCommented:
A black screen with remote desktop can often be repaired by disabling "Bitmap Caching" under "options", "Experience" in the remote desktop connection client. However odd that works with one router and not the other, but worth trying.

D-Link routers can often be problematic with VPN pass-through. Have you tried not using the VPN and configure port forwarding on the router to connect directly to the remote PC? Though not quite as secure I would recommend it for testing purposes. Instructions can be found:
http://www.portforward.com/english/routers/port_forwarding/Dlink/DI-624/Remote_Desktop.htm
0
 
Edwin_CAuthor Commented:
The login prompt appears after disabling Bitmap Caching!  I have worked on this problem for a few days and thought it was related to the router setting but it turned out to have been solved like this!
Many thanks to RobWill!
0
 
Rob WilliamsCommented:
Great! Glad to hear.
Thanks Edwin_C.
Cheers !
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now