[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

D-Link, Router, DI-624

Posted on 2007-08-08
5
Medium Priority
?
2,572 Views
Last Modified: 2013-11-05
Hi
I want to connect to the server in my office from my PC at home.  I can do it successfully by first connecting to my office's network through VPN and then connect to the server using XP remote desktop.
The problem occurred after I change the Linksys router to a faster D-Link router (DI-624).  The VPN can be connected successfully.  However when I launch Remote Desktop, the yellow header appears as usual (sometimes with a black screen) but then the login screen never come.  After a while, I will get a dialog saying "Network problem".
If I changed back to the Linksys router, I can connect to the office server again and so I believe it is related to the D-Link router.
I've read http://support.dlink.com/faq/view.asp?prod_id=1324&question=remote+desktop and followed it to open port 3389 in the router but it cannot help.  I found many articles on Remote Desktop + router problem but all of them are related to accessing a PC behind the router but my case is go through the router to access a PC in VPN.

What should I do with my router in this case?

Please help
Edwin
0
Comment
Question by:Edwin_C
  • 2
  • 2
5 Comments
 
LVL 18

Expert Comment

by:chuckyh
ID: 19655162
How is the VPN setup on this network? are you running a VPN server on a windows server?
0
 
LVL 16

Author Comment

by:Edwin_C
ID: 19655206
No.  It is built-in in the firewall.
0
 
LVL 78

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 19659571
A black screen with remote desktop can often be repaired by disabling "Bitmap Caching" under "options", "Experience" in the remote desktop connection client. However odd that works with one router and not the other, but worth trying.

D-Link routers can often be problematic with VPN pass-through. Have you tried not using the VPN and configure port forwarding on the router to connect directly to the remote PC? Though not quite as secure I would recommend it for testing purposes. Instructions can be found:
http://www.portforward.com/english/routers/port_forwarding/Dlink/DI-624/Remote_Desktop.htm
0
 
LVL 16

Author Comment

by:Edwin_C
ID: 19670091
The login prompt appears after disabling Bitmap Caching!  I have worked on this problem for a few days and thought it was related to the router setting but it turned out to have been solved like this!
Many thanks to RobWill!
0
 
LVL 78

Expert Comment

by:Rob Williams
ID: 19670160
Great! Glad to hear.
Thanks Edwin_C.
Cheers !
--Rob
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question