• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 311
  • Last Modified:

Using network printer requires login for admin, not for guest.

I want to be able to print as easily as a guest, without having to login.

I have 2 notebooks running XP Pro SP2, wirelessly networked to an XP Pro SP2 desktop host computer.  Non-admin accounts on each notebook have no trouble sharing host printers, but the admin accounts on each notebook receive "access denied" unless I first click on the host in 'View Workgroup Computers' & login with host admin account name & password.

Simple file sharing is not enabled, printer sharing permissions have admins at full access, Everyone and Guest at Print only.  My account user names and profile names on all 3 computers are identical, but each password is different.  I have tried changing a user name on one notebook but it didn't help.

This behavior is new & I don't know what I did/changed that caused it.
0
pbsurf
Asked:
pbsurf
  • 4
  • 4
1 Solution
 
Will SzymkowskiSenior Solution ArchitectCommented:
If you Enable "simple file sharing" this should remove the window asking to use the resources from another computer on a Lan.
0
 
pbsurfAuthor Commented:
I don't want SFS, I want to have to login to access shared files & directories.  I don't want to have to login to print.
0
 
thstephCommented:
Unfortunately Spec01 is right. You have to enable SFS since you are not working under a domain. If you had a domain, the answer would have been different, but in this case you would need to enable SFS. Unless if you want to create three different users on your 3 stations and give different permissions under thee printer. In this case you would need to have on your computer that has the printer the following users:
1. Administrator
2. Guest
3. User1 (Administrator)
4. User2 (Administrator)
5. User 3 Administrator)
In this case all trhee users will appear on your Welcome screen unless you have the login screen (no Fast User Switching option).
There is also another cause for your problem ... have your two pcs been a member of a domain and you removed them? If so, sometimes they do tend do do these sort of things. In the end I concur with the first given solution.
PS. Have you had your SFS disabled from before the problem first appeared?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
thstephCommented:
I think that by saving the 1st computer's Username and password in the "My Network places -> View workgroup computers" (Just place a tick in the checkbox) will do the work but I'm not so sure. Also try removing the ASP.NET account if enabled and check your AV settings
0
 
pbsurfAuthor Commented:
Hi thsteph,
Yes, the SFS has always been disabled and previously I could use desktop printers from the notebooks (from guest or admin account) without login, but had to login as admin to access files on the desktop. The computer was never working under a domain.

I'm not sure I understand your proposed solution in your 1st comment, but I'm willing to try it. All 3 compters have the same account name, both the profile and the username.  I had already added this name separately to the printer permissions with full access, but it made no difference (how does it know who you are before you login anyway?)  

How does the computer know to reject the admin, but not the guest, before you have even logged in?  With printer permissions set to Print for Everyone, shouldn't that allow Remember, guests on the notebooks currently print on the desktop printers without having to login.

Regarding the save username & password, wouldn't that defeat my desire to require login for file access.  Then I might as well just use SFS, right?  But I didn't have to before.  It seems like that's the reason for separate permissions fopr printers & file folders, but it isn't working right.

I  don't know what ASP.NET acct is, but if you tell me where to look I'll remove it.
0
 
pbsurfAuthor Commented:
thsteph,
I tried your suggestion of saving username & password & that is an acceptable workaround, thanks.  

Files are still protected by my original login to the notebook, so as long as I logout, nobody else can access the shared files.

I still would like to solve the problem that changed this behavior, but if not I will accept your solution & consider the problem solved.
0
 
pbsurfAuthor Commented:
thsteph,
I found the ASP.NET acct on the desktop computer & disabled it.  Can you tell me how to 'un-save' the desktop username & password on the notebooks so I can see if disabling ASP.NET made a difference?
Thanks.
0
 
thstephCommented:
Hmmm ... that's a bit tricky ... Since it's saved I don't know the way to unsave them ... but you could always insert a new one. So the next time you would try to login, it wouldn't accept the old username and/or password. That's a way around. Something else that came to mind is ... do you have your Windows Firewall enabled? If so try disabling it. It doesn't offer much protection either way. And what kind of AV are you using? Have you changed anything on your setup?

Regards
0
 
thstephCommented:
Any news?
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now