• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1360
  • Last Modified:

RH AS 4:Kernel panic up2date from 2.6.9-5 to 2.6.9-55.0.2

Hi all,
After I've install RHEL4 AS (which is having 2.6.9-5 kernel version), I immediately run up2date so it download all package (about more than 1 thousand files including latest kernel: 2.6.9-55.0.2) and the update completed overnight. The next day when i booted my computer, I have new option in my grub menu so I selected the 2.6.9-55.0.2 ELsmp x86_64 and within 30 seconds, the kernel panic! The error message i received are:

Mounting root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!

I'm not sure what is the correct way to update to latest kernel but I assume using up2date under this will act like "WIndows update" which will update what ever are relevant? Another question is when I run up2date for the 1st time, will I need to update Errata as well? If yes, is it mean I need to download all Errata from Redhat network and manually update it myself? Sorry, I'm kind of new in RH AS.
0
sengchoon
Asked:
sengchoon
  • 33
  • 32
  • 20
2 Solutions
 
Kerem ERSOYPresidentCommented:
Hi,

It seems that the new kernel detects more devices (This is generally happeneing when a new kernel detects SATA drives while previously only IDE drives are installed.

You can either try to make IDE recognized before SATA using the BIOS setup if it has such an option.

Otherwise I'll suggest you to boot your system from the Linux install disk in rescue mode. That is:
:linux rescue   (in the : prompt)
This will mount your system volume under /mnt/sysimage. Make it your root using:
chroot /mnt/sysimage
Then issue this command:
grub-install /dev/hda  (I assume you are using an IDE drive)

Reboot. This should fix our problem.
0
 
Kerem ERSOYPresidentCommented:
In RedHat terminolgy an errata means an update. So if it says there are errate it will mean that there are updates available. So up2date will update them you don't need to do something extra.
0
 
sengchoonAuthor Commented:
Hi,
I'm still newbie in this so I need further help.
Below is my grub.conf content. After I've completed up2date, my grub.conf being modified

============================================================================
:boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,4)
#          kernel /boot/vmlinuz-version ro root=/dev/hdc5
#          initrd /boot/initrd-version.img
#boot=/dev/hdc
default=1
timeout=30
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-55.0.2.EL.img
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.ELsmp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-55.0.2.ELsmp.img
title Red Hat Enterprise Linux AS (2.6.9-5.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-5.ELsmp.img
title Red Hat Enterprise Linux AS-up (2.6.9-5.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-5.EL.img
title Vista Ultimate
        rootnoverify (hd0,0)
        chainloader +1
============================================================================

My desktop specs is:
dmesg|grep CPU:
==================================================
Initializing CPU#0
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
CPU0: Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz stepping 0d
per-CPU timeslice cutoff: 1024.31 usecs.
Initializing CPU#1
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: Physical Processor ID: 0
Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz stepping 0d
checking TSC synchronization across 2 CPUs: passed.
Brought up 2 CPUs
ACPI: Processor [CPU1] (supports C1, 8 throttling states)
ACPI: Processor [CPU2] (supports C1, 8 throttling states)
Losing some ticks... checking if CPU frequency changed.
==================================================

When I selected Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp) during startup, those error mentioned previously occured. However, you'd mentioned to rebuild grub, but currently when I loaded into rescue mode, and when I execute "grub-install /dev/hdc" based on the fstab device referring to, how I know that it is fixing for the right kernel? This is because when I switch back to 2.6.9-5 kernal, I still can access linux. Forgive me if I ask silly question.

0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Kerem ERSOYPresidentCommented:
No way they are not silly questions.
The thing is what we expect from the grub install is to read the /etc/grub.conf file and determine the required kernel from here.

I really did not understand that. Does is still boot with the old kernel, if you select the old kernel through grub or not ?
0
 
sengchoonAuthor Commented:
Yes, when I selected Red Hat Enterprise Linux AS (2.6.9-5.ELsmp), it booted successfully. Then when I selected Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp), the screen shows the error I mentioned just now. Here are the full error message I received on the screen after I selected the new kernel (by the way, just now I'm in office so I did not post full error message, sorry:
-----------------------------------------------------------------------------------------------------
Booting 'RED HAT Enterprise AS (2.6.9-55.0.2)'
Kernel direct mapping tables upto 10100000000 @ 800-c000
root (hd0,4)
  Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinux-2.6.9-55.0.2.ELsmp ro root=LABEL=/ rhgb quiet
     [ Linux - bzImage, setup=0x1e00, size-0x197a23]
initrd /boot/initrd-2.6.9-55.0.2.ELsmp.img
     [ Linux-initrd @ 0x37f1b000, 0xd43ec bytes]
.
Decompressing Linux...done
Booting the kernel.
Red Hat nash version 4.2.1.10 starting
insmod: error inserting '/lib/jdb.ko': -1 Invalid module format
ERROR: /bin/insmod exited abnormally! (pid 433)
insmod: error inserting '/lib/ext2.ko': -1 Invalid module format
ERROR: /bin/insmod exited abnormally! (pid 434)
mkrootdev: label / not found
mount: error 19 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
-----------------------------------------------------------------------------------------------------

My fdisk -l:
-----------------------------------------------------------------------------------------------------
Disk /dev/hdc: 80.0 GB, 80026361856
255 heads, 63 sectors/track, 9279 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
        Device         Boot       Start                          End                     Blocks                Id                System
 /dev/hdc1               *         2048                 51202047              25600000                 7           HPFS/NTFS
/dev/hdc2                           ....                      ...........                  .............                   83         Linux
/dev/hdc3                           .......                   ...........                  ............                    82         Linux Swap
/dev/hdc4                          .......                      ..........                 ...........                       5         Extended
/dev/hdc5                          .......                       ........                   .........                      83         Linux
/dev/hdc6                          .......                       .......                   ...........                     83        Linux
-----------------------------------------------------------------------------------------------------
In my motherboard's bios, I configure my IDE to "Compatible Mode" and set to P-ATA + S-ATA because previously it was defaulted to "Enhance Mode" and I can't even boot into the old kernel. Do you need any further information in order for you to help me?
0
 
Kerem ERSOYPresidentCommented:
mkrootdev: label / not found

It means that your fstab is not accessible. Also hd0,4 is very strange
Will you boot in older kernel
and check your /etc/grub.conf and /boot/grub/device.map and send them here ?

please also check /lib/jbd.ko too
0
 
sengchoonAuthor Commented:
Below are the information:

/etc/grub.conf:
====================================================================================
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,4)
#          kernel /boot/vmlinuz-version ro root=/dev/hdc5
#          initrd /boot/initrd-version.img
#boot=/dev/hdc
default=1
timeout=30
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-55.0.2.EL.img
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.ELsmp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-55.0.2.ELsmp.img
title Red Hat Enterprise Linux AS (2.6.9-5.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-5.ELsmp.img
title Red Hat Enterprise Linux AS-up (2.6.9-5.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-5.EL.img
title Vista Ultimate
        rootnoverify (hd0,0)
        chainloader +1
====================================================================================

/boot/grub/device.map:
====================================================================================
# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/hdc
===================================================================================

For lib/jbd.ko, seems that it is not located under /lib. After I used find cmd to search the file , i foind this file in /lib/modules/2.6.9-5.ELsmp/kernel/fs/jbd/, /lib/modules/2.6.9-5.EL/kernel/fs/jbd/ and /lib/modules/2.6.9-55.0.2.EL/kernel/fs/jbd/. There nothing under /lib/modules/2.6.9-55.0.2.ELsmp/kernel but there are a lot of make file under /lib/modules/2.6.9-55.0.2.ELsmp/build
0
 
ezatonCommented:
Please post the contents of your /etc/modprobe.conf file, and the model of your system.

Thanks.
0
 
sengchoonAuthor Commented:
Sorry for  the late reply. Working...Below is my /etc/modprobe.conf file content:

alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias eth0 atl2
0
 
sengchoonAuthor Commented:
My computer spec:
=======================
ASUS P5GC-MX
KINGSTON DDR2 1GB PC667
SEAGATE 80GB 7200RPM SATA 2
Intel(R) Pentium(R) Dual  CPU  E2140  @ 1.60GHz
=======================

 df -k
=======================
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hdc5             28225596   6862048  19929752  26% /
none                   1025656         0   1025656   0% /dev/shm
/dev/hdc6             20627668     79324  19500508   1% /home
=======================

fdisk -lu
=======================
Disk /dev/hdc: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *        2048    51202047    25600000    7  HPFS/NTFS
/dev/hdc2        56227500    57030749      401625   83  Linux
/dev/hdc3        51215220    56227499     2506140   82  Linux swap
/dev/hdc4        57030750   156296384    49632817+   5  Extended
/dev/hdc5        57030813   114382799    28675993+  83  Linux
/dev/hdc6       114382863   156296384    20956761   83  Linux
Partition table entries are not in disk order
=======================

The Kernel which boot without problem is: uname -a
Linux myRHEL4 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:29:47 EST 2005 x86_64 x86_64 x86_64 GNU/Linux

Hope you all can advice me.
0
 
Kerem ERSOYPresidentCommented:
Hi,

It is normal that modules are not under lib directly but under kernel version. It seemes that there's a problem with your kernel modules and kernell looks at them under lib directly.

Will you run this command and let me know the result ?
grep jbd.ko /lib/modules/2.6.9-5.ELsmp
0
 
sengchoonAuthor Commented:
-->grep jbd.ko /lib/modules/2.6.9-5.ELsmp/*
/lib/modules/2.6.9-5.ELsmp/modules.dep:/lib/modules/2.6.9-5.ELsmp/kernel/fs/jbd/jbd.ko:
/lib/modules/2.6.9-5.ELsmp/modules.dep:/lib/modules/2.6.9-5.ELsmp/kernel/fs/ext3/ext3.ko: /lib/modules/2.6.9-5.ELsmp/kernel/fs/jbd/jbd.ko

--> grep jbd.ko /lib/modules/2.6.9-55.0.2.ELsmp/*
/lib/modules/2.6.9-55.0.2.ELsmp/modules.dep:/lib/modules/2.6.9-55.0.2.ELsmp/kernel/fs/jbd/jbd.ko:
/lib/modules/2.6.9-55.0.2.ELsmp/modules.dep:/lib/modules/2.6.9-55.0.2.ELsmp/kernel/fs/ext3/ext3.ko: /lib/modules/2.6.9-55.0.2.ELsmp/kernel/fs/jbd/jbd.ko
0
 
sengchoonAuthor Commented:
1 more question, when I perform up2date for the 1st time, when prompt to select package to be installed, I selected all without realise there's some with i386 version so will this cause the problem as well? For example:
rpm -qa|grep libtool-libs-1.5.6-4
libtool-libs-1.5.6-4.EL4.1
libtool-libs-1.5.6-4
libtool-libs-1.5.6-4
libtool-libs-1.5.6-4.EL4.1

there are so many of them. Is this one of the cause? Do I need to uninstall the i386 since I'm using x86_64? By the way, removing them will be time consuming compare to if I reinstall fresh copy again?
0
 
Kerem ERSOYPresidentCommented:
Hi,

both i386 nad x64_86 libraries are required. As you notice kernel modules are under /lib but not /lib64. If you delete them you'd be disrupting integrity of the system. Plese don't even think about it :)

I don't think there's a porblem with installtion or something else. It seems that modules are somehow disrupted.

I suggest you to remove your kernel:

rpm -evvl kernel-2.6.9-55.0.2.EL

and then
up2date kernel

thne lets see if it works.
0
 
Kerem ERSOYPresidentCommented:
I mean both rpm -evvl kernel-2.6.9-55.0.2.EL and rpm -evvl kernel-2.6.9-55.0.2.ELsmp
0
 
sengchoonAuthor Commented:
HI,
I've executed both rpm -evvl kernel-2.6.9-55.0.2.EL and rpm -evvl kernel-2.6.9-55.0.2.ELsmp as well as up2date kernel. After installation complete, I rebooted my PC and here are my latest grub.conf:
-------------------------------------
default=0
timeout=30
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-55.0.2.EL.img
title Red Hat Enterprise Linux AS (2.6.9-5.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.ELsmp ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd- 2.6.9-5.ELsmp.img
title Red Hat Enterprise Linux AS-up (2.6.9-5.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-5.EL ro root=LABEL=/ rhgb quiet
        initrd /boot/initrd-2.6.9-5.EL.img
title Vista Ultimate
        rootnoverify (hd0,0)
        chainloader +1
--------------------------------------------------
There's no SMP kernel so I only have 1 option so I selected "Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)"

this time, the error a bit different:
--------------------------------------------------
Decompressing Linux..done
Booting the kernel.
ide1: I/O resource 0x170-0x177 not free.
ide1: ports already in use, skipping probe
Red Hat nash version 4.2.1.10 starting
mkrootdev: label / not found
mount: error 2 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
--------------------------------------------------

After this error I boot back to the old kernel and I saw the up2date icon in red color so i executed and kernel-devel-2.6.9-55.0.2.EL,kernel-smp-2.6.9.55-0.2.EL were downloaded and installed. Now I reboot my PC and when I selected the latest kernel with ELsmp, the same error occur.
0
 
ezatonCommented:
Your problem, as I understand it, is as following:
1. Your sata controller is in compatibility mode, which has this effect:
* You emulate IDE disks, which might not work with newer kernels
2. Changing sata mode in the BIOS would be tricky, as it will require the following steps (which might be complicated to come back from):
* Adding the line "alias scsi_hostadapter XXXXX" where XXXXX is your disk device module (which will be hard to guess, but could be one of few devices)
* Rebuilding your initrd (rm /boot/initrd-2.6.9-55.0.2.ELsmp.img ; mkinitrd /boot/initrd-2.6.9-55.0.2.ELsmp.img 2.6.9-55.0.2)
* Rebooting and changing in the BIOS to enhanced SATA mode.

This is not a simple procedure. You need to know which module would fit your SATA device (please post the output of 'lspci -vv'), and in general, it's a tricky thing to do. However, your system now moves slowly, so this WILL enhance your system's performance.
0
 
Kerem ERSOYPresidentCommented:
Now that we're eliminated the module fault problem. I don't thin your modules are defective.

I think the problem is with your SATA drive. The new kernel ignores BIOS settings and tries to access it as a SATA drive while your old kernel treats it as an IDE drive. It seems that your BIOS is set-up in IDE compatiblity mode.

But if you change it you might need to reformat the drive including your Vista partition.

Will you tell me the contetnsts of your /etc/modprobe.conf. First of all make a backup copy and if it has a lie such as :
alias scsi_hostadapter ata_piix

Remove it and retry booting.
0
 
Kerem ERSOYPresidentCommented:
oops BTW Ezaton wrote about the same thing too. He was wise enough to suggest you to remove your /boot/initrd-2.6.9-55.0.2.ELsmp.img too before rebooting.
0
 
Kerem ERSOYPresidentCommented:
> In my motherboard's bios, I configure my IDE to "Compatible Mode" and set to P-ATA + S-ATA because > previously it was defaulted to "Enhance Mode" and I can't even boot into the old kernel. Do you need
> any further information in order for you to help me?

These issues are related to ACPI / APIC and currently solved in RHEL 5.0. It is possible to avoid in RHEL 4.4 and 4.5 too using boot time switches. But I generally prefer to use RedHAT 5.0
0
 
ezatonCommented:
I have seldom seen RHEL 4.3 or 4.4 fail to boot on such devices in enhanced mode.
0
 
ezatonCommented:
Correction - to install. When installed, it boots as well.
0
 
sengchoonAuthor Commented:
HI,
The result of lspci -vv:
---------------------------------------------------------------------------------------------------------------------------------
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
      Subsystem: ASUSTeK Computer Inc.: Unknown device 817a
      Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
      Latency: 0
      Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02) (prog-if 00 [VGA])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 817a
      Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin A routed to IRQ 169
      Region 0: Memory at dfe00000 (32-bit, non-prefetchable) [size=512K]
      Region 1: I/O ports at a400 [size=8]
      Region 2: Memory at e0000000 (32-bit, prefetchable) [size=256M]
      Region 3: Memory at dfe80000 (32-bit, non-prefetchable) [size=256K]
      Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
            Address: 00000000  Data: 0000
      Capabilities: [d0] Power Management version 2
            Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8249
      Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0, Cache Line Size 04
      Interrupt: pin A routed to IRQ 177
      Region 0: Memory at dfef8000 (64-bit, non-prefetchable) [size=16K]
      Capabilities: [50] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
      Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
            Address: 0000000000000000  Data: 0000
      Capabilities: [70] Express Unknown type IRQ 0
            Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
            Device: Latency L0s <64ns, L1 <1us
            Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
            Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
            Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
            Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
            Link: Latency L0s <64ns, L1 <1us
            Link: ASPM Disabled CommClk- ExtSynch-
            Link: Speed unknown, Width x0
      Capabilities: [100] Virtual Channel
      Capabilities: [130] Unknown (5)

00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01) (prog-if 00 [Normal decode])
      Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0, Cache Line Size 04
      Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
      I/O behind bridge: 0000e000-0000efff
      Secondary status: 66Mhz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
      BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
      Capabilities: [40] Express Root Port (Slot+) IRQ 0
            Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
            Device: Latency L0s unlimited, L1 unlimited
            Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
            Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
            Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
            Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 1
            Link: Latency L0s <256ns, L1 <4us
            Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
            Link: Speed 2.5Gb/s, Width x1
            Slot: AtnBtn- PwrCtrl- MRL- AtnInd- PwrInd- HotPlug+ Surpise+
            Slot: Number 1, PowerLimit 10.000000
            Slot: Enabled AtnBtn- PwrFlt- MRL- PresDet- CmdCplt- HPIrq-
            Slot: AttnInd Unknown, PwrInd Unknown, Power-
            Root: Correctable- Non-Fatal- Fatal- PME-
      Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
            Address: 00000000  Data: 0000
      Capabilities: [90] #0d [0000]
      Capabilities: [a0] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
      Capabilities: [100] Virtual Channel
      Capabilities: [180] Unknown (5)

00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01) (prog-if 00 [Normal decode])
      Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0, Cache Line Size 04
      Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
      I/O behind bridge: 0000d000-0000dfff
      Memory behind bridge: dff00000-dfffffff
      Secondary status: 66Mhz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
      BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
      Capabilities: [40] Express Root Port (Slot-) IRQ 0
            Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
            Device: Latency L0s unlimited, L1 unlimited
            Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
            Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
            Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
            Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 2
            Link: Latency L0s <256ns, L1 <4us
            Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
            Link: Speed 2.5Gb/s, Width x1
            Root: Correctable- Non-Fatal- Fatal- PME-
      Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
            Address: 00000000  Data: 0000
      Capabilities: [90] #0d [0000]
      Capabilities: [a0] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
      Capabilities: [100] Virtual Channel
      Capabilities: [180] Unknown (5)

00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin A routed to IRQ 193
      Region 4: I/O ports at a800 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin B routed to IRQ 185
      Region 4: I/O ports at b000 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin C routed to IRQ 201
      Region 4: I/O ports at b400 [size=32]

00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01) (prog-if 00 [UHCI])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin D routed to IRQ 177
      Region 4: I/O ports at b800 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin A routed to IRQ 193
      Region 0: Memory at dfeffc00 (32-bit, non-prefetchable) [size=1K]
      Capabilities: [50] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
      Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1) (prog-if 01 [Subtractive decode])
      Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
      I/O behind bridge: 0000c000-0000cfff
      Secondary status: 66Mhz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
      BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
      Capabilities: [50] #0d [0000]

00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Capabilities: [e0] Vendor Specific Information

00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01) (prog-if 80 [Master])
      Subsystem: ASUSTeK Computer Inc.: Unknown device 2601
      Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0
      Interrupt: pin B routed to IRQ 209
      Region 0: I/O ports at <unassigned>
      Region 1: I/O ports at <unassigned>
      Region 2: I/O ports at <unassigned>
      Region 3: I/O ports at <unassigned>
      Region 4: I/O ports at ffa0 [size=16]
      Capabilities: [70] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold-)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8179
      Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Interrupt: pin B routed to IRQ 209
      Region 4: I/O ports at 0400 [size=32]

02:00.0 Ethernet controller: Attansic Technology Corp.: Unknown device 2048 (rev a0)
      Subsystem: ASUSTeK Computer Inc.: Unknown device 8233
      Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
      Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
      Latency: 0, Cache Line Size 04
      Interrupt: pin A routed to IRQ 185
      Region 0: Memory at dffc0000 (64-bit, non-prefetchable) [size=256K]
      Expansion ROM at dffa0000 [disabled] [size=128K]
      Capabilities: [40] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
      Capabilities: [48] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
            Address: 0000000000000000  Data: 0000
      Capabilities: [58] Express Endpoint IRQ 0
            Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
            Device: Latency L0s <4us, L1 unlimited
            Device: AtnBtn+ AtnInd+ PwrInd+
            Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
            Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
            Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
            Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
            Link: Latency L0s unlimited, L1 unlimited
            Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
            Link: Speed 2.5Gb/s, Width x1
      Capabilities: [100] Advanced Error Reporting
---------------------------------------------------------------------------------------------------------------------------------
0
 
ezatonCommented:
Ok. The module is probably ata_piix. Add to your //etc/modprobe.conf the following line:
alias scsi_hostadapter ata_piix

And follow my suggestion as given before.

Good luck.
0
 
Kerem ERSOYPresidentCommented:
:)
In fact since you are alreadyy using your kernel in compatiblity mode (both in Vista and Linux) my suggestion would be to to remove the line:
alias scsi_hostadapter ata_piix
and delete your /boot/initrd-2.6.9-55.0.2.ELsmp.img
and reboot.

will you post the contents of your /etc/modprobe.conf here ?
0
 
Kerem ERSOYPresidentCommented:
I have another idea btw :)

- Edit your /boot/grub/device map. The content should be like that:
(hd0)           /dev/hda
and now modify it to read:
(hd0)           /dev/sda
Save and reboot and lets see what will happen

0
 
sengchoonAuthor Commented:
Hi,
Below is my /etc/modprobe.conf file content:
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias eth0 atl2
alias scsi_hostadapter ata_piix

Ezaton:
I've tried and my I am able to boot into the new kernel but only into console mode. After I log in, I fired "startx" and I am able to boot into Xwindows. Then I make changes on /etc/inittab to init:5 and reboot again and this time, after all driver loaded, when it try to boot Xwindows, it failed with "blank screen" and my keyboards light are blinking (same happened when kernel panic previously). THe same thing happen when I apply this step:
In console, typed "startx" and after succeeded, select "Action --> log off --> shutdown" and screen blank and nothing happen so I waited 5 mintes and the screen still blank.

KeremE:
"delete your /boot/initrd-2.6.9-55.0.2.ELsmp.img"
After selected 2.6.9-55.0.2.ELsmp:
--------------------------------
Error 15: File not found
---------------------------------

My /boot/grub/device map:
---------------------------------
(fd0)         /dev/fd0
(hd0)        /dev/hdc
---------------------------------

Should I change from /dev/hdc to /dev/sda?
0
 
Kerem ERSOYPresidentCommented:
Yeah please change /dev/hdc to /dev/sda (Depending on the slot it can be /dev/sdb  too) please try
0
 
ezatonCommented:
KeremE, I think that the problem is with the compatibility mode of the SATA controller (and the current kernel). I think that using Enhanced mode would solve it, and it seems to  - he was able to boot the system. Kernel panic when attempting to start GDM, but was able to boot the system with the new kernel, which is a good sign.

I would concentrate now on the X.

sengchoon:
Boot into run level 3 as you have done before, and then change into 5, using the command 'init 5'. Does your system panic?
0
 
sengchoonAuthor Commented:
Hi KeremE, I can't find any dev under /dev. If after I change it, will I have problem boot back the old kernel? This is  because right now when I use my original CD to boot linux rescue, it unable to detect my device and always prompt me to choose media.
0
 
sengchoonAuthor Commented:
Ezaton,
There's no problem during executing init 5 in console but after I've loaded into Xwindows, I go to "Action, Log off, Restart" and after while the screen blank off and my keyboard light are blinking again. I can't even see what is the error. Is there any error log in REDHAT which I can refer to? I tried to search /var/log and there're a lot of them. Not really know what is the purpose of each log (at least not now, will learn 1 by 1).
0
 
Kerem ERSOYPresidentCommented:
Ezaton: I understand that the problem is reatated to compatiblity mode too. But I think that since he has been using his system and he is also having a Vista installation on the same disk. I rather prefer to change the system back to work in compatiblity.

My last try was different to run it  in native mode.  Because if he succeeds to run the system in Native mode then he need to change his drive from  hdc to sda beacuse it is no more SATA

The log-off and restart issue is related to the ACPI not correctly handled by the OS. Do you have a chance to use RedHAT 5 CD instead for rescue mode instead?
0
 
Kerem ERSOYPresidentCommented:
> Hi KeremE, I can't find any dev under /dev. If after I change it, will I have problem boot back the old
> kernel? This is  because right now when I use my original CD to boot linux rescue, it unable to detect
> my device and always prompt me to choose media.

What do you mean by that? When you can't find any dev under /dev? When you boot with your old kernel ? When you boot from your install cd ?
If you mean install CD then it is normal becasue as your old kernel it thinks you are using an ide device.
The difference is your new kernel thinks it is SATA ignoring bios.

 
0
 
Kerem ERSOYPresidentCommented:
Eaton: We're both think that tihs is because Kernel Mode compatiblity thing. But if we disable compatiblity we need to either change /boot/grub/device.map or he'll reormat linux. oDo you have an ides about that ?To remove the compatiblty and changining the boot device ???
0
 
Kerem ERSOYPresidentCommented:
sengchoon: Even if it does not detect the drive we'll be abel you boot in rescue mode and mount it manually. Cus we already know that rescue mode still thinkis it is an ide device.
0
 
sengchoonAuthor Commented:
Nope. I do not have the RHEL5 CD. What I mean was if I changed the hdc to sda, and if the kernel panic and I'm without RHEL4.5 CD, will I able to boot back to old kernel after I made the changes to the /boot/grub/device.map?
0
 
Kerem ERSOYPresidentCommented:
Yeah. Linux Rescue just searches drives does not check files.
0
 
sengchoonAuthor Commented:
Hi KeremE:
Managed to change from hda to sda, manage to boot up..

Now, although i can boot into the new kernel, during boot, there are few failure:
-----------------------------------------------------------------------------------
Starting smartd:  [Failed]
Starting eth0: [Failed] device eth0 has different MAC address
-----------------------------------------------------------------------------------
My ethernet is atl2 and it was installed manually by me during using previous kernel.

Another issue, I still facing the Xwindows problem. Few scenario encounter the same problem:
1. change on /etc/inittab from 3 to 5
2. when the system boot init 3, typed "init 5" and managed to load Xwindows but when I restart computer, keyboard blinking (panic)
3. In Xwindows, I run terminal, typed "init 3", screen blank and keyboard blink.

Now, eventhough I can load new kernel, the biggest problem is Xwindows.

0
 
ezatonCommented:
This is a good sign.
First, you can boot. Second - smart doesn't work for SATA/SCSI disks, but only for IDE disks, so this is a good sign too.

Network - run 'ifconfig -a' and edit your file /etc/sysconfig/network-scripts/ifcfg-eth0 and replace the MAC address specified there with a the one obtained from iptables (it could be that the newer kernel can "see" the onboard network card).

Kernel panic - well, this is a new one. What VGA are you using?
Try adding (during boot time) to the grub command line (using 'e') the parameters 'noacpi' and let us know what happens.
0
 
sengchoonAuthor Commented:
ezaton, the Mac address in 'etc/sysconfig/network-scripts/ifcfg-eth0' (HWADDR) is having the same value with the result of ifconfig -a: 'eth0      Link encap:Ethernet  HWaddr'.
Secondly, if you see the result of lspci -vv which I've posted previously, the VGA is an integrated
-----------------------
'VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)'
-----------------------

Kernel panic - I've modify the /etc/grub/grub.conf to add pci=noacpi correct?
0
 
Kerem ERSOYPresidentCommented:
It seems that the new kernel has started to detect your ethernet interface now. As far as  understand you have another interface. The simplest method is too edit as ezaton says. don't forget to edit ifcfg-eth1 too.

For kernel panic I'll suggest you to use:
pci=noapic

I don't think it is necessary to disable acpi alltogether. Generally problems arise rrom APIC not ACPI itself.  I believe this should sove your kernel panic problem too. Generally sepaking these problems happen wehn acpi_sleep is in progress.
0
 
sengchoonAuthor Commented:
KeremE,
I've added pci=noapic but received error on not recognise this option. So I changed to "noapic" in kernel param and this time, no error instead, it can't boot the NASH. It just hang, nothing happen, keyboard not blinking.
0
 
Kerem ERSOYPresidentCommented:
ok plese reboot normally and post the dmesg :)
0
 
sengchoonAuthor Commented:
The result of dmesg:
--------------------------------------
APIC error on CPU0: 60(60)
APIC error on CPU1: 60(60)
--------------------------------------
0
 
Kerem ERSOYPresidentCommented:
Is it possible to disable APIC through your BIOS ?
0
 
sengchoonAuthor Commented:
KeremE,
After I've disabled the ACPI: APIC option in BIOS, LINUX cant event boot -up (hang, even NASH not load). I changed back to Enabled ACPI: APIC, the kernel can be started.Now i type "init 5", Xwindows started successfully, but I restart the system and the problem still the same (blank screen, keyboard blink)
0
 
Kerem ERSOYPresidentCommented:
No I meant isn some bios'es it is possible to disable ACPI or in some you can disable ACPI 2.0 this will help . I don't suggest to disable ACPI alltogether. I really don't understand when did you change tour default init setting from init 5?

I really did not understand waht do you mean by restart system ? Do you mean like rebooting without turning off ?? Or YOu mean You aca not switch to text mode ?
0
 
sengchoonAuthor Commented:
alright. here the situation. In my BIOS under power mgmt, there are 2 option.
1. ACPI 2.0 [ Enable ]
2. ACPI APIC [ Enable]
I disabled option 2, boot into 2.6.9-55.0.2.ELsmp, it start to load, then hang before loading NASH.

Restart system: After login in console mode (init 3 configured in /etc/inittab), I run "init 5'. Xwindows loading successfully although ethernet still not up. Then under the Xwindow, I selected "Action > Log Out, Restart the Computer" then the screen blank and keyboard light blink (same scenario when kernel panic).
0
 
ezatonCommented:
What VGA do you have? If it's an Intel, I have encountered it in the past, and there is no remedy for it. I can offer the following advice:
Do not restart your X. Never. The 2nd time around it will panic your computer.
Your computer hangs when starting at runlevel 5 because of the GUI display during startup. Remove the word "rhgb" from your grub config, and you will be fine.

About network - after your system boots - what is the output of 'ifconfig -a'? What are the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 and ifcfg-eth1 (if exists)?
0
 
sengchoonAuthor Commented:
I think my VGA is Intel since it is built-in.
"Do not restart your X." means? My current /etc/inittab is configured as 3 so it will reboot in console instead of GUI so do you mean after I've executed the command 'init 5' in the command, I shouldn't restart? Other than Restart, I've tried Log off/Shutdown and the problem still the same (panic with blank screen). It looks like whenever I wanted to switch back to console, it hang.

Below is the content of my /etc/sysconfig/network-scripts/ifcfg-eth0. In order for me to connect to the network, after login, everytime after login, I need to manually execute 'insmod /lib/modules/2.6.9-55.0.2.ELsmp/kernel/drivers/net/atl2/atl2.ko (by the way, my NIC is:
"Linux* Base Driver for the Attansic(R) L2 Fast Ethernet Adapter"). After this module has been executed, I can connect to my network but I don't want to do this everytime. Is there a way?

For SMARTD, do yo mean I need to change back the BIOS setting to "Compatible mode" or disable this feature under 'chkconfig"? Is there any impact/advantage for SMARTD to be started during system boot?

-----------------------------------------------------------------------------------------------------
[root@myRHEL4 ~]# ifconfig -a
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:51 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3722 (3.6 KiB)  TX bytes:3722 (3.6 KiB)

sit0      Link encap:IPv6-in-IPv4
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
-----------------------------------------------------------------------------------------------------


0
 
ezatonCommented:
Add to your /etc/modprobe.conf the following line:
alias eth0 atl2

Remove smart via chkconfig (you don't need it).

Edit your /boot/grub/menu.lst and remove the words "rhgb" from there. You will be able to start the system with runlevel 5, without the need for "startx". You would be able to stop your X, however, you will not be able to start it again until reboot.
0
 
Kerem ERSOYPresidentCommented:
Hi,

If you cjhange to compatiblity mode then you need to go back to hda which we don't want to happen. So please don't think about it.

With the BIOS. My general procedure is:
- Load Default values (in BIOS setup)
- After you loade defaults don't for get to set your Interfaces in SATA native mode etc.
- Then Disable ACPI 2.0
- Enable APIC

Reboot.
This procedure worked for me several times.
0
 
Kerem ERSOYPresidentCommented:
About Networking :
locate your /etc/sysconfig/networking/devices/ifcfg-eth0

there's a parameter in it:
ONBOOT=yes

change it to read

ONBOOT=no

This will set your netorking off at boot time.
0
 
Kerem ERSOYPresidentCommented:
I don't think mard is unnecessary for sata dirves. What  smartd does is when detecting a sector over hard disk is prone to error replace this sector with a working one over the drive. It also enables the OS to get the error log it is used both ide and and SCSI and SATA drives.
0
 
ezatonCommented:
KeremE: smart is a protocol (interface) for anticipation of disk failure, which is not being used in non-IDE disks. It allows reading of temperature, and several more goodies. Not working in SATA.

I would not change ONBOOT to no, but leave it as "yes". Make sure your alias exists in /etc/modprobe.conf and you should be fine.
0
 
Kerem ERSOYPresidentCommented:
Ezaton: smartd is utilised for any drive using ATA-3 or later. Apart from IDE and SATA, SCSI drives benefit from it too. It is utilised by libata module. This is an output from a healthy SATA system:
libata                     139369  1 ahci
scsi_mod              184057  5 sr_mod,sg,ahci,libata,sd_mod

As you clearly see libata is a part of even scsi. This is and excerpt from a sample configuration found in smartd.conf man page:
# Linux-specific: SATA disk using the libata
# driver.  This requires a 2.6.15 or greater
# kernel.  The device entry is SCSI but the
# underlying disk understands ATA SMART commands
  /dev/sda -a -d ata
0
 
Kerem ERSOYPresidentCommented:
Ezaton: you don't want him to disable instead take the module off ? What is the benefit i n this one when compared todisabling it ?
0
 
ezatonCommented:
I don't want him to take the module off, but to enable it. Just noticed it exists in /etc/modprobe.conf, so I think running 'depmod -a' is in place. Should solve the network driver issue.
0
 
sengchoonAuthor Commented:
Hi, the value "alias eth0 atl2" in already in the /etc/modprobe.conf. THe problem is whenever I booted the new kernel, this error message occur: "Starting eth0: [Failed] device eth0 has different MAC address" (previous kernel do not face this error).
This is 3rd party driver I download during my previous kernel. Filename: Atl2.ko. The instruction to install this is just to put this file into /lib/modules/<kernel_version>/kernel/driver/net and fire "insmode <filename>" and the module will be integrated into the kernel. After this point, I can see under the driver is "Active" and I can connect to my LAN/Internet. But I need to do this manually eventhough the value "alias eth0 atl2" in inside the /etc/modprobe.conf. But how to load this file whenener I booted the machine?
0
 
Kerem ERSOYPresidentCommented:
Hi,

Sometimes drivers add extra parameters in the form:
options atl2 <parameter>

such as irq settings etc which can not be fulfilled during boot time. So the driver can not be loadedautomatically while modprobe can load them. It this is the case watch your /etc/modprobe.conf for stale options like this. Also watching dmesg output would help to understand why the kernel can not load the dirver on boot time. It is may be it lacks a required parameter or may be becasue of a spuulied but not necessary paramater. So correct it and retry.
0
 
Kerem ERSOYPresidentCommented:
> Hi, the value "alias eth0 atl2" in already in the /etc/modprobe.conf. THe problem is whenever I booted
> the new kernel, this error message occur: "Starting eth0: [Failed] device eth0 has different MAC
> address" (previous kernel do not face this error).
he had already told what you had to do to avoid this error just edit /etc/sysconfig/networking/devices/ifcfg-eth0, locate the variable called HWADDR= remove the numbers to the right of this. This should correct the problem. MAy be your module is not loaded on bott time because of tihs.
0
 
sengchoonAuthor Commented:
Just for my personal understanding, is it means by setting HWADDR= (blank) will make the system to re-determine the MAC address automatically and assign to this variable on the next boot?
0
 
ezatonCommented:
It will not cause the system to redetermine, but to ignore the limitation (which is meant to prevent incorrect driver mapping).

Anyhow, run 'depmod -a' as well, as your system does not load the module, and it NEEDS to be inserted into the module autoloader tree.
0
 
sengchoonAuthor Commented:
ok. so the correct steps are:
To resolve eth0 atl2 issue:
- edit /etc/sysconfig/networking/devices/ifcfg-eth0
- REMOVE value assigned to HWADDR
- execute depmod -a
- reboot

To resolve XWindow issue:
Load Default values (in BIOS setup)
- Set Interfaces in SATA native mode etc.
- Then Disable ACPI 2.0
- Enable APIC
or
- modify /boot/grub/menu.lst (remove 'rhgb')
- modify /etc/inittab 'init' 3 to 'init 5'

Correct and forgive me if I get the wrong idea (sorry, I still newbie, still lot's of thing to learn from you all)
0
 
ezatonCommented:
I assume SATA is already set for native mode. I assume you have ACPI and APIC enabled (which is the status, as far as I understand it).
If the system fails to boot correctly without ACPI (and with APIC), restore the statue where both ACPI2.0 and APIC are enabled.
Other than that - the rest if just fine.
0
 
sengchoonAuthor Commented:
ok. Here I've done:
- edit /etc/sysconfig/networking/devices/ifcfg-eth0
- REMOVE value assigned to HWADDR
- execute depmod -a
- reboot
STATUS: Resolved. Network automatically up without error.

Xwindows:
In BIOS;
- Changed from ACPI 2.0 Support [Enabled] > [DIsabled]
- Change IDE Configuration from Enhance SATA > Compatible Mode
Save BIOS and boot, selected the 2.6.9-55.0.2.ELsmp:
Message:
ide1: I/O resource 0x170-0x177 not free.
ide1: ports already in use, skipping probe
Red Hat nash version 4.2.1.10 starting

Loaded successfully into Xwindows. Execute terminal, type shutdown -r 10, screen blank and keyboard light blinking (panic). So I tried another test case:

Change IDE from Compatible > Enhance
Disable ACPI 2.0, enable APIC, save reboot.
Selected the kernel and no error message and successfully booted into Xwindows. Restart Xwindows, blank screen. NOw my biggest problem is when I want to restart/log off/shutdown. None of them working and facing same problem.
0
 
ezatonCommented:
Edit your /boot/grub/menu.lst, as suggested by me and remove rhgb from there.
I don't think that the disabled ACPI has any effect on the system's panic.
0
 
sengchoonAuthor Commented:
sorry forgot to mention just now. I've actually removed the rhgb as well but the same problem still occur:

menu.lst:
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.ELsmp ro root=LABEL=/ quiet
        initrd /boot/initrd-2.6.9-55.0.2.ELsmp.img
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.EL ro root=LABEL=/ quiet
        initrd /boot/initrd-2.6.9-55.0.2.EL.img
0
 
Kerem ERSOYPresidentCommented:
I really believe that this is really an ACPI/APIC problem. I see that you did not apply my instructions completeley. As you would remember I had suggested that you reset to bios defaults dirst. Then it is obvious that you need Acpi 2.0 to disable. When you set your ide to compatiblity mode your bios maps your SATA drives to IDE hence you're getting these IDE busy errors. So please avoid using this setting.

It seems that changing yor grub/devie.map already solvd the boot problem for good. Lets focus on theX porblem now. Please do the final settings for now Acpi 2.0 disabled Apic enabled Mode Enhanced SATA.
0
 
sengchoonAuthor Commented:
hi KeremE, Apologise for the wrong point I'm getting.
Do I need to make any modification to the grub.conf before resetting the bios, etc? My grub.conf
menu.lst as below. Shoudl I add pci=noapic or just remain as it is currently?

title Red Hat Enterprise Linux AS (2.6.9-55.0.2.ELsmp)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.ELsmp ro root=LABEL=/ quiet
        initrd /boot/initrd-2.6.9-55.0.2.ELsmp.img
title Red Hat Enterprise Linux AS (2.6.9-55.0.2.EL)
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.9-55.0.2.EL ro root=LABEL=/ quiet
        initrd /boot/initrd-2.6.9-55.0.2.EL.img


0
 
ezatonCommented:
None, as it seems to me. Except that you need to verify that your /boot/grub/device.map includes /dev/sda as hd0.
0
 
sengchoonAuthor Commented:
I perform the below steps but still when comes to restart/log out/shutdown from X kernel panic:
- Load Bios to Default
- Power Mgmt: Acpi 2.0 [disabled] ,Apic [enabled]
- IDE Mode [Enhanced Mode] [SATA].

Under SATA mode, I tried different option (SATA+PATA , SATA) and all still the same.
Below are the issues solved so far :)
- No error msg during system bootup (ide1 issue solved),
- removed 'rhgb' (init 5 solved),  
- add into /etc/modprobe.conf: alias eth0 alt2 (resolve ethernet issue)
- modify /boot/grub/grub.conf: hda --> sda (forgot this resolve which issue :~) )
- modify /etc/modprobe.conf: alias scsi_hostadapter ata_piix (resolve new kernel able to recognise "Enhance Mode" for SATA

Pending for resolution/advice.
- After loaded into X window, cannot shutdown/log off/restart: Blank Screen, Keyboard light blinking, panic. Tried use other IDs to perform the same but issue still occur.
0
 
ezatonCommented:
I have encountered it with some Asus boards (don't remember which). As far as I know, this is unresolvable and has to do with the utilization of the Intel device on the Asus boards. You can replace in /etc/X11/xorg.conf the line saying something like:
Driver i810
(could be other word starting with i, like i915 or the likes) to
Driver vesa
which will result with a lower display performance, but will solve the issue at hand.
0
 
Kerem ERSOYPresidentCommented:
Under SATA mode, I tried different option (SATA+PATA , SATA) and all still the same.
Below are the issues solved so far :)
- No error msg during system bootup (ide1 issue solved),  (This is because Compatiblity mode.)
- removed 'rhgb' (init 5 solved),  
- add into /etc/modprobe.conf: alias eth0 alt2 (resolve ethernet issue)
- modify /boot/grub/grub.conf: hda --> sda (forgot this resolve which issue :~) ) (booting allthogether :) remember new kernel detected your disk SATa (hence sda instead of hda)
- modify /etc/modprobe.conf: alias scsi_hostadapter ata_piix (resolve new kernel able to recognise "Enhance Mode" for SATA
 
will you post your xorg.conf herE ?
0
 
sengchoonAuthor Commented:
I'll post it tonight when I reach home. By the way, my /etc/X11/xorg.conf driver is i810. So I just use editor to change to Vesa?
0
 
sengchoonAuthor Commented:
My /etc/X11/xorg.conf

--------------------------------------------------------------------------------------------------------------------------
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "LCD Panel 1280x1024"
        HorizSync    31.5 - 67.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        VendorName  "Videocard vendor"
        BoardName   "Intel 945"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection
--------------------------------------------------------------------------------------------------------------------------
0
 
ezatonCommented:
Replace
Driver "i810"
with
Driver "vesa"
and restart (panic) the computer. It should work then.
0
 
Kerem ERSOYPresidentCommented:
I have seen this before please add the lines indicated below. In the end your i810 section should read this way:

Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        Option "DisplayInfo" "FALSE"
        VendorName  "Videocard vendor"
        BoardName   "Intel 945"
EndSection

and please retry.
0
 
ezatonCommented:
KeremE: I have also seen this before. As far as I remember, the only way to solve it was to avoid using i810 driver, but the generic vesa.
0
 
Kerem ERSOYPresidentCommented:
Ezaton: I vhave seen this option solved the issue. But it is possible to solve it using vesa too. But it is better to use the native driver if possible. as you old earlier vesa setting has the performance impact.
0
 
sengchoonAuthor Commented:
hi all, below are the results:
1:---------------------------------------------
Section "Device"
        Identifier  "Videocard0"
        Driver      "i810"
        Option "DisplayInfo" "FALSE"
        VendorName  "Videocard vendor"
        BoardName   "Intel 945"
EndSection
---------------------------------------------
Result: Still panic


2:---------------------------------------------
Driver "i810"
with
Driver "vesa"
---------------------------------------------
Result: Rebooted successfully.
0
 
ezatonCommented:
Good.
0
 
sengchoonAuthor Commented:
so changing to "vesa" is the final solution?
0
 
ezatonCommented:
I would try an update the BIOS and try that again, or add an external VGA card (NVidia is known to behave better under Linux), but there is no other magical solution. If it works, it works. It works somewhat slower on a GUI, but the bug you have encountered causes kernel panic when using the so called "faster" driver. Except for my suggestions here, I see no other way of avoiding the problem. Sorry.
0
 
sengchoonAuthor Commented:
Thanks a lot for the help so far. Now I am able to use the new kernel with my Oracle 10g R2 :D
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 33
  • 32
  • 20
Tackle projects and never again get stuck behind a technical roadblock.
Join Now