Network Browsing on a Windows 2003 Server running RAS (multi-homed)

I have a Windows 2003 server SP2 running RAS and Veritas Backup Exec (which requires netbios for selections from remote machines.  Currently, I cannot browse the network from this server and therefore cannot make remote selections from within Backup Exec.  I've read that running netbios should not be done on a multi-homed server, but can't find a way around this...

Jewell_ITAsked:
Who is Participating?
 
cj_1969Commented:
netBIOS has not been actively used and programmed for in years.
Backup Exec is probably the most widely used backup solution on the Windows platform ... that said ... there should be no dependancy on NetBIOS.  As long as you have TCP/IP running and a WINS and DNS server then you should be fine.  You will need to make sure that the "remote" machines are updating DNS and WINS so that the machine names can be resolved.

FYI ... NetBIOS is not a routable protocol so the reference to "remote" selections is not clear ... does this just mean a machine other than the one that Backup Exec is running on?  Or do you mean (are you trying to) backing up machines on other network segments ... like a remote site or another LAN segment?

Chekc the Backup Exec documentation ... there is probably a displaimer on there about "NetBIOS over TCP/IP" being enabled ... which is pretty much the standard these days.
0
 
Jewell_ITAuthor Commented:
To state the issue differently, I cannot browse the network (due to multi-homing - 1 NIC and RAS) from the server running Veritas Backup Exec and therefore cannot make remote selections for backup (same lan segment - just machines other than the one running Backup Exec)  -

The article referenced by haim96 has solutions for multi-homing/browsing issue, but does not explain how to make it work for my Windows 2003 server running RAS which is also my only option for my PDC.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
SysExpertCommented:
You may have to try using UNC notation if browsing does not work.

ALso, BE may not run well on multihomed machines.

did you check the Veritas site or contact them for help ?


I hope this helps !
0
 
Jewell_ITAuthor Commented:
I just want to find a way to make browsing work...

This server is the only server available to be the PDC  - which means I can find no way to prevent it from becoming the master browser.  The master browser does not work since the server is multi-homed with one NIC and RAS running. Actually browsing does work on the server until someone logs into the VPN on the RAS.  Surely there is somekind of work around here!

 
0
 
haim96Commented:
did you try to enable "'netbios over TCP/IP" ?
0
 
ocon827679Connect With a Mentor Commented:
If you look at the original article that haim96 posted you will see that it isn't going to work since you have a multi-homed PDC.  The PDC is the domain master browser and collects the browse lists from all masters within the network.  Unfortunately it is done on a controller basis which is why you aren't going to see the proper list all of the time.  Can you move the PDC emulator role to another DC?  
0
 
Jewell_ITAuthor Commented:
netbios over TCP/IP is enabled.

ocon827679 - that wasn't what I wanted to hear...  In any case, I have managed to put the PDC emulator role to another server.  However, this server continues to become the master browser eventhough I set the following reg keys:

IsDomainMaster  No
MaintainServerList  No

Is there something else that I'm missing?
0
 
ocon827679Commented:
did you reboot?

Sorry to hear that you didn't want to hear it!  
0
 
honmapogConnect With a Mentor Commented:
If you can't get it to work, you can add your remote servers manually - without browsing - by using the "User Defined Selections"
0
 
cj_1969Commented:
Try this ...
To prevent multihomed Microsoft Windows NT servers from becoming browser servers, follow these steps: 1. Click Start, point to Settings, click Control Panel, and then double-click Services.
2. Click Computer Browser, click Properties, and then click Manual.
3. Click OK, click Close, and then restart the computer.
Or, use Registry Editor (Regedt32.exe) to edit the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\MaintainServerList Change the value of this subkey to false, quit Registry Editor, and then restart your computer.

Note In Windows 2000, instead of the value false, use the value no. To encourage singlehomed computers to become the browser servers, use Registry Editor (Regedt32.exe) to edit the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters\IsDomainMaster Change the value of this subkey to yes, quit Registry Editor, and then restart your computer.

ALSO ...

You CAN make a multi-homed machine work as a master browser if you disable the appropriate networking services on all but one interface ... per the article that haim96 referenced ...
How to browse with a multihomed PDC
The domain master browser service properly binds to only one network interface. The PDC serves the role of the domain master browser. We suggest that your PDC is not multihomed.

If your PDC is multihomed because it serves as a router, and you cannot promote a singlehomed backup domain controller (BDC) to PDC, you can try the following technique to work around this problem.

Unbind the WINS Client (TCP/IP) interface from all your adaptors except for one. This will also unbind the NetBIOS, Workstation, and Server interfaces from this card. We recommend that these bindings remain on the adaptor that is on the busiest segment. Although the WINS Client (TCP/IP) interface is unbound from the other adaptors, there will still be connectivity to the PDC from the other segments. The TCP/IP Protocol interface is left bound, which will be able to route the requests to the bound interface. After unbinding the additional adaptors, you should make sure that WINS and any LMHosts files do not refer to the unbound adapters.

To unbind the WINS Client (TCP/IP) interface, follow these steps: 1. In Control Panel, double-click Network.
2. Click the Bindings tab.  
3. In the Show Bindings For box, select All Adapters.
4. Expand all the adaptors.
5. Select WINS Client (TCP/IP), and then click Disable

0
 
haim96Commented:
cj_1969, it's copy/ paste from doc i had link in the first post.  :)
as you can see JEWELL didn't found it very useful...
0
 
cj_1969Commented:
I know its a copy and paste ... maybe not that obvious but I didput in ... "per the article that haim96 referenced ".

I see what was written but I don't know that all of this was tried.  The responses indicate that the article was looked at but I don't think that these steps were done.  Based onthe symptoms and the results that these steps produce ... this SHOULD resolve the problem.
0
 
haim96Commented:
i think that honmapog have good point with adding server menual...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.