Command line mutt not working

Posted on 2007-08-09
Last Modified: 2013-12-18
We are using SuSE linux 9.0 and want to use command line mutt like the following:
echo " blah blah " |mutt -s "blah blah"

Now this is working perfectly fine on some of our servers, but when I recently tried it on a new one(in another network) it is not working.

I have put the appropriate entry in the relayhost entry in the
relayhost = []

I tested the smtp server above with telnet, and everything seems to be in order there as well. However when I run the mutt command, I get the following messages in /var/log/mail

Aug  9 06:40:03  postfix/smtp[1406]: smtp_parse_destination: [] smtp
Aug  9 06:40:03 somlzr postfix/smtp[1406]: fatal: unknown service: smtp/tcp
Aug  9 06:40:04 somlzr postfix/qmgr[1116]: warning: premature end-of-input on private/smtp socket while reading input attribute name
Aug  9 06:40:04 somlzr postfix/qmgr[1116]: warning: private/smtp socket: malformed response
Aug  9 06:40:04 somlzr postfix/qmgr[1116]: warning: transport smtp failure -- see a previous warning/fatal/panic logfile record for the problem description
Aug  9 06:40:04 somlzr postfix/master[1109]: warning: process /usr/lib/postfix/smtp pid 1406 exit status 1
Aug  9 06:40:04 somlzr postfix/master[1109]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling

Could you let me know what needs to be done or verified in order for this to work.

many thanks,

Question by:sandeep_th
    LVL 7

    Expert Comment

    Look in /etc/services. Those two lines should be present in this file. If not (or the file is not present at all) add them. This should solve your problem.

    smtp            25/tcp          mail            # Simple Mail Transfer
    smtp            25/udp

    Author Comment

    These lines are there already :-(
    LVL 6

    Accepted Solution


    probably you are running chrooted postfix process, so you should check if this file : /var/spool/postfix/etc/services  contains required lines.


    LVL 1

    Expert Comment

    Forced accept.

    EE Admin

    Featured Post

    Highfive Gives IT Their Time Back

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    Microsoft Outlook is not just an email client but it is full featured Personal Information Manager. But sometimes Outlook gets disconnected and you simply can’t access it. What steps can you perform before calling IT support? In this article we will…
    In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
    Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now