Cannot debug ASP.net using VWD 2008 Express Edition

ChetOS82
ChetOS82 used Ask the Experts™
on
When I run the website in the debugger, I get the following error:

"Unable to attach to application 'WebDev.WebServer.EXE' (PID: 3712) using 'MACHINE'.  Unmanaged debugging is not available."

I was running Visual Web Developer 'Orcas' Express Edition.  I installed Visual Studio 2008 Beta without uninstalling anything first (stupid, I know).  Everything still worked perfect after that.  I saw that there was a new 2008 Beta 1 express edition, so I installed that.  It would not debug.  I then uninstalled it, uninstalled the Orcas edition, and reinstalled 2008 Beta 1.

I have not (nor do I really want to) uninstalled VS 2008.

I probably just changed a setting in VS 2008 (which had more options) and that setting came across to the express edition, and it doesn't support it.  I have had something like this happen before and I just needed to load VS and change it, then reload the Express Edition.

I don't want to use VS to build websites because the windows and layouts I used in AppDev are not conducive to WebDev.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
My hunch was right.  I had turned on "Native code" debugging in VS2008, when I loaded the project in VWD 2008 Express (which doesn't support native debugging) it threw the error.

To fix:
Close the express edition.
Load the website in VS2008
Go to project properties (right-click on project name and click Properties), and click on "Start Options"
Uncheck "Native code" (at the bottom)
Save and close VS2008
Open the project in the express edition... it should debug properly now.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial