[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 744
  • Last Modified:

"Failed to send the spooled mail file, D:\CFUSION\Mail\spool\51D.cfmail. SMTP server replied ""5.5.4 Invalid Address"" Moved file to D:\CFUSION\Mail\undelivr\64E.c

Hi,

Till last 2 days my coldfusion application was working fine sending emails but suddenly
it stopped sending emails all the mail sits in the spool directory and are never sent out.
I have to manually restart the CF webserver to push the mail out.

1. I have checked Cold Fusion MX Administrators :
server connection option -> sucessful
2. Telnet to the SMTP server -> sucessful

Webserver: Windows 2003
Cold Fusion: 5.0
Exchange: 2003

I checked the mail.log and found this error as it does not give any errors on the page.
"Error","148","08/08/07","14:33:30",,"Failed to send the spooled mail file, D:\CFUSION\Mail\spool\51D.cfmail. SMTP server replied ""5.5.4 Invalid Address"" Moved file to D:\CFUSION\Mail\undelivr\64E.cfmail."

Your help would be appreciated as I am at production environment and my clients are
pressurizing me for a quick fix.

Thanks
Aasit.
0
Aasitpatel
Asked:
Aasitpatel
  • 4
  • 2
1 Solution
 
Scott BennettCommented:
Are you sure the address in your to and from fields are valid email addresses? if they are not both valid you my get this error.

Also if you are formatting your email addresses like: "John Smith <smith@domain.co.uk>" try just using the email address.

This person had the same problem:

http://blog.pixl8.co.uk/index.cfm/2007/2/1/BlueDragonNET-cfmail--Windows-2003-SMTP-server-501-Invalid-Address-problem
0
 
AasitpatelAuthor Commented:
I think I fixed the problem by applying Microsoft Patch. Will monitor for 2 days and let you know
as of now the emails are going through after applying the patch.

Thanks for your answer
Aasit
0
 
AasitpatelAuthor Commented:
I think I was wrong on that the problem is this so the mails were not going through:

Hello,

I have a cold fusion web application running for many clients including our own company on:
1. HP
2. Windows 2003

Everything was working normal website was up and running.Clients would connect remotely
without any problems.

1. I upgraded the OS to Windows 2003 SP2.
2. Extended the HP partition.
3. Added more ram.

Problem:
When my clients try to access the website remotely sometimes not always that is after every
2 hours or so the they get page unavailable problem.I re-start the webserver and the website
works for another 1 hr or so ...

This has been going on for 5 days now can somebody please advice me on how to handle this
problem.

I tried changing the netcard and even changed the BIOS of my server but nothing worked.
Strangely staff from my company can access the website without any problems.I assume
that is coz they are members of my Active directory.

Waiting for some help.

Thanks
Aasit.


0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Scott BennettCommented:
if people on your internal network can access it fine but people outside your network cannot then there is most likely a networking  or DNS issue. Have you change any of your router or firewall configurations or your IP address, or have you updated your DNS records for this site lateley? Try opening a comand prompt from a computer outsite your network and run  "tracert www.yoursite.com" to see where the connection is breaking.
0
 
AasitpatelAuthor Commented:
As of now I read this link so am going to try this too:

http://technet2.microsoft.com/windowsserver/en/library/ed5382af-e819-4d33-ace0-225d31b7ab751033.mspx?mfr=true

1. Uninstall Windows 2003 SP2
2. Upgrade ADAM to SP1
3. Install Windows 2003 SP2

And will see if that solves the problem.I will also try your suggestion to trace the issue.

Will let you know the result.

Thanks
Aasit.

0
 
AasitpatelAuthor Commented:
This issue got resolved by itself after we upgrade our ColdFusion server from 5.0 to 8.0. thanks to all of you for spending your time on this issue.
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now