• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3751
  • Last Modified:

error while loading shared libraries: libssl.so.6

Hi Experts,

Stupidly I ignored the warnings and removed openssl use rpm -e --no-deps openssl.x.x.x

After that, I can't do anything. RPM, WGET, SSH

It displays an error "error while loading shared libraries: libssl.so.6".

Even if I were to install openssl from the tarball, it still don't work.

Anyone have any bright ideas?
0
archerlogic
Asked:
archerlogic
  • 2
1 Solution
 
ravenplCommented:
Get login to another similar system(fedora or redhat), and copy
/lib/libssl*
/lib/libcrypto*
make sure along these files are *.so.6
then install proper openssl again.
0
 
archerlogicAuthor Commented:
I got a "segmentation error" now, after copying those files.
0
 
ravenplCommented:
Copy from similar distribution. If You run RH, copy from another RH, if You run FC, copy from another FC.
0
 
Computer101Commented:
Forced accept.

Computer101
EE Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now