Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 166
  • Last Modified:

Can't view websites running on IIS from outwith office on Windows 2003 server

Hi
I've a web server running windows 2003. On this IIS is running with a website called "TestSite2", with a page called Index.htm.
I can access the files from within building intranet but not outside the building.  The website port is set to 7001.

Here's how things are setup.

PC with website hosted/IIS Setup:     http://192.168.1.126/
Visiting                               http://192.168.1.126/TestSite2/Index.htm 
from any PC in building works fine.  

Visiting      
xx.xx.xx.xx/TestSite2/Index.htm
OR
xx.xx.xx.xx:7001/TestSite2/Index.htm  
doesn't work outside building.

"The page cannot be found" error.

Router is set to accept all traffic on port 7001 and direct to 192.168.1.126.   SonicWall is running but port 7001 is opened.  

If I put TestSite2 on our Terminal Server, it can be accessed from outwith building on that but that's no use  - must be on the  192.168.1.126 PC.  IIS doesn't have any security on it. The only tick box is "Allow anonymous access" (no windows authentication etc ticked)

Not sure what's up.  Don't think its the router as it seems configured right.

Ideas, please - thank-you!
0
rwallacej
Asked:
rwallacej
  • 11
  • 5
2 Solutions
 
SagiEDocCommented:
Your firewall rules seem fine however when you say "outside the building" are you refering to people accessing the site via the Internet? If so their firewall may not be allowing any traffic on port 7001.
0
 
rwallacejAuthor Commented:
"outside the building"
indeed I mean people accessing from internet
0
 
rwallacejAuthor Commented:
I have just tried setting my laptop firewall settings to allow traffic in port 7001 but no joy accessing site
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
rwallacejAuthor Commented:
I don't know if this helps but

http://x.x.x.x/TestSite/Index.html 

gives "The page cannot be found"

and

http://x.x.x.x:7001/TestSite/Index.html

gives "Internet Explorer cannot display the webpage"
0
 
SagiEDocCommented:
hangon a second the ip that goes in x.x.x.x is that ip address a public ip address?
0
 
rwallacejAuthor Commented:
yes
we use x.x.x.x/exchange or x.x.x.x:80/exchange  to get our emails
0
 
rwallacejAuthor Commented:
at least I think it must be public if we can access emails anywhere in world ?
0
 
SagiEDocCommented:
The test site you added is on the same machine as the exchange web interface?
Is the site setup to allow annonymous? If so check the permissions on the website, right click and go to permissions and make sure the annon account has permissions to the folder.
0
 
SagiEDocCommented:
Check the seetings of the exchange webfolders site, everything in your new site should mach exactly the only diffrence should be the port number, home directory and users who have access.
0
 
rwallacejAuthor Commented:
IIS site settings:

for authentication methods "Enable anonymous access" is ticked. User name is IUSR_....
"Integrtaed windows auth", "digest authentication", "basic authentication" and ".net authentication" are all unchecked

for IP Address and domain retrictions , "Granted access" is checked, and no exceptions are there.

under "Home directory", "A directory located on this computer" is checked
local path is C:\inetpub\wwwroot\TestSite
with "Read" ticked

no filters on ISAPI filters

Windows explorer settings:
c:\inetpub\wwwroot\TestSite
security :  Internet Guest Account is set to "Read and exectute, List folder contents, read"

no idea what's up!
0
 
rwallacejAuthor Commented:
When I visit x.x.x.x, I get the "This site is under construction" message. This is IIS running on terminal server.
Does the Terminal server IIS settings need to be configured, or is it just the router since the 192.168.126 is connected to router.
0
 
brwwigginsCommented:
what happens if you go to http://x.x.x.x:7001 internally? does the website answer?

Unless you do a port translation, the firewall will forward the outside traffic on port 7001 and IIS must be configured to listen on that port in addition to port 80 for that website.
0
 
rwallacejAuthor Commented:
visiting  http://x.x.x.x:7001 internally  doesn't work;  I need to use 192.168..../TestSite

IIS on the server hosting the site is listening on port 7001. This is a different server to terminal server

Home for weekend, need to leave til Monday now....
0
 
SagiEDocCommented:
You do not need to set IIS on the terminal server. To sum up:
If you go to  http://x.x.x.x:7001 it does not work, and if you go to http://x.x.x.x:7001/testsite it does. Nothing works from external?
If that is the case it is working fine internally. If you wanted http://sitename to work you would need to add to DNS. You do not have the ability to update external DNS so you would need to use http://www.webmailaddy.com:7001
0
 
rwallacejAuthor Commented:
If I go to to http://x.x.x.x:7001/testsite it doesn't work externally out of office.

I have a fixed IP address of x.x.x.x.
I thought I could host pages in the office with IIS running, accessible from the internet with this IP address and a port number?

Thanks
0
 
rwallacejAuthor Commented:
turned out this was SonicWall. It wasn't installed on PC hosting site, so router was blocking items on their way out to internet.
installing SonicWall software on PC hosting site fixed things
0
 
rwallacejAuthor Commented:
thanks to you both for your contributions
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

  • 11
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now